Incomplete page loads with SSL

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
agaveville
Registered User
Posts: 5
Joined: Fri Nov 13, 2020 6:19 pm

Incomplete page loads with SSL

Post by agaveville »

No clue what the issue here is. I have an image-intensive forum that works beautifully when loaded as http, but seems unable to manage the load when https is called. Under https, pages load fine, but once page load exceed roughly 50 images (about 200k each), only the first 50 or so load. Using Hostmonster's free AutoSSL.
agaveville
Registered User
Posts: 5
Joined: Fri Nov 13, 2020 6:19 pm

Re: Incomplete page loads with SSL

Post by agaveville »

Anybody?

This is from the error log:
[Sat Nov 21 11:04:14.142093 2020] [:error] [pid 384434:tid 22386776520448] [client 68.98.3.16:0] Caused by SystemException in API_Linux.cpp:458: execve() for program "/opt/cpanel/ea-php72/root/usr/bin/php-cgi" failed: Resource temporarily unavailable, referer: https://www.agaveville.org/viewtopic.php?f=3&t=4037
User avatar
david63
Registered User
Posts: 18580
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Incomplete page loads with SSL

Post by david63 »

Loads exceptionally fast for me - I cannot see any problem
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10416
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Incomplete page loads with SSL

Post by Noxwizard »

agaveville wrote:
Wed Nov 18, 2020 10:53 pm
but once page load exceed roughly 50 images ...
More specifically, these images are attachments. Since the attachments are rendered through PHP which needs to load them from disk and re-display them, you are probably exceeding a CPU limit imposed by your host. They enforce that limit by preventing you from running more processes until your usage goes down.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.
agaveville
Registered User
Posts: 5
Joined: Fri Nov 13, 2020 6:19 pm

Re: Incomplete page loads with SSL

Post by agaveville »

david63 wrote:
Sat Nov 21, 2020 6:53 pm
Loads exceptionally fast for me - I cannot see any problem
The problem is that many of the images fail to load.
agaveville
Registered User
Posts: 5
Joined: Fri Nov 13, 2020 6:19 pm

Re: Incomplete page loads with SSL

Post by agaveville »

Noxwizard wrote:
Sat Nov 21, 2020 7:10 pm
agaveville wrote:
Wed Nov 18, 2020 10:53 pm
but once page load exceed roughly 50 images ...
More specifically, these images are attachments. Since the attachments are rendered through PHP which needs to load them from disk and re-display them, you are probably exceeding a CPU limit imposed by your host. They enforce that limit by preventing you from running more processes until your usage goes down.
Thanks, that makes sense.

Since the site works perfectly WITHOUT SSL, it isn't the biggest deal ever. Just sick of all the security warnings, which may be frightening off some potential users.
Post Reply

Return to “[3.3.x] Support Forum”