WAMP for XP & Vista

Discussion of non-phpBB related topics with other phpBB.com users.
Forum rules
General Discussion is a bonus forum for discussion of non-phpBB related topics with other phpBB.com users. All site rules apply.
Post Reply
User avatar
TheSnake
Registered User
Posts: 483
Joined: Wed Aug 09, 2006 10:36 pm
Location: Staffordshire, England, UK
Contact:

WAMP for XP & Vista

Post by TheSnake » Sun Jun 06, 2010 4:16 pm

I recently installed phpBB 3.0.7-PL1 & then was notified the current version of PHP I have (5.1.2) is old & need to update it for any future versions of phpBB.

Looking at the website where I got my WAMP from (Apache2Triad), it is no longer being updated, so I had the option of either trying to reconfiger new installation into it of PHP, or get a newed WAMP Server. My problem has always been that Apache2Triad won't run on my Laptop (Vista), no matter how many times I try following the guides on their website or other guides found via Google. As soon as the computer is rebooted the next time, A2T will not start, Elevation of Process is required, rarely but on a couple of occasions I've managed to get it to work, until next bootup. It's been ok on XP however.

What I'm looking for is recommendations of any decent WAMP Servers that work on XP & Vista, that don't suck. Over the last week, I've tried various WAMP servers, all seem to have issues: phpMyAdmin has Link errors, WAMP won't load at all, Needs Elevation, but no amount of changing settings gets to work, etc...

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: WAMP for XP & Vista

Post by EXreaction » Sun Jun 06, 2010 4:45 pm


User avatar
TheSnake
Registered User
Posts: 483
Joined: Wed Aug 09, 2006 10:36 pm
Location: Staffordshire, England, UK
Contact:

Re: WAMP for XP & Vista

Post by TheSnake » Sun Jun 06, 2010 5:24 pm

Thanks for the links, but I'm looking to find any others.

I've tried WampServer, they have a Link tables issue, as well as the phpMyAdmin ain't working right, the drop-down menu for choosing Databases don't work.

I haven't tried XAMPP yet, as they have already stated on their website that there are issues with running XAMPP on Vista.

Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: WAMP for XP & Vista

Post by Desdenova » Sun Jun 06, 2010 6:40 pm

I'm running Vista, and haven't hit any issues yet with XAMPP. This is over a year that I've been using it, FYI.

Try running it, works well enough.

User avatar
TheSnake
Registered User
Posts: 483
Joined: Wed Aug 09, 2006 10:36 pm
Location: Staffordshire, England, UK
Contact:

Re: WAMP for XP & Vista

Post by TheSnake » Sun Jun 06, 2010 8:01 pm

I've just installed XAMPP on my main computer (Windows XP Home, SP3) so far, it looks ok, the issue I previously had in phpMyAdmin with WampServer isn't there (linked tables being disabled), but there is the oddity about the Drop-down menu on the Left Frame for choosing a Database, it's just a list of links.

Previous jobs in offices using phpMyAdmin had the Drop-down Menu, as well as in Apache2Triad, is there a reason that isn't working in XAMPP/WampServer or is it just something available to certain phpMyAdmin installations/configurations?

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Re: WAMP for XP & Vista

Post by SamG » Sun Jun 06, 2010 10:00 pm

Please note that General Discussion's rules prohibit support-type questions. Discussion of XAMPP and similar products is of broad interest to the phpBB community, but questions about specific functionality will need to be addressed elsewhere.
We should talk less, and say more.

Kim_Possible
Registered User
Posts: 1343
Joined: Sun Sep 21, 2008 3:57 pm

Re: WAMP for XP & Vista

Post by Kim_Possible » Sun Jun 06, 2010 11:06 pm

For what it's worth I have never had any trouble with WampServer on XP or Vista.

Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: WAMP for XP & Vista

Post by Desdenova » Sun Jun 06, 2010 11:14 pm

TheSnake wrote:Previous jobs in offices using phpMyAdmin had the Drop-down Menu, as well as in Apache2Triad, is there a reason that isn't working in XAMPP/WampServer or is it just something available to certain phpMyAdmin installations/configurations?
Probably.

Thing is, since you're using XAMPP on a local machine, you probably don't want to bother with phpMyAdmin in the first place (it is pretty slow, sadly.)

Try either Navicat Lite for DB management, or MySQL GUI tools (which are EOL, but there is no stable replacement currently available), both work pretty well, though I prefer the MySQL GUI tools myself. :)

User avatar
TheSnake
Registered User
Posts: 483
Joined: Wed Aug 09, 2006 10:36 pm
Location: Staffordshire, England, UK
Contact:

Re: WAMP for XP & Vista

Post by TheSnake » Mon Jun 07, 2010 12:45 am

Desdenova wrote:
TheSnake wrote:Previous jobs in offices using phpMyAdmin had the Drop-down Menu, as well as in Apache2Triad, is there a reason that isn't working in XAMPP/WampServer or is it just something available to certain phpMyAdmin installations/configurations?
Probably.

Thing is, since you're using XAMPP on a local machine, you probably don't want to bother with phpMyAdmin in the first place (it is pretty slow, sadly.)

Try either Navicat Lite for DB management, or MySQL GUI tools (which are EOL, but there is no stable replacement currently available), both work pretty well, though I prefer the MySQL GUI tools myself. :)
OK, not sure what is causing it, but when I start phpMyAdmin, the left pane is just a list. There is a dB called "cdcol", if I go into that dB, then the left pane changes into the drop-down menu style I'm used to using, & going from there to any of the other dB's in the drop-down list return the same thing, Drop-down menu's. It goes like that again (just a plain list) after restarting the Server, & after system reboots. Not sure why it's behaving like that, but I'm just glad I can get it to work the way I'm used to with A2T.

Looked at the 2 links, Navicat is paid, so not at the moment, & MySQL GUI Tools says that Workbench is available instead. I'll have a proper look at that site tomorrow sometime.

I'm just waiting till tomorrow, gonna try XAMPP on my Vista Laptop. ;)

Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: WAMP for XP & Vista

Post by Desdenova » Mon Jun 07, 2010 2:35 am

Like I said, MySQL GUI tools is EOL (no support), and there's navicat lite (available on the same site as navicat, just have to look a bit harder in downloads) which is free.
MySQL workbench, the stable version, does not have anything that allows you to interact with your database server, however; the query tool is included until 5.2 which is still in testing.

User avatar
TheSnake
Registered User
Posts: 483
Joined: Wed Aug 09, 2006 10:36 pm
Location: Staffordshire, England, UK
Contact:

Re: WAMP for XP & Vista

Post by TheSnake » Mon Jun 07, 2010 7:25 pm

I tried WampServer again (Vista Laptop), still kept coming up with link table issues & various Not OK was displayed in the status. :(

Installed XAMPP & so far, it is running clean, although the same weird issue as on the main computer, with a list instead of drop-down menu, but as soon as I access the 1st dB, it all goes how I want it, & I've tested it by restarting the server & rebooting at least 3 times each. :D

I've saved them links & will take a look into the Lite version later on.

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Seattle, WA
Name: David Lewis
Contact:

Re: WAMP for XP & Vista

Post by Highway of Life » Tue Jun 08, 2010 8:20 pm

TheSnake wrote:I've tried WampServer, they have a Link tables issue, as well as the phpMyAdmin ain't working right, the drop-down menu for choosing Databases don't work.
You should use a Database admin tool other than phpMyAdmin, such as Navicat or MySQL Workbench. PMA is extremely slow compared to other tools, and it’s highly inefficient.

EDIT: Oh, I see someone beat me to it already. I believe MySQL Workbench replaces the GUI tools.
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: WAMP for XP & Vista

Post by Desdenova » Tue Jun 08, 2010 11:25 pm

Highway of Life wrote:
TheSnake wrote:I've tried WampServer, they have a Link tables issue, as well as the phpMyAdmin ain't working right, the drop-down menu for choosing Databases don't work.
You should use a Database admin tool other than phpMyAdmin, such as Navicat or MySQL Workbench. PMA is extremely slow compared to other tools, and it’s highly inefficient.

EDIT: Oh, I see someone beat me to it already. I believe MySQL Workbench replaces the GUI tools.
No stable release of MySQL workbench completely replaces the GUI tools. No MySQL administrator, no MySQL Query Browser, which makes it pretty useless IMO. :P

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Seattle, WA
Name: David Lewis
Contact:

Re: WAMP for XP & Vista

Post by Highway of Life » Wed Jun 09, 2010 1:23 am

That's a shame. :(
I never noticed, since I only use Navicat, it has everything a developer needs for managing databases.
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: WAMP for XP & Vista

Post by Desdenova » Wed Jun 09, 2010 6:10 am

Highway of Life wrote:That's a shame. :(
I never noticed, since I only use Navicat, it has everything a developer needs for managing databases.
Apparently it's coming in the next release, but since it isn't in there I'm sticking with the GUI tools until 5.2 is stable. P:

Post Reply

Return to “General Discussion”