phpBB2 worked with PHP5.3, but won't with PHP5.5

Discussion of non-phpBB related topics with other phpBB.com users.
Forum rules
General Discussion is a bonus forum for discussion of non-phpBB related topics with other phpBB.com users. All site rules apply.
Post Reply
Nap BlownApart
Registered User
Posts: 35
Joined: Sun Jul 30, 2006 6:47 am

phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by Nap BlownApart »

I'm still running an old phpBB2 board, with ptirhiik's mod. (I haven't been hacked, and it's been running perfectly all these years.)

I recently updated my whole server (OS and all the LAMP software to current versions) and I've found that my forum is broken now because of deprecated changes in PHP5.

It would be a real shame to loose all the content my community has.

I'm wondering if it is possible to change some php.ini settings, or use ini_set(), to get it going? I would consider upgrading, but because of ptirhiik's awesome mod, I think I'm locked in.

Any advice?

Cheers,
Nap
User avatar
KevC
Support Team Member
Support Team Member
Posts: 69992
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by KevC »

Support for phpBB2 ended several years ago. Any support requests regarding phpBB2 are limited to help with conversion to phpBB3.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
User avatar
Lumpy Burgertushie
Registered User
Posts: 67908
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by Lumpy Burgertushie »

what MOD are you talking about?
if you are running this on your own server you can just revert back to the older php version.

if the MOD is the attachment MOD then it will be converted if you convert to phpbb3

robert
User avatar
3Di
Former Team Member
Posts: 15668
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by 3Di »

Nap BlownApart wrote:I'm still running an old phpBB2 board, with ptirhiik's mod. (I haven't been hacked, and it's been running perfectly all these years.)

I recently updated my whole server (OS and all the LAMP software to current versions) and I've found that my forum is broken now because of deprecated changes in PHP5.

It would be a real shame to loose all the content my community has.

I'm wondering if it is possible to change some php.ini settings, or use ini_set(), to get it going? I would consider upgrading, but because of ptirhiik's awesome mod, I think I'm locked in.

Any advice?

Cheers,
Nap
Oh well, are you talking about Categories Hierarchy MOD?
If so and you want to move to phpBB3 (I strongly suggest you to do that) then your best bet is here: https://www.phpbb.com/customise/db/conv ... convertor/
At the end of all the above mentioned MOD it is a fork of phpBB2, so no support given here AFAIK.

Good luck.
Nap BlownApart
Registered User
Posts: 35
Joined: Sun Jul 30, 2006 6:47 am

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by Nap BlownApart »

@KevC: I'm aware that support has ended. But my community hasn't. It's just how things work in the IT business. I'm not looking for support, I'm looking for advice.

@Lumpy: The MOD was/is the "Categories Hierarchy (Sub Forums) hack" by ptirhiik. The main reason for installing it was because It included sub-forums, which vanilla phpBB2 didn't have at the time, and I really needed.

I have my own server with virtual hosts and am hosting a site for a friend who wants the latest version. What I might be able to do is configure my server with PHP5.3 and PHP5.5. Through my control panel, I can select which version a particular domain uses. Thus I can run 5.3 on mine, and 5.5 on the theirs.

But the cleanest path is to use one version of PHP. And, I too, would like to make use of the new features in 5.5, hence my question.

Is migration a possibility? All the phpBB2 data & files are still on the server, obviously. I'm just not sure if it's possible to do from my install. The "Categories Hierarchy (Sub Forums)" made substantial changes to the code and data bases.

Cheers,
Nap
User avatar
tbackoff
Former Team Member
Posts: 7064
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by tbackoff »

Nap BlownApart wrote:I'm wondering if it is possible to change some php.ini settings, or use ini_set(), to get it going? I would consider upgrading, but because of ptirhiik's awesome mod, I think I'm locked in.

Any advice?
Nap BlownApart wrote:@KevC: I'm aware that support has ended. But my community hasn't. It's just how things work in the IT business. I'm not looking for support, I'm looking for advice.
That is still considered support. If you really want to stick with phpBB 2, you will need to figure it out yourself or find a community that will assist you. One popular choice is phpbb2refugees.com, but be aware that they are in no way affiliated with us, even though you may see some users from here on that site.
Flying is the second best thrill to cheerleaders; being caught is the first.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 69992
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by KevC »

If it's possible to change the hierarchy of the sub-forums, make them all top level, do the conversion and move them back to being subs again.

The 3x conversion doesn't damage or change your 2x database at all so you can at least see what happens by running a conversion.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
Nap BlownApart
Registered User
Posts: 35
Joined: Sun Jul 30, 2006 6:47 am

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by Nap BlownApart »

Thanks for the suggestions, I'll give them a go and report back on what worked.

Cheers,
Nap
Nap BlownApart
Registered User
Posts: 35
Joined: Sun Jul 30, 2006 6:47 am

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by Nap BlownApart »

@KevC
I flattened the forum as you suggested and ran the conversion. My forum is now working in phpBB3 :)
Only the search index wasn't converted, but I think I can live with that.

I also had the EasyMOD, Attachment, & Export PM Mods installed. I haven't tested their status yet, but not really concerned about them.

Thank you all for your comments!!

Now I have to tidy up the presentation etc.

Cheers,
Nap
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22544
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by Mick »

Nap BlownApart wrote:Only the search index wasn't converted, but I think I can live with that
You can rebuild it.
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
KevC
Support Team Member
Support Team Member
Posts: 69992
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by KevC »

Nap BlownApart wrote:I also had the EasyMOD, Attachment, & Export PM Mods installed. I haven't tested their status yet, but not really concerned about them.
As no files are carried over, easyMOD and the export PM MOD will not have been converted. The attachments should be ok though.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
a[c]e
Registered User
Posts: 126
Joined: Mon Sep 07, 2009 5:09 pm

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by a[c]e »

I have now got the exact same problem as the starter of this thread.. Running the CH modded phpBB 2, and my service provider will shut down php 5.3 within very short time, so I need to migrate the forum over to phpBB 3.. However, I am no expert on how to do this, so any help would be greatly appreciated!

Where can I contact someone to be helped about this? Thanks a lot!
User avatar
KevC
Support Team Member
Support Team Member
Posts: 69992
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by KevC »

Information on how to convert from phpBB2 to phpBB3 is here.

Basically, you must have both phpBB2 and phpBB3 installed on the same server. After you have finished installing phpBB3 you will have the option to convert your phpBB2 board using the built in converter. The information it asks you for is related to the phpBB2 installation and can be found in its config.php file on the server. All of your users, posts, forums, PMs etc are converted. However, styles and MODs are not (with the exception of the birthday and attachment MODs which are supported by the converter). The phpBB2 database is not converted per se, it is merely read and converted/moved to the new phpBB3 database, so if it goes wrong your old board will not be affected at all. At the end of the conversion, once you’re happy it’s all working, your phpBB2 database and files can be backed up and removed if you so wish. They are not connected to the new installation in any way.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
a[c]e
Registered User
Posts: 126
Joined: Mon Sep 07, 2009 5:09 pm

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by a[c]e »

Thanks for your reply KevC!

Will I be able to convert the CH phpBB 2 version with the normal converter? As I read in this post I might have to "flatten" the sub-forums first?
User avatar
darcie
Community Team Member
Community Team Member
Posts: 5541
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: phpBB2 worked with PHP5.3, but won't with PHP5.5

Post by darcie »

There's a link to a convertor posted above and a topic for it here. I would suggest opening a new topic in the Convertors forum to get help specific to your issues.

I did this about five years ago, and I don't recall flattening the site. I did add to the convertor to bring genders over, and maybe a couple other things like topic descriptions. It's hard to remember after all this time! You'll have to rearrange forums and permissions once it completes. I'd suggest running a test conversion offline and playing with it.
phpBB on Facebook | Site Rules | Former Community Team leader
Post Reply

Return to “General Discussion”