Images Hijacked by Photobucket?

Discussion of non-phpBB related topics with other phpBB.com users.
Forum rules
General Discussion is a bonus forum for discussion of non-phpBB related topics with other phpBB.com users. All site rules apply.
User avatar
Walther
Registered User
Posts: 268
Joined: Fri Jul 09, 2004 5:21 pm
Location: The Netherlands

Re: Images Hijacked by Photobucket?

Post by Walther » Sun Oct 15, 2017 4:39 pm

urhm, with what phpbb version is the extract-external-links script supposed to run?
I have 3.1.10 and error out with

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/scripts/extract_external_links.php on line 15: include(../phpbb/db/tools/tools_interface.php): failed to open stream: No such file or directory
Further inspection learns there is a file called tools.php in phpbb/db/ but no directory /tools in phpbb/db :?


Could i (temporary) take the phpbb/db/tools/* from the phpbb3.2.1 package :|

User avatar
david63
Jr. Extension Validator
Posts: 14945
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Images Hijacked by Photobucket?

Post by david63 » Sun Oct 15, 2017 5:50 pm

If it is looking for a file called tools.php then I suspect that it is probably phpBB 3.0.x

User avatar
Walther
Registered User
Posts: 268
Joined: Fri Jul 09, 2004 5:21 pm
Location: The Netherlands

Re: Images Hijacked by Photobucket?

Post by Walther » Sun Oct 15, 2017 5:57 pm

david63 wrote:
Sun Oct 15, 2017 5:50 pm
If it is looking for a file called tools.php then I suspect that it is probably phpBB 3.0.x
???

It is not looking for a file tools.php
The phpbb version now in use is 3.1.10 , and that version has phpbb/db/tools.php instead of phpbb/db/tools/*.*

User avatar
Walther
Registered User
Posts: 268
Joined: Fri Jul 09, 2004 5:21 pm
Location: The Netherlands

Re: Images Hijacked by Photobucket?

Post by Walther » Tue Oct 17, 2017 9:39 am

....silence....guess nobody has the answer then?

But, there is a chrome extension that bypass the photobucket ransom: https://chrome.google.com/webstore/deta ... fnflicjjgj :)

(open source: https://github.com/kzahel/photobucket-embed-fix )

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20958
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Images Hijacked by Photobucket?

Post by RMcGirr83 » Tue Oct 17, 2017 10:09 am

Walther wrote:
Sun Oct 15, 2017 4:39 pm
urhm, with what phpbb version is the extract-external-links script supposed to run?
3.2 or you could just change this line

https://github.com/v12mike/fetch-extern ... ks.php#L15

to suit your version.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
Walther
Registered User
Posts: 268
Joined: Fri Jul 09, 2004 5:21 pm
Location: The Netherlands

Re: Images Hijacked by Photobucket?

Post by Walther » Tue Oct 17, 2017 10:34 am

So you say i can change

Code: Select all

include($phpbb_root_path . 'phpbb/db/tools/tools_interface.' . $phpEx);
in

Code: Select all

include($phpbb_root_path . 'phpbb/db/tools.' . $phpEx);
safely?

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20958
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Images Hijacked by Photobucket?

Post by RMcGirr83 » Tue Oct 17, 2017 1:51 pm

No, the script is written for 3.2. You would have to be running 3.2.

I was simply stating why it wasn't working for you.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
Walther
Registered User
Posts: 268
Joined: Fri Jul 09, 2004 5:21 pm
Location: The Netherlands

Re: Images Hijacked by Photobucket?

Post by Walther » Tue Oct 17, 2017 2:24 pm

seemed to do the trick though:
...All Done!!
1937 files (photobucket only) 251.020.156 bytes

v12mike
Registered User
Posts: 264
Joined: Thu Jul 09, 2015 5:03 pm

Re: Images Hijacked by Photobucket?

Post by v12mike » Tue Oct 24, 2017 7:33 am

Sorry I wasn't around to answer this, we had a server failure that took all of my time for a week or so.

Funny that no-one else reported that problem. I know that the scripts have been run on phpBB 3.0 forums, and I thought 3.1. Maybe others found the fix themselves.

mainevette
Registered User
Posts: 65
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Images Hijacked by Photobucket?

Post by mainevette » Mon Nov 27, 2017 3:29 am

Hi Mike,

I'm wondering if this script would have changed the location that my boards avatars are saved. I have a plugin on on my wordpress site that's trying to fetch my phpBB avatars but it's not working. I've been troubleshooting with the developer of the wordpress plugin and he's wondering if the image redirect extension could have changed things. I thought you'd be able to provide a better idea of whether that's a possibility.

Specifically, the plugin I'm using is searching for each user's uploaded avatar in the following directory (my admin avatar image is used as an example - see my user profile here: http://www.forum.corvette-restoration.c ... rofile&u=2):

Code: Select all

http://www.forum.corvette-restoration.com/images/avatars/upload/fa32204b6318e94f394bfa900d906505_2.jpg
However, when we look at the posts in my forum each avatar is being pulled from the following directory below, and with a different file name:

Code: Select all

http://www.forum.corvette-restoration.com/download/file.php?avatar=2_1255917380.jpg
My avatar was never on Photobucket so I didn't expect the image redirect extension would have downloaded and moved my avatar.

I tried disabling the extension to see if that would resolve the issue but the links above don't change.

I'm curious to get your thoughts on this.

Thanks,
Tim

v12mike
Registered User
Posts: 264
Joined: Thu Jul 09, 2015 5:03 pm

Re: Images Hijacked by Photobucket?

Post by v12mike » Mon Nov 27, 2017 8:24 am

The extension does not actually make any changes to files and directories, it just tests for the existence of local copies of image files to control whether image links are redirected. It does not touch locally hosted avatars, but can redirect externally hosted avatars (but this doesn't seem to be relevant to your problem).

The paths you show for avatar storage and links look like normal phpBB code (nothing to do with my work). There are probably several reasons that phpBB obscures the file location in links, but that is what it does. Has your wordpress extension ever worked? Does the wordpress plugin attempt to read the avatar file from disk, or does it create a link for the users' browser? If the former, then is the file name prefix set correctly, if the latter, then a direct link won't work unless you relax the .htaccess security.

mainevette
Registered User
Posts: 65
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Images Hijacked by Photobucket?

Post by mainevette » Wed Nov 29, 2017 3:25 am

Thanks for the quick reply, Mike. We figured out that it was an .htaccess issue and not something with the image redirect extension.

Thanks again!

User avatar
BigBlockMopar
Registered User
Posts: 80
Joined: Tue Mar 08, 2005 3:15 pm

Re: Images Hijacked by Photobucket?

Post by BigBlockMopar » Sun Dec 17, 2017 10:23 pm

I installed the scripts and extension on a forum of mine and it worked!
Thank you very much for this v12Mike.

I did have to limit the amount of pics that were fetched to prevent timeouts.
Perhaps with the actual downloading of the photos, an automated page-refresh can be done as long as there are more files to download.

There's a nifty little program called 'BigDump' for uploading large databases to a MySQL-server, which has a similar function that it will do an X-amount of data before it reloads the page and starts off from that point again.

panhead
Registered User
Posts: 641
Joined: Sat Dec 20, 2003 8:17 pm

Re: Images Hijacked by Photobucket?

Post by panhead » Sat Dec 30, 2017 3:25 pm

I also installed the scripts and enabled the extension. Approx. 2300 pictures (only photobucket) are downloaded. But I am a bit confused, should the downloaded pictures now be visible or do I have to make another step?

Update: I think it works, but not all pictures were/could be downloaded.

mainevette
Registered User
Posts: 65
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Images Hijacked by Photobucket?

Post by mainevette » Sun Feb 04, 2018 4:04 pm

Hi Mike,

I'm hoping you can help me out. Previously I had this extension working perfectly on my board. Everything was fine until I migrated my board to a new web host and upgraded to phpBB 3.2.1. After the migration the image redirect wasn't working quite right. I thought perhaps the database tables for the extension got corrupted during the install so I re-ran the two scripts (extract links and download images). Now some of the images show up properly, but some still show the photobucket speedometer image.

Currently, I have the extension enabled and have the "Local Image Store Mode" enabled. "Proxy Mode" is set to disabled.

Here's a link to a forum page where images originally hosted on photobucket are being properly displayed (scroll about halfway down the page). http://www.forum.corvette-restoration.c ... ?f=8&t=251 When I use the "inspect tool" of my browser and click on one of the photos the link is pointed to the /images/ext/ directory. The images that show up are the correct original images.

For comparison, here's a link to a forum page where images originally hosted on photobucket are still displayed as the speedometer image. http://www.forum.corvette-restoration.c ... &start=100 When I use the "inspect tool" the link points to the images/ext/ directory.

I've confirmed that these photos were in fact originally hosted on photobucket by disabling the extension and using the inspect element function to verify the original photo link pointed to photobucket. Interestingly, when I do this the speedometer image shows up with green text instead of blue text.

I strongly suspect that when I reran the script after my website migration it pulled in the speedometer image from photobucket instead of the actual image. Perhaps photobucket changed something that caused this to happen. However, I'm not sure how to view the files in the images/ext directory to verify this.

Any suggestions would be greatly appreciated.

Post Reply

Return to “General Discussion”

Who is online

Users browsing this forum: Tommy89 and 26 guests