My server IP is always being blocked by spamhaus

Discussion of non-phpBB related topics with other phpBB.com users.
Forum rules
General Discussion is a bonus forum for discussion of non-phpBB related topics with other phpBB.com users. All site rules apply.
KYPREO
Registered User
Posts: 312
Joined: Fri Feb 02, 2018 9:56 am
Contact:

Re: My server IP is always being blocked by spamhaus

Post by KYPREO »

I wouldn't have thought lack of DMARC alone is enough to get you blacklisted. This is a newer higher standard of verification.

Do you have SPF or DKIM set up? That should be the first step before DMARC.

Is there a MX entry in your DNS matching the name of your mail server?

Have you done a reverse DNS check on your mail server? If a reverse DNS check on the origin IP of sent emails does not match the fully qualified domain of your mail server, this will be sure to trigger your emails as spam.

KYPREO
Registered User
Posts: 312
Joined: Fri Feb 02, 2018 9:56 am
Contact:

Re: My server IP is always being blocked by spamhaus

Post by KYPREO »

PS you can use this tool of ths previously listed tester does not work for you: https://mxtoolbox.com/SuperTool.aspx (select the Test Email Server option and Email Deliverability option)

User avatar
WelshPaul
Registered User
Posts: 365
Joined: Tue Aug 19, 2014 2:09 pm

Re: My server IP is always being blocked by spamhaus

Post by WelshPaul »

Lumpy Burgertushie wrote:
Sat Feb 01, 2020 2:02 am
however, that is something that the host should have found the first time you asked them for help.
Not unless you have a shared hosting plan or managed VPS/Dedicated server.

If you get a VPS or Dedicated server then the onus is on you to set it up and configure it correctly and the majority of hosts won't entertain such support requests.

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3493
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: My server IP is always being blocked by spamhaus

Post by thecoalman »

</Solidjeuh> wrote:
Mon Feb 03, 2020 2:22 am
Today it was blocked again :(

I doubted DMARC was the issue. SPF, DKIM and last but least DMARC can help keep email from going to the recipients spam box. It shouldn't cause it to get blocked let alone the IP getting blocked.

This was a new IP they issued you?

You said this was VPS, is it a WHM control panel? There is section in there under email that logs incoming and outgoing email. You may want to look to see if there is a bunch of unusual activity. If you are using any other software or scripts double check them.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison

User avatar
</Solidjeuh>
Registered User
Posts: 1774
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: My server IP is always being blocked by spamhaus

Post by </Solidjeuh> »

They investigated this a bit further. My "_DMARC" was good now, but I was still missing a "SPF record". They see no more errors, and should be okay now.

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3493
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: My server IP is always being blocked by spamhaus

Post by thecoalman »

Like I said the SPF record is good for keeping emails out spam box, unless things have changed and they are clamping down I doubt it's causing the IP to be blocked. Most sites don't have one because it's really the site owner that needs to set it up. The host can't really set this up because if for example you were using external email service this can screw you up, and incorrect SPF record is worse than no record.

By all means set it up but make sure it's right. If you are using WHM email can be sent through "main" IP or if you have second IP through that. You need to make sure it's the right IP. This is what i have been using

Code: Select all

v=spf1 mx ip4:123.123.123.123 mx:the.domain.com -all
The domain can be different that the domain, e.g, example above with WHM server. If the you are seding through main IP it;s going to be the hostname. The IP is the IP sending the email. -all is probably not what they are using but you should use it.
https://www.dmarcanalyzer.com/spf/how-t ... xt-record/
-all Fail – servers that aren’t listed in the SPF record are not authorized to send email (not compliant emails will be rejected).
~all Softfail – If the email is received from a server that isn’t listed, the email will be marked as a soft fail (emails will be accepted but marked).
+all We strongly recommend not to use this option, this tag allows any server to send email from your domain
One other thing check the Return-Path in the header of sent email, if it's not the board email under emails settings set Force from email address: to yes.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison

User avatar
</Solidjeuh>
Registered User
Posts: 1774
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: My server IP is always being blocked by spamhaus

Post by </Solidjeuh> »

Thank you all for the help!
@thecoalman, I'm using PLESK, so this should be okay?
v=spf1 mx ip4:46.228.199.52 mx:supportforum.be -all No need to add IP6 ?

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3493
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: My server IP is always being blocked by spamhaus

Post by thecoalman »

Look at an email header and make sure the domain is correct, in my case since it's sent through the "main" IP it's actually the hostname. Use one of the email testers to confirm it's right. This is not something you want to screw up because it will cause emails to bounce especially with the -all.

I've been using that for years now and AFAIK I do not have any trouble with email delivery, they go to inbox. If you have the DMARC setup you'll get reports on it, you might want to look at them initially.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison

Post Reply

Return to “General Discussion”