Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Ideas Centre
User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by callumacrae » Sun Jan 02, 2011 5:36 pm

Paul wrote:
which won't bode well for reputation nor will it bode well for eventual monetization of the open source product.

PFS.
phpBB is free, and always will be free.
I think he believes that you should always be able to install open source software on everything, even if it running out of date software.

~Callum
macr.ae = my website. you probably won't like it.
Proud user ofProud user of

User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by Erik Frèrejean » Sun Jan 02, 2011 5:57 pm

Callum95 wrote:I think he believes that you should always be able to install open source software on everything, even if it running out of date software.

~Callum
Well thats simply impossible. PHP adds and drops stuff phpBB relies on, once PHP introduces a new function that phpBB needs to implement feature `x` backwards compatibility is broken. Seeing that phpBB will support PHP 5.2 when Ascraeus comes around seems pretty backward compatible enough to me, keeping in mind the fact that PHP 5.2.16 is the latest release in the PHP 5.2.x line.
Stuff improves and to utilise all the possibilities of of new releases you'll have to break backward compatibility at some point (every software developer does that).
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)

User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by callumacrae » Sun Jan 02, 2011 8:18 pm

Erik Frèrejean wrote:
Callum95 wrote:I think he believes that you should always be able to install open source software on everything, even if it running out of date software.

~Callum
Well thats simply impossible. PHP adds and drops stuff phpBB relies on, once PHP introduces a new function that phpBB needs to implement feature `x` backwards compatibility is broken. Seeing that phpBB will support PHP 5.2 when Ascraeus comes around seems pretty backward compatible enough to me, keeping in mind the fact that PHP 5.2.16 is the latest release in the PHP 5.2.x line.
Stuff improves and to utilise all the possibilities of of new releases you'll have to break backward compatibility at some point (every software developer does that).
I wasn't disagreeing with you - in fact, I think support should be dropped for PHP 5.2 and it's the fault of the hosting companies for not upgrading to 5.3. Support has ended for 5.2, after all.

~Callum
macr.ae = my website. you probably won't like it.
Proud user ofProud user of

ToonArmy
Former Team Member
Posts: 4608
Joined: Sat Mar 06, 2004 5:29 pm
Location: Worcestershire, UK
Name: Chris Smith
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by ToonArmy » Tue Jan 04, 2011 5:27 pm

cruisepak wrote:Agree with all the posts about Red Hat / CentOS 5.3 Linux...arguably the most popular enterprise version of Linux. Although PHP is updated often by Red Hat, the versioning remains the same so as to ensure backwards compatibility. i.e. the current version of php is 5.1. However, the code base is actually 5.3, etc.
That's totally incorrect, the version of PHP in RHEL is 5.1 it is not PHP 5.3.
Chris SmithBlogGitHub
Image
In a foreign field he lay. Lonely soldier unknown grave. On his dying words he prays. Tell the world of Paschendale.

MCForge
Registered User
Posts: 2
Joined: Wed Jan 05, 2011 2:35 pm

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by MCForge » Wed Jan 05, 2011 2:59 pm

im new so please understand i dont know everything about how to do this. im only 16.
i know my question is porbally stupid but here i go

How to i update my version of PHP

User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by Erik Frèrejean » Wed Jan 05, 2011 5:42 pm

Unless you are running a VPS or dedicated server you can't. Contact your host about it.
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)

User avatar
Snooty
Registered User
Posts: 52
Joined: Wed Feb 04, 2004 8:15 pm
Location: Holland
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by Snooty » Sat Aug 13, 2011 8:27 am

For this new phpbb, will it also be required to have a certain MySql version? I'm running a bit of an old one and recently, Wordpress requires a new version to run it.

User avatar
Sajaki
Registered User
Posts: 1354
Joined: Mon Mar 02, 2009 1:41 pm
Name: Andreas
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by Sajaki » Sat Aug 13, 2011 2:11 pm

WP requires Mysql 5.0 or later, which will be fine for phpbb 3.1.

Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by Oleg » Sun Aug 14, 2011 1:43 am

At this time phpbb 3.1 has the same mysql version requirements as 3.0. We may drop support for mysql < 5 if we start using features of mysql 5+. (At this time I'm unaware of any developments that use mysql 5+ features.)

We will drop support for postgresql 7.x, 8.0 and possibly 8.1.

See this topic for more details and to offer your opinion if you have one: http://area51.phpbb.com/phpBB/viewtopic ... 72#p220956

As a side note, mysql 4.x and 5.0 are no longer supported by oracle. If you are still on 4.x you really should update to at least 5.0. If you are on 5.0 you should consider updating to 5.1. If you are not hosting your forum yourself you should ask your host what their upgrade plans are. There really should not be a reason to run mysql 4.x today.
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com

Ninko
Registered User
Posts: 18
Joined: Wed Oct 05, 2005 6:59 pm

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by Ninko » Tue Oct 16, 2012 1:43 pm

Hi there,

My host provider is running PHP Version 5.2.17, but in my Administration Control Panel it says 'The version of PHP on this server will no longer be supported by future versions of phpBB.'.

Is this version not good enough or have I missed something?

Thanks


Ninko

User avatar
Ger
Recognised Extension Developer
Posts: 1850
Joined: Wed Jan 02, 2008 7:35 pm
Location: 192.168.1.100
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by Ger » Tue Oct 16, 2012 2:31 pm

It's good enough for 3.0.x, but won't be supported for 3.1 or higher. PHP 5.2 is end of life since december 2010.
My extensions:
Simple CMS, Feed post bot, Avatar Resize, Modbreak, Magic OGP, Live topic update, Modern Quote, Quoted Where (GDPR) and Autoresponder.
Newest: FAQ manager for 3.2

Like my work? Buy me a coffee to keep it coming. :ugeek:
-Available for custom work-

anim
Registered User
Posts: 6
Joined: Thu Aug 10, 2006 3:43 am
Location: Scotland

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by anim » Sun Mar 17, 2013 10:35 pm

Forgive my ignorance but I keep trying to keep things 'updated' and I seem to be on version : 3.0.10 with the 'latest' stated as 3.0.11

But they are talking about version 5xx ! So how does that work then and why when I am apparently only one didgit out is it no longer going to be supported?
I have terrible trouble with spam registrations and it takes ages to go through them 'by hand' ... keep hoping the latest versions will work better.

Also when I do have the forums updated to the latest versions I have to beg for help from a friend and I worry about what will happen when they refuse. Last time it went wrong and it took a long time to get things sorted and I still don't know why ! They thought it would be straight forward but it wasn't then and it wasn't the time before either.

I don't run any 'odd' add-ons or anything and keep things simple and straightforward.

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by HGN » Mon Mar 18, 2013 1:22 am

Those are two different things: phpBB and PHP.
phpBB is the bulletin board software. The latest revision is 3.0.11.
PHP is the language used to write the forum software and should be installed on the server by the hosting provider.

This topic is about a future branch of phpBB: 3.1.x. The current branch is 3.0.x. The future branch requires version 5.2 or higher of the PHP scripting language on the server.

We have a knowledgebase article describing how to update your board best: How to update to the latest version of phpBB3.
For questions or issues with the update of your board, you can post a topic in 3.0.x Support Forum.

User avatar
tbackoff
Former Team Member
Posts: 7022
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by tbackoff » Mon Mar 18, 2013 2:39 am

HGN wrote:The future branch requires version 5.2 or higher of the PHP scripting language on the server
Slight correction - future versions will require PHP 5.3.3 as per this announcement. ;)
Flying is the second best thrill to cheerleaders; being caught is the first.

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Post by HGN » Mon Mar 18, 2013 10:59 am

Correct, my mistake.

A good reason to close this topic and refer to the discussion topic on the updated announcement: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Locked

Return to “phpBB Discussion”