Page 1 of 14

Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 3:19 pm
by naderman
You may discuss the announcement about dropping support for PHP versions below 5.2 in this topic.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 3:48 pm
by Darth Wong
*runs to check*

Oh good, I'm running PHP 5.2.11. Whew!

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 4:39 pm
by tbackoff
Wasn't this previously announced? ;)

Anyway, no worries - I'm running 5.3.x.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 4:54 pm
by Mighty Gorgon
I totally agree with this decision. :)

The problem is that some hostings are too lazy to update their packages, even when official supports ends.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 5:03 pm
by MasterZ
Mighty Gorgon wrote:I totally agree with this decision. :)

The problem is that some hostings are too lazy to update their packages, even when official supports ends.
I second that.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 5:18 pm
by ttuu
i am fine.
I'm running PHP 5.2.9

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 5:26 pm
by DavidIQ
Mighty Gorgon wrote:The problem is that some hostings are too lazy to update their packages, even when official supports ends.
This is very true. I ran into such an issue with a client recently. However we got in contact with his hosting provider and they switched him over to another server with the updated PHP. So in a case where someone finds themselves in such a situation the best thing is to raise awareness to the hoster.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 5:30 pm
by Erik Frèrejean
t_backoff wrote:Wasn't this previously announced? ;)
That was before the change in the development cycle. The old Ascraeus would have gotten a new framework which would have been 5.2. The new Ascraeus will be developed on 5.2, but won't be rewritten (as per the announcement)

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 5:53 pm
by Desdenova
Finally! PHP4 seems to really hold us back. With that out of the way in 3.1, maybe more advanced and powerful code will begin to take form. :)

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 6:10 pm
by tbackoff
Erik Frèrejean wrote:
t_backoff wrote:Wasn't this previously announced? ;)
That was before the change in the development cycle. The old Ascraeus would have gotten a new framework which would have been 5.2. The new Ascraeus will be developed on 5.2, but won't be rewritten (as per the announcement)
Ah, OK. I understand now.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 6:42 pm
by Ahri89
I'm running 5.2.11 :P

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 7:31 pm
by EightOhProlene
Can someone explain to me why people seem to think I need to know what version of PHP they are using? I do not care what version PHP is on your server. Discuss the announcement, as requested.

Transitioning to phpBB 3.1 is a great time to require a newer version of PHP to be installed. Why not?

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 8:24 pm
by Sam
I am surprised no one noted that PHP4 officially reached EOL on 31 December 2007. It is a danger to your server to have that software running, knowing that any security problem will not be patched or even announced. If anyone is using PHP 4 (in the words of David Lewis) "They need to get away from the host."

Having PHP 5.2 is a great step in development for phpBB, and I am very happy to see it.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 9:04 pm
by Ishimaru Chiaki
I agree with the decision. Maybe this will convince lazy host to finally update to at least 5.2.x since phpBB is the most used opensource forum script.

On my side, it's already OK. My local server and my host both use 5.2.x, and as I upgrade my Ubuntu every year and my host's admins keep the server up-to-date, I'll probably be on 5.3.x when Ascraeus will come out.

Re: Discuss: phpBB 3.1 discontinues support for PHP < 5.2

Posted: Tue Jan 26, 2010 9:18 pm
by Sajaki
i totally agree ;)

fyi it was slashdotted back in 2007 even.
http://developers.slashdot.org/article. ... 14/0646216