[Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Suggested Hosts
User avatar
Ger
Recognised Extension Developer
Posts: 1850
Joined: Wed Jan 02, 2008 7:35 pm
Location: 192.168.1.100
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Ger » Wed Nov 14, 2012 1:24 pm

BroIgnatius wrote:
Marshalrusty wrote:Thus, my horror in reading about this upgrade of phpbb.
So if I understand you correctly, you worry about not being able to update to the latest version of phpBB? Yet you keep running software that you haven't updated for several years and has known issues without any support left for that software? If I were you, I'd worry about that ancient software first.

Besides: when someone chooses to run a 6+ years old OS, that person should not expect to be able to run all new software on that OS.
My extensions:
Simple CMS, Feed post bot, Avatar Resize, Modbreak, Magic OGP, Live topic update, Modern Quote, Quoted Where (GDPR) and Autoresponder.
Newest: FAQ manager for 3.2

Like my work? Buy me a coffee to keep it coming. :ugeek:
-Available for custom work-

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by imkingdavid » Thu Nov 15, 2012 6:13 pm

I just wanted to alert those who don't actually read the Announcements forum unless a new topic is posted there, that the PHP version has been bumped to 5.3.3 instead of 5.3.2. This is because the Symfony dependencies we rely on use 5.3.3 as the minimum version.
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

Jacob23
Registered User
Posts: 10
Joined: Fri Nov 18, 2011 4:58 am

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Jacob23 » Thu Nov 15, 2012 7:15 pm

You should change the title of this topic and of the announcement topic: viewtopic.php?f=14&t=2152375

User avatar
tbackoff
Former Team Member
Posts: 7022
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by tbackoff » Thu Nov 15, 2012 8:34 pm

I changed this topic title, I'll have an admin take care of the announcement.
Flying is the second best thrill to cheerleaders; being caught is the first.

Jacob23
Registered User
Posts: 10
Joined: Fri Nov 18, 2011 4:58 am

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by Jacob23 » Thu Nov 15, 2012 11:13 pm

Thanks. :)

Saeid
Registered User
Posts: 13
Joined: Sun Jun 27, 2010 7:41 pm
Location: Netherlands
Name: Saeid
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by Saeid » Sun Dec 09, 2012 3:10 am

I don't know how it goes with hosting companies. I mean is it my right to ask my hosting provider to upgrade theire PHP version?

User avatar
Lumpy Burgertushie
Registered User
Posts: 66320
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by Lumpy Burgertushie » Sun Dec 09, 2012 3:21 am

Saeid wrote:I don't know how it goes with hosting companies. I mean is it my right to ask my hosting provider to upgrade theire PHP version?
certainly. they may or may not do it. however I do believe that most companies are probably already up to this version or will be soon.

also, it is probably a while in the future before you have to worry about this requirement for the next version of phpbb. it may or may not even be released next year.


luck,
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by Oleg » Mon Dec 10, 2012 12:21 am

The minimum version requirement is such that most hosts should have no issues updating to it when their customers ask for it, if they aren't already at that version.
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com

User avatar
3Di
Former Team Member
Posts: 13766
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by 3Di » Mon Dec 10, 2012 12:38 am

I do not see the reason why discussing about PHP version's requirement when the supposed to be 3.1 phpBB version is so far away from to be released. :geek:
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
MichaelC
Development Team Member
Development Team Member
Posts: 3642
Joined: Mon Dec 21, 2009 3:36 pm
Location: Surrey, UK
Name: Michael Cullum
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by MichaelC » Mon Dec 10, 2012 12:46 am

3Di wrote:I do not see the reason why discussing about PHP version's requirement when the supposed to be 3.1 phpBB version is so far away from to be released. :geek:
This is to notify users that have out-dated installations to give them time to upgrade PHP before 3.1.

Could you expand on why you think 3.1 is 'so far away from to be released'?
:)
Formerly known as Unknown Bliss
Please don't PM me for support (or stuff that belongs in the forums or tracker) but otherwise feel free
Website Feedback || Website Tracker

User avatar
3Di
Former Team Member
Posts: 13766
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by 3Di » Mon Dec 10, 2012 12:51 am

MichaelC wrote:
3Di wrote:I do not see the reason why discussing about PHP version's requirement when the supposed to be 3.1 phpBB version is so far away from to be released. :geek:
This is to notify users that have out-dated installations to give them time to upgrade PHP before 3.1.

Could you expand on why you think 3.1 is 'so far away from to be released'?
Tell me please a reason (ETA) why I wouldn't think that. I'm a perfect lurker, overall.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
MichaelC
Development Team Member
Development Team Member
Posts: 3642
Joined: Mon Dec 21, 2009 3:36 pm
Location: Surrey, UK
Name: Michael Cullum
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by MichaelC » Mon Dec 10, 2012 1:16 am

Because nobody can accurately predict how long it will be until a release. We can look at what still needs doing and is blocking a release at the time of writing but we cannot put time estimates on how long they will take us to complete or whether we will have any further issues blocking the release further along the road.
:)
Formerly known as Unknown Bliss
Please don't PM me for support (or stuff that belongs in the forums or tracker) but otherwise feel free
Website Feedback || Website Tracker

User avatar
3Di
Former Team Member
Posts: 13766
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by 3Di » Mon Dec 10, 2012 1:20 am

MichaelC wrote:Because nobody can accurately predict how long it will be until a release. We can look at what still needs doing and is blocking a release at the time of writing but we cannot put time estimates on how long they will take us to complete or whether we will have any further issues blocking the release further along the road.
Ditto. I am right. :)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by callumacrae » Mon Dec 10, 2012 8:07 am

3Di wrote:
MichaelC wrote:Because nobody can accurately predict how long it will be until a release. We can look at what still needs doing and is blocking a release at the time of writing but we cannot put time estimates on how long they will take us to complete or whether we will have any further issues blocking the release further along the road.
Ditto. I am right. :)
Yeah, you are; two weeks notice is better than a years notice, right?
macr.ae = my website. you probably won't like it.
Proud user ofProud user of

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by RMcGirr83 » Mon Dec 10, 2012 10:49 am

Would this be an appropriate gauge as to the current status of 3.1 being released?

http://tracker.phpbb.com/secure/IssueNa ... stId=10596

There are 150 blocker/major bugs currently, some dating back to 2007.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Post Reply

Return to “phpBB Discussion”