[Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Get Involved
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17326
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by DavidIQ »

Ah you mean this. You're not too ar from the truth about the notice being generated in 5.4. It's something I intend to fix in my next release. Thanks for reminding me. :mrgreen:
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
imkingdavid
Former Team Member
Posts: 2673
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by imkingdavid »

Rich does bring up a good point that I hadn't considered, though. Even if phpBB works on 5.4, not all MODs will necessarily work without throwing strict notices and such. 5.4 is generally backwards compatible, but if a MOD is doing something that violates strict standards, errors that weren't shown before will still be shown.

So I suppose it may not be so clear cut to say that you should necessarily go straight to 5.4 right away. If it's not too much hassle, I suppose you could request the upgrade to 5.4 initially and check to see if any errors are displayed, and if so you could request to be bumped back to >= 5.3.3.
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
cumberbatchforum
Registered User
Posts: 5
Joined: Sat Jan 26, 2013 4:31 pm

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by cumberbatchforum »

Hi,

Thank you for your help yesterday! I went for the 5.4 option and have been back onto my forum, all seems to be working ok so fingers crossed it stays that way.

:mrgreen:
gotwings
Registered User
Posts: 37
Joined: Sat Jan 15, 2005 5:14 am

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by gotwings »

Hmmm......

So the Ascraeus blog post states that PHP 5.3.3 or better will be needed for 3.1.x :
Please note that phpBB 3.1 has some requirements that differ from phpBB 3.0:

PHP version 5.3.3 or greater
PHP’s json extension
Only PostgreSQL versions 8.3 and above are supported
However, the very first post in the follow-up forum topic states:
The next major release of phpBB, phpBB 3.1 "Ascraeus", will require PHP 5.3.2 or newer.
It would be nice to know which it is : 5.3.3 or 5.3.2 . Any insight much appreciated!

--gw
gotwings
Registered User
Posts: 37
Joined: Sat Jan 15, 2005 5:14 am

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by gotwings »

Ack, sorry, ignore me. I see that the initial requirement was 5.3.2, but then that was amended to 5.3.3 . Apologies for the noise....
User avatar
O Bloggueiro
Registered User
Posts: 31
Joined: Tue Feb 11, 2014 9:40 pm
Location: Portugal
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by O Bloggueiro »

I was reading this thread to try to figure how to make this update.
But I'm still not sure how to proceed, can help?
Comment, Participate!
Sorry for my English, I'm Portuguese and I use Google Translate.
User avatar
tbackoff
Former Team Member
Posts: 7064
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by tbackoff »

What update? If you are looking to update to 3.1, it's currently only in the ALPHA testing phases. If you are looking to update PHP, you need to speak to your web host.
Flying is the second best thrill to cheerleaders; being caught is the first.
User avatar
O Bloggueiro
Registered User
Posts: 31
Joined: Tue Feb 11, 2014 9:40 pm
Location: Portugal
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by O Bloggueiro »

t_backoff wrote:What update? If you are looking to update to 3.1, it's currently only in the ALPHA testing phases. If you are looking to update PHP, you need to speak to your web host.
Thank you.
Yes, I meant to upgrade PHP, I will follow the suggestion.
Comment, Participate!
Sorry for my English, I'm Portuguese and I use Google Translate.
Post Reply

Return to “phpBB Discussion”