[Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Scam Warning
User avatar
MichanForo
Registered User
Posts: 19
Joined: Tue Mar 01, 2011 7:53 pm
Location: Mallorca
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by MichanForo » Tue Mar 13, 2012 8:22 pm

Well, my hosting is running PHP 5.2.14... but I hope they'll upgrade soon to this version :P

User avatar
DoYouSpeakWak
Registered User
Posts: 2307
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by DoYouSpeakWak » Wed Mar 14, 2012 12:10 pm

victory1 wrote:I see on my cpanel that my host is using PHP 5.2.17, when I inquire when they will switch to 5.3, I was told how to switch to PHP 5.3.x?

By default, we use PHP 5.2.x on our systems, however if you wish to run PHP 5.3.x, please add the following line to your public_html .htaccess file:

AddType application/x-httpd-php53 php53 php

So just because your host is running 5.2, does not mean that 5.3 is not available. My ACP PHP Information says PHP Version 5.3.6
If your acp php info says you running 5.3.6 then your running 5.3.6, some hosts provides both still. I suggest anyone to get a vps and install it them self. you can get a vps for 15-20 dollars a year these days that works just fine.
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid phpBB help and System administrator services.

Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Pony99CA » Wed Mar 14, 2012 8:23 pm

DoYouSpeakWak wrote:I suggest anyone to get a vps and install it them self. you can get a vps for 15-20 dollars a year these days that works just fine.
That sounds wak (pun intended). Non-free shared hosting that I've seen runs at least $2.00 per month (or $24 per year). I've never seen VPS for close to that, much less cheaper.

Also, not everybody wants to have to worry about installing their infrastructure themselves. Installing phpBB presents them with enough challenges as is. :)

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.

User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by callumacrae » Wed Mar 14, 2012 10:09 pm

Pony99CA wrote:
DoYouSpeakWak wrote:I suggest anyone to get a vps and install it them self. you can get a vps for 15-20 dollars a year these days that works just fine.
That sounds wak (pun intended). Non-free shared hosting that I've seen runs at least $2.00 per month (or $24 per year). I've never seen VPS for close to that, much less cheaper.

Also, not everybody wants to have to worry about installing their infrastructure themselves. Installing phpBB presents them with enough challenges as is. :)

Steve
I've never used a decent hosting service for $2/m ;-)

Minimum I would pay for shared hosting is $5/m, minimum for a VPS would be $15/m - although it is possible to get both for far cheaper.


My stats might be a few years out of date, I get everything for free these days.
macr.ae = my website. you probably won't like it.
Proud user ofProud user of

User avatar
Elias
Registered User
Posts: 4626
Joined: Sat Feb 25, 2006 4:31 pm
Location: In the Water!
Name: Elias

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Elias » Thu Mar 15, 2012 4:09 am

callumacrae wrote:My stats might be a few years out of date, I get everything for free these days.
I know, right ;)
"Mystery creates wonder, and wonder is the basis of man's desire to understand." - Neil Armstrong
|Installing Extensions|Writing Extensions|Extension Validation Policy|

User avatar
DoYouSpeakWak
Registered User
Posts: 2307
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by DoYouSpeakWak » Thu Mar 15, 2012 10:31 am

You can find good offers on WHT, (webhostingtalk.com)

Iwe got two $15-20yr boxes with 128mb ram atm. both for about 6 month. one have had 5 mins of downtime or so, runs nginx and apc, load times 0.020 or so on index. Other has more downtime. So its a chance of course. Then again im using some 30 euro a month vps as well, they arnt perfect either. It all comes down to pride of service for the host. Not always the price.

Its not for everybody, but it does open up some great options. get a kvm vps were you can upgrade the kernel, but arch on it and you will have a very fast box with latest packages. Currently if you are on centos with php 5.2.x your kernel and other essential packages will be years old. Not weeks. But thats a longer discussion :)

Most hosts just setup a shared box. Let it run without updates as long as its online. Those are the lazy ones you imo have to avoid. unsafe to use such a old system.
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid phpBB help and System administrator services.

User avatar
bantu
3.0 Release Manager
3.0 Release Manager
Posts: 2523
Joined: Mon Jul 10, 2006 9:58 pm
Name: Andreas Fischer

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by bantu » Thu Mar 15, 2012 11:44 am

DoYouSpeakWak wrote:I suggest anyone to get a vps and install it them self. you can get a vps for 15-20 dollars a year these days that works just fine.
In general this is not a good idea. Most of our users do not have the knowledge to run their own server and it is quite easy to get into legal trouble when it gets hacked e.g. because it is running outdated software. Hosting companies are supposed to take care of those problems.
Powered by Coffee

User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by callumacrae » Thu Mar 15, 2012 1:37 pm

bantu wrote:
DoYouSpeakWak wrote:I suggest anyone to get a vps and install it them self. you can get a vps for 15-20 dollars a year these days that works just fine.
In general this is not a good idea. Most of our users do not have the knowledge to run their own server and it is quite easy to get into legal trouble when it gets hacked e.g. because it is running outdated software. Hosting companies are supposed to take care of those problems.
+1

We have gone so far off topic 0_o
macr.ae = my website. you probably won't like it.
Proud user ofProud user of

DrinkChoc
Registered User
Posts: 94
Joined: Sat Apr 23, 2011 6:33 pm
Location: England
Name: Daniel
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by DrinkChoc » Sat Apr 14, 2012 8:52 pm

It's a good decision to make considering PHP is evolving and improving but the only problem I see with this is that some people don't have a host that can provide them with the necessary version of PHP meaning they can't update and if they try to, they'll experience a lot of problems. I suppose most hosts should be up to date though anyway as PHP 5.3 isn't exactly new.
Daniel || Web & Graphic Designer

Me | Forrst | Dribbble

Want an invite to Forrst? Just ask via PM.

User avatar
Stoker 4.0
Registered User
Posts: 1483
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Stoker 4.0 » Fri Apr 20, 2012 1:53 pm

Pheeew :D
Im running 5.3.3 on my server.
But wouldnt this hit a lot of people?

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17079
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by DavidIQ » Fri Apr 20, 2012 2:36 pm

Seeing that PHP 5.3.2 was published on 2010-03-04, I would certainly hope most hosting providers would have at least gotten there by now. ;) Sometimes they'll give the owner the option to use one of a set of versions. When my hosting provider went from 4 to 5 they ran both concurrently for some time and I had the option to use either one on my site. I would expect most hosting providers to do the same or have already upgraded.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
Stoker 4.0
Registered User
Posts: 1483
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by Stoker 4.0 » Fri Apr 20, 2012 3:11 pm

I just think that there are a lot of crappy hosts out there.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17079
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by DavidIQ » Fri Apr 20, 2012 3:23 pm

Stoker 4.0 wrote:I just think that there are a lot of crappy hosts out there.
Completely agree. I think that minimum PHP requirements for common/free software like phpBB can help push even those crappy hosts to upgrade. :)
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
victory1
Registered User
Posts: 935
Joined: Sun Oct 10, 2010 6:47 pm
Contact:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by victory1 » Sun Apr 22, 2012 1:48 pm

DavidIQ wrote:When my hosting provider went from 4 to 5 they ran both concurrently for some time and I had the option to use either one on my site. I would expect most hosting providers to do the same or have already upgraded.
You are right about that in my case for 5.2 & 5.3. I actually never bothered to read my host KB. :oops: It was not until this announcement and I realized my host was running PHP 5.2.17 that I inquire about 5.3; only to be told that 5.3.x was always available to be. Anyway, I switched to 5.3.6 which was the version that my host was running at the time but recently it was upgraded to 5.3.10

So my advice to others is to check with their host or read their KB. ;) 5.3.x might be available to you but you might not be aware.

fac7orx
Registered User
Posts: 43
Joined: Sun Dec 28, 2008 6:49 pm

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by fac7orx » Wed Apr 25, 2012 6:37 am

Can anyone comment on godaddy? My control panel there says 5.2 :(.
PHP Version: PHP 5.2
Anyone know of a way to get 5.3 on there?

Post Reply

Return to “phpBB Discussion”