Page 4 of 8

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Wed Sep 05, 2012 7:42 pm
by krafyt
Highly effective host I have. Asked them to do the upgrade and received an answer 5 mins later:

"Upgrade in progress. Will be finished within in 30 mins."

:D

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Fri Sep 07, 2012 3:12 pm
by Freethinkaluva
This is the first I've heard of version 5. At the top of my ACP I just noticed that it said:
"The version of PHP on this server will no longer be supported by future versions of phpBB."
and then gave a link to - viewtopic.php?f=14&t=2152375

We just updated to version 3.0.11 so, how much time do I have? Will it be basically like any other version update?

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Fri Sep 07, 2012 4:46 pm
by EXreaction
PHP is not the same as phpBB.

PHP is software your host must manage on their server, you need to contact them to do the update.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Fri Sep 07, 2012 10:13 pm
by Lumpy Burgertushie
and I believe that "future versions of phpbb" is referring to phpbb3.1 and not any of the phpbb 3.0.x versions.


robert

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Fri Sep 07, 2012 11:30 pm
by bantu
Lumpy Burgertushie wrote:and I believe that "future versions of phpbb" is referring to phpbb3.1 and not any of the phpbb 3.0.x versions.
That's correct.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Sep 09, 2012 8:09 pm
by noth
if you go into cPanel or phpMyAdmin, whereabouts do you go to see what php version the hosts are running?

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Sep 09, 2012 8:25 pm
by HGN
You can see the php version through the phpBB's Administration Control Panel - PHP Information.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Mon Sep 10, 2012 1:36 am
by Jessica
unless Phpinfo() has been disabled for security reasons :/ it's like that for mine. but I don't need to worry about my version.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Mon Sep 10, 2012 2:19 am
by Lumpy Burgertushie
Jessica wrote:unless Phpinfo() has been disabled for security reasons :/ it's like that for mine. but I don't need to worry about my version.
are you saying that the link is in your admin panel but your host has disabled it for security reasons?

or, are you saying that the link is not there which means that you are apparently using a free forum host or a one click install from your hosting control panel?


robert

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Mon Sep 17, 2012 5:23 pm
by Jessica
Lumpy Burgertushie wrote:
Jessica wrote:unless Phpinfo() has been disabled for security reasons :/ it's like that for mine. but I don't need to worry about my version.
are you saying that the link is in your admin panel but your host has disabled it for security reasons?

or, are you saying that the link is not there which means that you are apparently using a free forum host or a one click install from your hosting control panel?


robert
the first one. my host (x10hosting) has disabled it. though I managed to get the version in "Send statistical information"...so it's 5.3.16 (though apparently before it was 5.3.8...wrote it was that in my last post in this topic)

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Tue Sep 25, 2012 6:26 pm
by keith10456
I'm on 5.3.16 as well (JustHost). My other option is 5.4 which another one of my major scripts (which utilizes Zend Guard) doesn't run on 5.4 (because Zend Guard doesn't currently support 5.4) :?

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Oct 14, 2012 3:31 pm
by VickiFletcher
If this is not the appropriate place to ask this, would someone be kind enough to let me know where to post.

I do want to be able to use the latest version, Ascraeus, when it's released.
(Approximately when will that be?)
I am currently hosted by HostGator through a reseller. Therefore, HostGator will NOT talk to me directly, nor can I post on their Forums.
My current version of PHP is 5.2.17, according to my C-Panel.

From reading the HostGator Forum, all I need to do is add the following to the .htaccess file in my public_html directory:

Code: Select all

# Use PHP 5.3
AddType application/x-httpd-php53 .php
Is that addition the only thing I need to do to update to PHP 5.3.2?
What can or will happen after I add it to my .htaccess file?
Does it take much time to accomplish?
Is there any possibility of anything going wrong?
Should I delete the php.ini file in my (/home/forum name) directory prior to editing to the .htaccess file?

I have NO understanding of PHP and very little understanding of phpBB. I do not want anything to go wrong if I do the upgrade.

I would really appreciate any help, input and insight in to making the upgrade to PHP 5.3.2 (or greater).
Thanks,
Vicki

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Oct 14, 2012 3:46 pm
by EXreaction
You must contact your host to resolve hosting related issues. If it is through a reseller, contact your reseller.

We are unable to provide hosting related support because we are not familiar with how the server is setup, so anything we may suggest is likely to be wrong.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Oct 14, 2012 3:48 pm
by tbackoff
VickiFletcher wrote:I do want to be able to use the latest version, Ascraeus, when it's released.
(Approximately when will that be?)
There is currently no specific date for when phpBB 3.1.x will be released (it's not even in beta yet).
VickiFletcher wrote:I am currently hosted by HostGator through a reseller. Therefore, HostGator will NOT talk to me directly, nor can I post on their Forums.
My current version of PHP is 5.2.17, according to my C-Panel.

From reading the HostGator Forum, all I need to do is add the following to the .htaccess file in my public_html directory:

Code: Select all

# Use PHP 5.3
AddType application/x-httpd-php53 .php
Is that addition the only thing I need to do to update to PHP 5.3.2?
What can or will happen after I add it to my .htaccess file?
Does it take much time to accomplish?
Is there any possibility of anything going wrong?
Should I delete the php.ini file in my (/home/forum name) directory prior to editing to the .htaccess file?
Have you tried asking the reseller? As for the code to your .htaccess, I seem to remember reading that somewhere. However, you should really contact the reseller to see what they have to say.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Oct 14, 2012 4:01 pm
by VickiFletcher
t_backoff wrote: There is currently no specific date for when phpBB 3.1.x will be released (it's not even in beta yet).
Ohhhh, so then there isn't any rush to get this done then. That's good to know.
t_backoff wrote: Have you tried asking the reseller? As for the code to your .htaccess, I seem to remember reading that somewhere. However, you should really contact the reseller to see what they have to say.
The reseller I have wouldn't know the answer(s). He just has a couple of users that he hosts and gives us the access for free.

Thanks for the information!
Vicki