Page 1 of 8

[Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Posted: Sat Mar 10, 2012 2:12 am
by DavidIQ
Use this topic to discuss the recent announcement of phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sat Mar 10, 2012 3:48 am
by Danielx64
All I can say right now is YES YES YES. Also considering that php 5.4.0 is out, it would be a good time to upgrade to php 5.3.x if one have not done so.

Now phpbb already support php 5.4.0 right?

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sat Mar 10, 2012 4:00 am
by Peter77sx
That's unfortunate. Maybe if I forward the announcement to my hosting, it will be a cool incentive to upgrade.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sat Mar 10, 2012 4:25 am
by /a3
Peter77sx wrote:That's unfortunate. Maybe if I forward the announcement to my hosting, it will be a cool incentive to upgrade.
I imagine phpBB 3.0 will be supported for at least a year after phpBB 3.1 has been released. And phpBB 3.1 hasn't been released yet, either.

But of course most people will be looking forward to the newest, latest and greatest version so far. :)

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sat Mar 10, 2012 6:32 am
by Elias
*Daniel wrote:All I can say right now is YES YES YES. Also considering that php 5.4.0 is out, it would be a good time to upgrade to php 5.3.x if one have not done so.
Yes sir!!

Glad to see it get accepted after a huge discussion at area51!
*Daniel wrote:Now phpbb already support php 5.4.0 right?
Oleg wrote:The next major release of phpBB, phpBB 3.1 "Ascraeus", will require PHP 5.3.2 or newer.
Thanks

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sat Mar 10, 2012 6:38 am
by callumacrae
Peter77sx wrote:That's unfortunate. Maybe if I forward the announcement to my hosting, it will be a cool incentive to upgrade.
Don't worry, 3.1 is a while off yet - they've got plenty of time to upgrade.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sat Mar 10, 2012 8:12 am
by MichaelC
3.0 will be supported for a while after 3.1 is released. Just as phpBB 2.0 was supported for a while after phpBB 3.0 was released.

This was announced a long time ago here.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sat Mar 10, 2012 8:37 pm
by keith10456
Glad to hear it... :!:

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Mar 11, 2012 3:08 am
by Jessica
hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Mar 11, 2012 10:29 am
by brunoais
Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Mar 11, 2012 12:02 pm
by callumacrae
brunoais wrote:
Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .
Actually, we only updated to 5.3 about six months ago.

Now I just have to start bugging Corey about 5.4…

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Mar 11, 2012 5:53 pm
by brunoais
callumacrae wrote:
brunoais wrote:
Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .
Actually, we only updated to 5.3 about six months ago.

Now I just have to start bugging Corey about 5.4…
What? phpbb.com is hosted at x10hosting?

I think it has php 5.3 longer than that. I remember long ago doing stuff for php 5.3.* about 10 months ago or so.

Edit:
The update to php 5.3 was confirmed at 2/08/2011, 8 months ago.
callumacrae wrote: Now I just have to start bugging Corey about 5.4…
Let's do that by 5.4.2+. Before that there will be some fixing like there was with 5.3.*. No need to bug before that, I don't believe they will follow anyway.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Sun Mar 11, 2012 6:05 pm
by MichaelC
brunoais wrote:
callumacrae wrote:
brunoais wrote:
Jessica wrote:hmm I don't have to worry. my php version is 5.3.8 so I guess I'm good
x10hosting is used to keep the php version updated ;) .
Actually, we only updated to 5.3 about six months ago.

Now I just have to start bugging Corey about 5.4…
What? phpbb.com is hosted at x10hosting?

I think it has php 5.3 longer than that. I remember long ago doing stuff for php 5.3.* about 10 months ago or so.

Edit:
The update to php 5.3 was confirmed at 2/08/2011, 8 months ago.
callumacrae wrote: Now I just have to start bugging Corey about 5.4…
Let's do that by 5.4.2+. Before that there will be some fixing like there was with 5.3.*. No need to bug before that, I don't believe they will follow anyway.
No. Callum works at x10hosting.

phpBB.com is on two servers hosting by OSUOSL.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Tue Mar 13, 2012 9:30 am
by DoYouSpeakWak
5.4.0 is out but its not ready yet. Many of the php- modules havnt been updated yet.

But 5.3.2 or higher is in all the ubuntu, debian, fedora releases. Centos im not sure about. But anyone still running older php is a crappy host anyway. So no problems here im sure by the time 3.1 comes out 5.4 will be standard in most setups.

Re: [Discuss] phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Posted: Tue Mar 13, 2012 5:12 pm
by victory1
I see on my cpanel that my host is using PHP 5.2.17, when I inquire when they will switch to 5.3, I was told how to switch to PHP 5.3.x?

By default, we use PHP 5.2.x on our systems, however if you wish to run PHP 5.3.x, please add the following line to your public_html .htaccess file:

AddType application/x-httpd-php53 php53 php

So just because your host is running 5.2, does not mean that 5.3 is not available. My ACP PHP Information says PHP Version 5.3.6