[Discuss] AutoMOD 1.0.2 released

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Suggested Hosts
User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [Discuss] AutoMOD 1.0.2 released

Post by Jessica »

automat01 wrote:is it ok to use automod to update itself? After doing this, I couldn't install any other mods, I got an SQL error when writing in phpbb_mods table saying that 'mod_contribs' column didn't exist. I tried uploading and updating automod manually but the column was still missing. I finally uninstalled/reinstalled automod 1.0.2 and everything is fine now. Is that a bug with the update or just me that shouldn't have used automod in the first place?
Yes -- https://www.phpbb.com/customise/db/offi ... /faq/f_788

You must have forgotten to run the install script to add in the tables...
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein
automat01
Registered User
Posts: 17
Joined: Mon Feb 07, 2011 2:48 am

Re: [Discuss] AutoMOD 1.0.2 released

Post by automat01 »

I'm pretty sure i ran it, i even recopied the install folder for this, but since i'm the only one that got this issue you must be right, most likely i forgot something somewhere... It was on a test forum so... I'll try it again and see what happens.
VitaminK
Registered User
Posts: 5
Joined: Sun Aug 05, 2012 4:06 am

Re: [Discuss] AutoMOD 1.0.2 released

Post by VitaminK »

I copied all the files over but there is nothing on my install/index.php page about AutoMod install?
User avatar
Lumpy Burgertushie
Registered User
Posts: 68307
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [Discuss] AutoMOD 1.0.2 released

Post by Lumpy Burgertushie »

VitaminK wrote:I copied all the files over but there is nothing on my install/index.php page about AutoMod install?
if you have the right files in the right place, then your board should give you an error about deleting the install folder.

also, if you have the right files in the right place then the install/index.php file should have this as the first few lines of code in it:

Code: Select all

* @ignore
*/
define('UMIL_AUTO', true);
define('IN_PHPBB', true);
define('IN_INSTALL', true);
$phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : '../';
$phpEx = substr(strrchr(__FILE__, '.'), 1);
include($phpbb_root_path . 'common.' . $phpEx);
$user->session_begin();
$auth->acl($user->data);
$user->setup();

if (!file_exists($phpbb_root_path . 'umil/umil_auto.' . $phpEx))
{
	trigger_error('Please download the latest UMIL (Unified MOD Install Library) from: <a href="http://www.phpbb.com/mods/umil/">phpBB.com/mods/umil</a>', E_USER_ERROR);
}

include($phpbb_root_path . 'includes/functions_mods.'.$phpEx);

// The name of the mod to be displayed during installation.
$mod_name = 'AUTOMOD';

/*
* The name of the config variable which will hold the currently installed version
* You do not need to set this yourself, UMIL will handle setting and updating the version itself.
*/
$version_config_name = 'automod_version';
it those two things are not true then you still have not uploaded the correct files into the correct place.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
VitaminK
Registered User
Posts: 5
Joined: Sun Aug 05, 2012 4:06 am

Re: [Discuss] AutoMOD 1.0.2 released

Post by VitaminK »

I havent tried deleting the install folder yet? I thought I needed to keep that to install AutoMod?

I do not see that in my index.php file either...



Everything I've done;
Install fresh phpbb forum > upload automod files to /phpbb3/ > go back to url install/index.php > don't see what I'm missing :|
User avatar
Lumpy Burgertushie
Registered User
Posts: 68307
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [Discuss] AutoMOD 1.0.2 released

Post by Lumpy Burgertushie »

VitaminK wrote:I havent tried deleting the install folder yet? I thought I needed to keep that to install AutoMod?

I do not see that in my index.php file either...



Everything I've done;
Install fresh phpbb forum > upload automod files to /phpbb3/ > go back to url install/index.php > don't see what I'm missing :|
when you install phpbb there is a folder named install. you go there to install phpbb. after it is finished, you have to delete that folder.

when you want to install automod, it also uploads a folder named install.

it is not the same install folder that comes with phpbb.

within that folder named install is a index.php file that belongs to automod. it is not the same as the index.php file that belongs to phpbb.

now, phpbb is designed so that if there is a folder named install in the board root ( the same place as the config.php file ) it will not work. It will give you a message that tells you to delete the install folder or the only thing you can access is the admin panel.

That is as it is supposed to be.

However, keep in mind that when you upload the automod files/folders you are not supposed to go to the board index page at all so therefore you would not even see this message.

what you are supposed to be doing is going to the install folder.

yourdomain.com/yourobard/install/index.php

now, as I said earlier, if you have the automod files/folders uploaded correctly then all you have to do is go to the install/index.php file and you will see a page that has a tab that says install.

if you do not, then you do NOT have the automod files/folders uploaded correctly.


I would start over. I would delete all traces of automod from your server.
1. on your computer, create a folder named automod_download
2. download a new version of automod to that folder on your computer.
3. using your ftp program, connect to your server and make sure you have your board root
(you can see the board's config.php file ) in the right hand window of your ftp program.
4. in the left window, navigate to the folder named automod_download and open it.
you should now see all of the automod folders.
5. drag all of the automod folders from the left side to the right side.
you will see folders of the same name on both sides, do not worry about this. if it asks you about overwriting, say yes.
6. in your browser, go to: yourdomain.com/yourboard/install/index.php

7. click on the install tab or button
8. you are done.

If you board is installed in the board root ( yourdomain.com/index.php )
and not in a folder ( yourdomain.com/yourboard/index.php )

then ignore anywhere I have said "yourphpbb" in the instructions and put the files/folders in the board root.


luck,
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
VitaminK
Registered User
Posts: 5
Joined: Sun Aug 05, 2012 4:06 am

Re: [Discuss] AutoMOD 1.0.2 released

Post by VitaminK »

Thank you for the quick reply, what I had done was upload the entire automod folder, not the /root folder within that folder :roll:

I will follow the rest of your instructions and hopefully not have a problem.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68307
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [Discuss] AutoMOD 1.0.2 released

Post by Lumpy Burgertushie »

no, you do not upload the root folder.

you upload the contents of the root folder.

I did not make that clear in my instructions, I am sorry.

you unzip the zip file to your new automod folder.
then, in your ftp, on the left side.
open the root folder

then, drag and drop all of the folders within that root folder to the right side.

not the root folder itself , but all of the contents of it.


sorry about the confusion.

robwert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
VitaminK
Registered User
Posts: 5
Joined: Sun Aug 05, 2012 4:06 am

Re: [Discuss] AutoMOD 1.0.2 released

Post by VitaminK »

I know that, that is what I meant. I got it to work already thanks.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68307
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [Discuss] AutoMOD 1.0.2 released

Post by Lumpy Burgertushie »

VitaminK wrote:I know that, that is what I meant. I got it to work already thanks.
great, good job.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
tbackoff
Former Team Member
Posts: 7064
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: [Discuss] AutoMOD 1.0.2 released

Post by tbackoff »

Seems we need one of these warnings here too...
Please do not post support requests in the this topic. Please post them in the AutoMOD support forum or the AutoMOD support section in the customization database.
Flying is the second best thrill to cheerleaders; being caught is the first.
User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: [Discuss] AutoMOD 1.0.2 released

Post by 1234homie »

What about phpbb3.1?
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17377
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: [Discuss] AutoMOD 1.0.2 released

Post by DavidIQ »

What about it? AutoMOD is irrelevant at this point to 3.1.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [Discuss] AutoMOD 1.0.2 released

Post by sevenalive »

Why isn't AutoMod default in the phpbb download. It is essential. Too many people try and manually edit and make mistakes, wasting mod creators and style creators time.

It's mature enough and I haven't had a problem with it. I do have to manually edit the install.xml's when other mods cause the install to fail.
User avatar
RMcGirr83
Former Team Member
Posts: 21696
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: [Discuss] AutoMOD 1.0.2 released

Post by RMcGirr83 »

For the same reason that the support toolkit and titania aren't included....they are modifications for use in phpBB.
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
Appreciate the extensions/mods/support then buy me a beerImage
Post Reply

Return to “phpBB Discussion”