[Discuss] phpBB 3.1.1 Release - Please Update

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Ideas Centre
User avatar
noth
Registered User
Posts: 2472
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by noth » Sun Nov 02, 2014 7:11 pm

ok cheers :D

User avatar
Volksdevil
Registered User
Posts: 2414
Joined: Sun Oct 03, 2010 2:03 pm
Location: Lancashire, UK
Name: Neil
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Volksdevil » Sun Nov 02, 2014 11:58 pm

Nice and quick update. I always dread them, but they always go smoothly. Just once previously I had an issue I think. Good going over a few years! 8-)
My phpBB Extensions
Finally found great Website Hosting from Image KUALO!
Do NOT use 123-reg.co.uk - Incapable of running phpBB!
:ugeek: TekNeil - Streamer on Mixer | My Volkswagen Corrado G60

User avatar
Dead Man
Registered User
Posts: 241
Joined: Tue Jun 05, 2012 12:35 am

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Dead Man » Mon Nov 03, 2014 7:38 am

I am trying to update from 3.0.12 to the new version but I get these errors.

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/content/54/6674154/html/forums/install/index.php on line 110

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/content/54/6674154/html/forums/install/index.php on line 110

Parse error: syntax error, unexpected T_STRING in /home/content/54/6674154/html/forums/install/index.php on line 110

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25185
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Paul » Mon Nov 03, 2014 7:40 am

You are using a php version lower as 5.3.3, which is the minimum for phpBB 3.1
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

arod-1
Registered User
Posts: 1327
Joined: Mon Sep 20, 2004 1:33 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by arod-1 » Mon Nov 03, 2014 6:51 pm

Paul wrote:You are using a php version lower as 5.3.3, which is the minimum for phpBB 3.1
this seems somehow wrong, no?

this file (install/index.php) has a check for php version at the top. yet, some syntax that depends on php version appear further on (specifically, the namespace stuff at line 110).

i think the right thing would be to exile (almost) all of index.php to another file, leave only the php version check in install.php, and then require this other file once the php version is known to be good.
the error message that appears at the top of install/index.php, and reads

Code: Select all

die('You are running an unsupported PHP version. Please upgrade to PHP 5.3.3 or higher before trying to install phpBB 3.1');
is very reasonable, but b/c those version-dependent features will blow even loading this file, we are left with the cryptic messages Mr. Dead Man reported.

IMO, this is a bug.

peace.

User avatar
naderman
Consultant
Consultant
Posts: 3735
Joined: Fri Aug 01, 2003 10:06 pm
Location: Berlin, Germany
Name: Nils Adermann
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by naderman » Mon Nov 03, 2014 10:06 pm

arod-1 wrote:IMO, this is a bug.
So please report it on the tracker. :-)
I appreciate gifts from my Amazon wishlist.
naderman.de twitter: @naderman

User avatar
Dead Man
Registered User
Posts: 241
Joined: Tue Jun 05, 2012 12:35 am

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Dead Man » Tue Nov 04, 2014 2:03 am

How do I check what PhP Version I have than. I get confused with the 2 Numbers phpBB decided to make.
You guys seem to talk about phpBB 3.1.1 and phpBB 5.3.

You mean Database and BoardVersion? If so than how to I upgrade to the new Database Version?
Also how does that affect my current phpbb Site with the Edits I have made to it?

Image

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 2228
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by kinerity » Tue Nov 04, 2014 2:17 am

Dead Man wrote:You guys seem to talk about phpBB 3.1.1 and phpBB 5.3.
Actually, it's 2 separate things. phpBB (the board software) is 3.1.1, PHP (the programming language) needs to be PHP 5.3.3 or higher. To check this on your 3.0.12 board, click on the SYSTEM tab, then click PHP information in the left hand menu. Your PHP version will be listed.
PHP.png
PHP.png (25.35 KiB) Viewed 2390 times
Kailey Truscott - Community Team

User avatar
Boardtalk.net
Registered User
Posts: 1203
Joined: Fri Jun 05, 2009 8:12 pm
Location: Ireland
Name: Colette
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Boardtalk.net » Tue Nov 04, 2014 2:22 am

Dead Man wrote:How do I check what PhP Version I have than. I get confused with the 2 Numbers phpBB decided to make.
You guys seem to talk about phpBB 3.1.1 and phpBB 5.3.
How to find out what php version you are using...
Go to ACP and on the Top Left (see image)
2014-11-04 02_18_20-ACP index.png
2014-11-04 02_18_20-ACP index.png (12.05 KiB) Viewed 2384 times
Then on the top of the page you will see what php version you are using, like mine in the image below;
2014-11-04 02_19_50-PHP information.png
2014-11-04 02_19_50-PHP information.png (5.25 KiB) Viewed 2383 times

User avatar
Boardtalk.net
Registered User
Posts: 1203
Joined: Fri Jun 05, 2009 8:12 pm
Location: Ireland
Name: Colette
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Boardtalk.net » Tue Nov 04, 2014 2:24 am

Snap kinerity :)

Pony99CA
Registered User
Posts: 4783
Joined: Thu Sep 30, 2004 3:13 pm
Location: Hollister, CA
Name: Steve
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Pony99CA » Tue Nov 04, 2014 2:53 am

Did the 3.1.1 update also fix the annoying "new" Private Message notifications (which is really an unread PM)? Or did it at least contain a way to easily find unread PMs?

It wasn't mentioned, so I'm guessing that it didn't, but I thought that I'd ask just to be sure.

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29247
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Marshalrusty » Tue Nov 04, 2014 4:55 am

Pony99CA wrote:Did the 3.1.1 update also fix the annoying "new" Private Message notifications (which is really an unread PM)? Or did it at least contain a way to easily find unread PMs?

It wasn't mentioned, so I'm guessing that it didn't, but I thought that I'd ask just to be sure.
No, we didn't quite get to that in this small release. It's in the tracker, however, so no chance of us forgetting :)
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

User avatar
Dead Man
Registered User
Posts: 241
Joined: Tue Jun 05, 2012 12:35 am

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Dead Man » Tue Nov 04, 2014 7:34 am

kinerity wrote:
Dead Man wrote:You guys seem to talk about phpBB 3.1.1 and phpBB 5.3.
Actually, it's 2 separate things. phpBB (the board software) is 3.1.1, PHP (the programming language) needs to be PHP 5.3.3 or higher. To check this on your 3.0.12 board, click on the SYSTEM tab, then click PHP information in the left hand menu. Your PHP version will be listed.
PHP.png
Alright thanks I found it.

It is PHP Version 5.2.17

So what should be my next steps now?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29247
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Marshalrusty » Tue Nov 04, 2014 7:42 am

Look in your host's Control Panel to see if you can select a PHP version there.

If not, contact them and ask for something newer than 5.3.3
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

User avatar
mamba
Registered User
Posts: 432
Joined: Thu Jan 16, 2003 7:59 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by mamba » Tue Nov 04, 2014 7:59 am

I must thank the team for this update. I came from 3.0.12 and now my board can be viewed properly on tablets and phones — wonderful! I was worrying about phpbb's lack of responsive design off and on for a few years now. So the update was sorely needed.

I did have a few problems converting but it was worth the hassle. ;)

One complaint: I got an email notifying me to update the board from 3.0.12 to 3.1 (which I thought was spam from someone), but then when I got the 3.1.1 email I thought I'd better check here and saw the announcement, downloaded it thinking it was a normal update, then BAM! -- problems, new functionality, everything switched around, etc, all with no warning.

Now when software like Firefox updates they always have a page explaining exactly what's changed and where things have been moved to, what the new methods are to do x and y etc. I would have liked that. If it exists and I've missed it, please forgive me, but since it was not pushed into my face, as it should have been, I suspect some blame lies with the developers...

But anyway, thanks for the new software. I use it many times a day!
Using 3.2, PHP version 7, MySQL 5.5, Host: hostgator shared Linux, Style: Prosilver

Post Reply

Return to “phpBB Discussion”