[Discuss] phpBB 3.1.1 Release - Please Update

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Suggested Hosts
LavIgor
Registered User
Posts: 545
Joined: Mon Apr 28, 2014 1:47 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by LavIgor »

mamba wrote:That's closer, thanks. Put a link to that in the Announcement.

Still, it's not a document that concentrates on what's changed from 3.0 to 3.1

There really is a need for such a document, if anyone has the time....
Have you looked at the wiki?
https://wiki.phpbb.com/PhpBB3.1
https://wiki.phpbb.com/PhpBB3.1/RFC

User avatar
mamba
Registered User
Posts: 462
Joined: Thu Jan 16, 2003 7:59 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by mamba »

LavIgor wrote:
mamba wrote:Still, it's not a document that concentrates on what's changed from 3.0 to 3.1. There really is a need for such a document, if anyone has the time....
Have you looked at the wiki?
https://wiki.phpbb.com/PhpBB3.1
https://wiki.phpbb.com/PhpBB3.1/RFC
Unfortunately, while those documents are very interesting to me (because I do make changes to the code), they are still not useful to a non-technical admin who simply wants to know, for instance, why she no longer gets emails to approve new registrations.
Using 3.3, PHP version 7.1, MySQL 5.6, Host: hostgator shared Linux, Style: Prosilver

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69635
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by KevC »

mamba wrote: they are still not useful to a non-technical admin who simply wants to know, for instance, why she no longer gets emails to approve new registrations.
Approval by admin is the only one that does that. That hasn't changed.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
mamba
Registered User
Posts: 462
Joined: Thu Jan 16, 2003 7:59 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by mamba »

Using 3.3, PHP version 7.1, MySQL 5.6, Host: hostgator shared Linux, Style: Prosilver

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69635
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by KevC »

Notification of new accounts only happened in 3.0 with 'by admin'. That hasn't been changed. There isn't a setting to turn it off.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
mamba
Registered User
Posts: 462
Joined: Thu Jan 16, 2003 7:59 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by mamba »

You don't seem to understand the issue. Read the thread I linked carefully.
Using 3.3, PHP version 7.1, MySQL 5.6, Host: hostgator shared Linux, Style: Prosilver

Peter77sx
Registered User
Posts: 3259
Joined: Wed Nov 09, 2005 2:51 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Peter77sx »

mamba wrote:You don't seem to understand the issue. Read the thread I linked carefully.
Your posting all over the place about your issue :) it would probably help others help you better if you started a new topic in the support forum and not on someone else s topic or in phpbb discussion . :)

User avatar
mamba
Registered User
Posts: 462
Joined: Thu Jan 16, 2003 7:59 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by mamba »

That's not "my issue". That's resolved, but the fact remains it would never have been an issue with proper documentation. Ok, point made (I hope). I'm out of this thread.
Using 3.3, PHP version 7.1, MySQL 5.6, Host: hostgator shared Linux, Style: Prosilver

User avatar
Koymc Dox
Registered User
Posts: 26
Joined: Sun Jul 08, 2007 5:57 pm
Location: Indianapolis

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by Koymc Dox »

I had a bit of a delay in doing the upgrade from 3.0.12, and during that delay 3.1.1 came out.

But I did the upgrade today, and it was smooth as glass. Having run Betas and RCs, I even had my custom style ready for 3.1x.

Thanks for a great product, folks.
:)
"You're controlling one of the elemental forces of the universe one minute, the next you're giggling about lingerie. I can't allow myself to think about it or the paradox would give me an aneurism."

arifur
Registered User
Posts: 11
Joined: Fri Aug 10, 2012 12:02 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by arifur »

Backin the day it used to take months if not years for new releases of phpbb. I am very gratefull for the frequent releases and bug fixes.

User avatar
freddie
Registered User
Posts: 404
Joined: Sun Mar 31, 2002 1:40 pm
Location: Estes Park, USA
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by freddie »

I downloaded the latest phpbb3 version and automod, but I was unable to get automod working on this version. lots of files from the 'includes' folder were missing ?

User avatar
pit-PL
Registered User
Posts: 3090
Joined: Sat Nov 21, 2009 12:24 pm

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by pit-PL »

Where did you get the AutoMOD for phpBB 3.1 from?

User avatar
freddie
Registered User
Posts: 404
Joined: Sun Mar 31, 2002 1:40 pm
Location: Estes Park, USA
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by freddie »

it was the 3.0 one, now i know why it failed, urghl

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69635
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by KevC »

freddie wrote:it was the 3.0 one, now i know why it failed, urghl
3.1 uses extensions, not MODs. You just upload them to the right folder and activate them in the admin panel. No core code changes should be necessary, hence no autoMOD for 3.1,
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

tay666
Registered User
Posts: 12
Joined: Sat Dec 03, 2011 3:55 am

Re: [Discuss] phpBB 3.1.1 Release - Please Update

Post by tay666 »

kinerity wrote:Your server must be running PHP 5.3.3 or higher. If you meet that requirement (as well as the other requirements), then you're fine.
And if our host won't upgrade, what are our options?
How long will the older version be supported?

Post Reply

Return to “phpBB Discussion”