Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Ideas Centre
Post Reply
sbafta
Registered User
Posts: 22
Joined: Sun Mar 03, 2013 11:25 pm

Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by sbafta » Thu Oct 12, 2017 5:11 am

Greetings All;

I didn't find a good answer in my search of the forums here.

The host that we have our forum on has invited us to upgrade the PHP to either 7 or 7.1.

Does phpBB 3.2.1 work well with PHP 7 or 7.1? Has anyone else noticed any problems?

Please advise.

Thank you.

User avatar
david63
Jr. Extension Validator
Posts: 13198
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by david63 » Thu Oct 12, 2017 5:57 am

phpBB 3.2 and greater have been specifically designed to run on PHP7 (and greater) and do so without any problems. You will find many users on here are running phpBB 3.2.1 on PHP7.1
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

sbafta
Registered User
Posts: 22
Joined: Sun Mar 03, 2013 11:25 pm

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by sbafta » Thu Oct 12, 2017 6:56 am

Wow, thank you david63.

User avatar
AmigoJack
Registered User
Posts: 5005
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by AmigoJack » Thu Oct 12, 2017 7:59 am

sbafta wrote:
Thu Oct 12, 2017 5:11 am
I didn't find a good answer in my search of the forums here.
Have you considered looking up the software requirements in the Support > Documentation > 3.2?
The worst thing about censorship is ███████████

Heo32
Registered User
Posts: 55
Joined: Sat Jan 07, 2017 10:08 pm

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by Heo32 » Thu Oct 12, 2017 8:48 pm

david63 wrote:
Thu Oct 12, 2017 5:57 am
You will find many users on here are running phpBB 3.2.1 on PHP7.1
I'm one of them. No issues. :)

User avatar
Ancient Viking
Registered User
Posts: 385
Joined: Sun Jan 15, 2012 11:43 pm

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by Ancient Viking » Tue Oct 31, 2017 8:49 pm

Heo32 wrote:
Thu Oct 12, 2017 8:48 pm
david63 wrote:
Thu Oct 12, 2017 5:57 am
You will find many users on here are running phpBB 3.2.1 on PHP7.1
I'm one of them. No issues. :)
Me too without having a single issue. :)
My local forum: egetforum.nu - Offline Forum Online!

photosa
Registered User
Posts: 204
Joined: Wed Mar 23, 2005 2:35 pm
Location: South Africa
Contact:

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by photosa » Thu Nov 16, 2017 10:43 am

I upgraded to php 7.1 and then got the message below. Went back to php 5.6.32 and now working again.
I am on phpbb 3.2.1

General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 67329
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by KevC » Thu Nov 16, 2017 10:52 am

photosa wrote:
Thu Nov 16, 2017 10:43 am
I upgraded to php 7.1 and then got the message below. Went back to php 5.6.32 and now working again.
I am on phpbb 3.2.1

General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
That's well documented and simple to fix
viewtopic.php?f=556&p=14635916
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

photosa
Registered User
Posts: 204
Joined: Wed Mar 23, 2005 2:35 pm
Location: South Africa
Contact:

Re: Does phpBB 3.2.1 Run Well With PHP version 7 or Higher

Post by photosa » Thu Nov 16, 2017 11:04 am

Thanx, it worked

Post Reply

Return to “phpBB Discussion”

Who is online

Users browsing this forum: Dev222 and 25 guests