Page 4 of 5

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 9:11 am
by Mick
Lumpy Burgertushie wrote:
Sat Nov 17, 2018 4:42 am
John connor wrote:
Sat Nov 17, 2018 4:05 am
. . . what is a stache?
It's short for moustache but Bertie is too young to grow one yet.

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 8:43 pm
by Jphammer
Crizzo wrote:
Tue Nov 20, 2018 12:04 pm
Jphammer wrote:
Tue Nov 20, 2018 12:02 pm
Iv'e updated to 3.2.4 and I'm now getting white page when clicking on some topics but other topics are fine.

I can created topics and comment with no problems .

Please could someone help ?
Did you apply these changes: viewtopic.php?f=556&t=2492371 ?
I have just applied those changes and its has worked , thank you .

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 9:03 pm
by Jphammer
I've tried to register as test account on my forum and im getting the following SQL Error

" Field 'mobile_password' doesnt have a default vale {1364} "

its only since the update the error has appeared . Is anyone else getting the same?

Please could someone help ?

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 9:16 pm
by warmweer
Jphammer wrote:
Thu Nov 22, 2018 9:03 pm
I've tried to register as test account on my forum and im getting the following SQL Error

" Field 'mobile_password' doesnt have a default vale {1364} "
That a phpBB support question or (I think) an extension support Q (field mobile password?)

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 9:31 pm
by GanstaZ
I don't think that there is any mobile password field in vanilla phpbb at least i haven't seen any. Smells more like an extension error.

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 10:57 pm
by Jphammer
warmweer wrote:
Thu Nov 22, 2018 9:16 pm
Jphammer wrote:
Thu Nov 22, 2018 9:03 pm
I've tried to register as test account on my forum and im getting the following SQL Error

" Field 'mobile_password' doesnt have a default vale {1364} "
That a phpBB support question or (I think) an extension support Q (field mobile password?)
I've disabled all my extensions but still no luck . they are all updated as well.

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 10:58 pm
by Jphammer
GanstaZ wrote:
Thu Nov 22, 2018 9:31 pm
I don't think that there is any mobile password field in vanilla phpbb at least i haven't seen any.
First thing i looked for, but cant see any options for it .

Re: Discuss: phpBB 3.2.4 Release

Posted: Thu Nov 22, 2018 11:01 pm
by Lumpy Burgertushie
since mobile password is not part of standard phpbb I would assume you need to either remove the module for it in your admin panel or search the database for that field and remove whatever it is from the database.

and I can't find any reference to that field on phpbb.com or even using google.


robert

Re: Discuss: phpBB 3.2.4 Release

Posted: Mon Nov 26, 2018 10:43 am
by Ambis
Do you guys have thumbnails working after updating to 3.2.4?

PHPInfo in phpbb3 admin shows the GD section and says it is enabled. I checked the Attachment options and everything should point it to being able to create thumbnails, but when I upload a 20 MB 2000x7000 file, it still shows the whole full image in the post. I can't find anything that's causing this.

Edit: My current live board does generate thumbnails with the same settings with 3.2.3. Some images, with Open Image from the post opens a link with &t=1 query param. My dev site does not do this.

Re: Discuss: phpBB 3.2.4 Release

Posted: Mon Nov 26, 2018 11:13 am
by canonknipser
Ambis wrote:
Mon Nov 26, 2018 10:43 am
when I upload a 20 MB 2000x7000 file, it still shows the whole full image in the post.
Did you check the php error logs and server error logs for any "silent" error from the gd functions, like running out of memory?

As a alternative to gd, I developed a little extension using ImageMagick in a safe way to generate thumbnails.
The extension is just submitted to the extension DB for verification: viewtopic.php?f=456&t=2492941 I suggest not to use it on a live board prior verification.

Re: Discuss: phpBB 3.2.4 Release

Posted: Mon Nov 26, 2018 11:26 am
by HiFiKabin
Ambis wrote:
Mon Nov 26, 2018 10:43 am
Do you guys have thumbnails working after updating to 3.2.4?

PHPInfo in phpbb3 admin shows the GD section and says it is enabled. I checked the Attachment options and everything should point it to being able to create thumbnails, but when I upload a 20 MB 2000x7000 file, it still shows the whole full image in the post. I can't find anything that's causing this.

Edit: My current live board does generate thumbnails with the same settings with 3.2.3. Some images, with Open Image from the post opens a link with &t=1 query param. My dev site does not do this.
If you require support, please post your problem there

Re: Discuss: phpBB 3.2.4 Release

Posted: Mon Nov 26, 2018 11:28 am
by Ambis
canonknipser wrote:
Mon Nov 26, 2018 11:13 am
Did you check the php error logs and server error logs for any "silent" error from the gd functions, like running out of memory?
There's no errors in the logs :/ Not in phpbb3 logs and not in php logs.
canonknipser wrote:
Mon Nov 26, 2018 11:13 am
As a alternative to gd, I developed a little extension using ImageMagick in a safe way to generate thumbnails.
The extension is just submitted to the extension DB for verification: viewtopic.php?f=456&t=2492941 I suggest not to use it on a live board prior verification.
So cool! :!: I subbed to the topic to wait for info about approval. Did you / can you add image reorientation using orientation metadata?

Re: Discuss: phpBB 3.2.4 Release

Posted: Mon Nov 26, 2018 11:29 am
by Ambis
HiFiKabin wrote:
Mon Nov 26, 2018 11:26 am
If you require support, please post your problem there
Not requiring support, only asking if others are having the same problem. If none do, then I'll keep debugging it on my own.

Re: Discuss: phpBB 3.2.4 Release

Posted: Mon Nov 26, 2018 1:02 pm
by JimA
Ambis wrote:
Mon Nov 26, 2018 11:29 am
HiFiKabin wrote:
Mon Nov 26, 2018 11:26 am
If you require support, please post your problem there
Not requiring support, only asking if others are having the same problem. If none do, then I'll keep debugging it on my own.
To help you start off debugging, you might want to read the section related to the fixed security issue on 3.2.4 in the announcement over here: viewtopic.php?f=14&t=2492206

I don't know the specifics myself, but it's related to the way thumbnails are generated, so that could very well be the cause of your problem. Like HiFiKabin said though, if you require further help on the issue, it'd be best to post in the support forums, for clarity's sake. :)

Re: Discuss: phpBB 3.2.4 Release

Posted: Mon Nov 26, 2018 10:00 pm
by Jphammer
Has anyone had issues with Youtube video's appearing since updating to 3.2.4 ?

On previous verison i was able to just put the link in and it would diplay the video.