Page 1 of 1

*HELP: pbb Unix Timestamp not updating*

Posted: Tue Apr 09, 2019 12:35 am
by ArtWithoutRules
Hello everyone,

So I'm currently building a forum and I want to set all of the announcement posts to the same time and date.

I've changed the post_time Unix in pbb_posts, purged the ACP cache, yet it doesn't seem to be updating on the front end.

Any idea why this is the case?

Any help is appreciated.

Cheers.

Re: *HELP: pbb Unix Timestamp not updating*

Posted: Tue Apr 09, 2019 6:14 am
by mrgoldy
I am guessing tou are refering to the post times shown on the board index, the last post column. These times are stored inside the forums table, and you’ll have to adjust those aswell. (If the last post is actually one of those Announcements.

You might have to check the topics table for first and last post data too.

Otherwise, if you are viewing the topic from within ‘viewtopic.php’ and you do not see the correct time, then you have not adjusted the times in the posts table correctly.

First and last post information are often stored in other columns aswell, so information can be displayed without having to make addiotonal queries to different tables.

Re: *HELP: pbb Unix Timestamp not updating*

Posted: Tue Apr 09, 2019 6:18 am
by david63

Re: *HELP: pbb Unix Timestamp not updating*

Posted: Tue Apr 09, 2019 9:04 am
by ArtWithoutRules
mrgoldy wrote:
Tue Apr 09, 2019 6:14 am
These times are stored inside the forums table, and you’ll have to adjust those aswell.
Hey MrGoldy, I've edited the post_time in pbb_forums and that seems to have resolved the issue! Thanks a bunch! :D