Install phpBB on pc

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Suggested Hosts
furm
Registered User
Posts: 13
Joined: Sun Jun 14, 2020 7:14 pm

Re: Install phpBB on pc

Post by furm »

I am getting the error below when I clearly have php installed.

"You are running an unsupported PHP version. Please upgrade to PHP 7.1.3 or higher before trying to install or update to phpBB 3.3"

Here is what my php file looks like.

https://imgur.com/a/iRZW0BX

Any help?

Thanks.
User avatar
warmweer
Jr. Extension Validator
Posts: 4907
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Install phpBB on pc

Post by warmweer »

The message is clear:
You're trying to install or update to phpBB 3.3 but using php 5.x.
You're using Usbwebserver 8.6 or 8.6.1 but for phpBB3.3 you need UsbWebserver 8.6.2 with php 7.1
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
3Di
Former Team Member
Posts: 15846
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Install phpBB on pc

Post by 3Di »

warmweer wrote:
Fri Jul 03, 2020 6:05 am
You're trying to install or update to phpBB 3.3 but using php 5.x.
It could also be PHP 7.0.x, same applies though.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Looking for a specific feature or alternative option?
User avatar
warmweer
Jr. Extension Validator
Posts: 4907
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Install phpBB on pc

Post by warmweer »

3Di wrote:
Fri Jul 03, 2020 6:10 am
It could also be PHP 7.0.x, same applies though.
In this case it's clearly php 5 (5.6 or 5.4 depending on the version of USBWebserver)
php7 would have php7apache2_4.dll
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
3Di
Former Team Member
Posts: 15846
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Install phpBB on pc

Post by 3Di »

Sure, what I meant is phpBB 3.3.x needs at least PHP 7.1.3 hence that error message (I know it) can be shown to everybody running a lesser version, that's for future readers. About that toy (USBserver) I am not an expert, thanks god. :)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Looking for a specific feature or alternative option?
Post Reply

Return to “phpBB Discussion”