php 8.0 works fine!!!!!!!!!!

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Anti-Spam Guide
yotsuba
Registered User
Posts: 22
Joined: Fri Dec 25, 2020 9:23 am

php 8.0 works fine!!!!!!!!!!

Post by yotsuba »

Hi!!!! I got the latest download of phpbb in the zip file, and it installed/rins in sqlite3 mode just fine with php8!!!!!!!!!!!!! How come ppl say that phpbb is not compatible with php8 yet? Mine seems to work fine!!!!!!!!!!!!!!!!! :D :D :D
Last edited by Mick on Wed Dec 30, 2020 10:59 am, edited 1 time in total.
Reason: Solved
User avatar
david63
Registered User
Posts: 18828
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: php 8.0 works fine!!!!!!!!!!

Post by david63 »

Just because you have not encountered any problems yet does not mean that there aren't any.
yotsuba wrote:
Tue Dec 29, 2020 8:34 am
How come ppl say that phpbb is not compatible with php8 yet?
Because there are issues reported in the Bug Tracker that have not been fixed in a released version of phpBB.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
yotsuba
Registered User
Posts: 22
Joined: Fri Dec 25, 2020 9:23 am

Re: php 8.0 works fine!!!!!!!!!!

Post by yotsuba »

ahhh. well at least its not totally messed up, which is a great sign! 8-) :D
User avatar
ssl
Registered User
Posts: 459
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: php 8.0 works fine!!!!!!!!!!

Post by ssl »

Hi
I try it on my test forum 8.0.0RC4 version

Capture d’écran 2020-12-29 à 09.58.31.png
Sorry for my English ... I do my best!
yotsuba
Registered User
Posts: 22
Joined: Fri Dec 25, 2020 9:23 am

Re: php 8.0 works fine!!!!!!!!!!

Post by yotsuba »

Stop the presses :shock: :shock: :shock: Yeah, I did end up having probs with php8. When i installed prosilver SE and then the "Pages" extention, it kept breaking totally- blank screen. I tried a few times to make sure it was not me. Just as a fyi, xenforo forum software is the only to work with php8. Wordpress does not work with php8 yet, wikimedia has been lagging a long time, they are only supporting like php 7.2 or 7.3. Its interesting, someone should make a website saying what DOES work with php 8 :lol:

Now, i notice that every site says---oah, whats the rush blah blah. Here is what i think about that. WELL, ppl knew php 8 was coming out. In fact, MONTHS ago when the beta versions of php8 were avail, they should have immediately begin testing!!!! Maybe people want to wait till php8 is about a month from not being supported any more then they will make the popular programs work with php8? :roll: :roll: :roll: :roll:

PHP is supposed to be one of the easiest to learn and use, and php8 has improvements to include security, and not allowing so much dangerous or bad code as php 5 did. Php 8 is absolutely better, THAT is the rush, dammit! Everyone should only use php8 and above, and the world would be a better place yay :lol: :D ;) 8-) :mrgreen:
yotsuba
Registered User
Posts: 22
Joined: Fri Dec 25, 2020 9:23 am

Re: php 8.0 works fine!!!!!!!!!!

Post by yotsuba »

ssl wrote:
Tue Dec 29, 2020 9:00 am
Hi
I try it on my test forum 8.0.0RC4 version


Capture d’écran 2020-12-29 à 09.58.31.png
Be careful, its tricky!!!!! I wasted a whole night on it- don't make my mistake!! :lol: Everything works for a while, then the forum breaks. Only use it for testing for now. I will be so happy when the next version of phpbb comes out that supports php8 :D 8-)
Last edited by yotsuba on Wed Dec 30, 2020 1:11 am, edited 1 time in total.
User avatar
david63
Registered User
Posts: 18828
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: php 8.0 works fine!!!!!!!!!!

Post by david63 »

So now that you have found issues with PHP8 you can help in getting a phpBB compatible version by posting those issues in the Bug Tracker
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
yotsuba
Registered User
Posts: 22
Joined: Fri Dec 25, 2020 9:23 am

Re: php 8.0 works fine!!!!!!!!!!

Post by yotsuba »

david63 wrote:
Wed Dec 30, 2020 12:54 am
So now that you have found issues with PHP8 you can help in getting a phpBB compatible version by posting those issues in the Bug Tracker
Sure, and when i go to eat in a restaurant, I will get there a day early, order the supplies, cook the meal myself, then it will be just perfect when its time to eat. :lol: :D :lol: :D :lol: :D ha ha
User avatar
P_I
Registered User
Posts: 1439
Joined: Tue Mar 01, 2011 8:35 pm
Location: Staying home - Western Canada
Contact:

Re: php 8.0 works fine!!!!!!!!!!

Post by P_I »

yotsuba wrote:
Wed Dec 30, 2020 12:33 am
wikimedia has been lagging a long time, they are only supporting like php 7.2 or 7.3.
Fact check: https://www.mediawiki.org/wiki/Compatibility#PHP says MediaWiki 1.35 is compatible with PHP 7.4.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
yotsuba
Registered User
Posts: 22
Joined: Fri Dec 25, 2020 9:23 am

Re: php 8.0 works fine!!!!!!!!!!

Post by yotsuba »

P_I wrote:
Wed Dec 30, 2020 1:03 am
yotsuba wrote:
Wed Dec 30, 2020 12:33 am
wikimedia has been lagging a long time, they are only supporting like php 7.2 or 7.3.
Fact check: https://www.mediawiki.org/wiki/Compatibility#PHP says MediaWiki 1.35 is compatible with PHP 7.4.
AHHH i stand corrected, thanks for pointing out that im stupid-thats a good thing for others to know!! :lol: :D :lol: :D -- except for having millions of installs wikimedia not working on php 8 is annoying :D :lol: . i wanted to use wikimedia, then it didnt work on php7.4 so i didnt even visit the site for months. 7.4 IS better tho, a good start.
User avatar
david63
Registered User
Posts: 18828
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: php 8.0 works fine!!!!!!!!!!

Post by david63 »

yotsuba wrote:
Wed Dec 30, 2020 12:59 am
i don't know crap about how to program and i don't want to
Nobody is expecting you to know anything about programming - just post your findings in the Bug Tracker, but as that is beyond your current skill level please stop complaining that nobody is doing anything - if nobody knows about a problem then it will not get fixed. This is open source software where everyone plays a part.

To use your restaurant analogy - if you go to a restaurant for a meal and it is not cooked correctly then would you not say something so that it can get fixed? Perhaps not - as you appear to expect everyone else to do it for you.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22948
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: php 8.0 works fine!!!!!!!!!!

Post by Mick »

You should retract your topic subject by editing it as there are obviously PHP8.0 issues.
"The more connected we get the more alone we become" - Kyle Broflovski©
yotsuba
Registered User
Posts: 22
Joined: Fri Dec 25, 2020 9:23 am

Re: php 8.0 works fine!!!!!!!!!!

Post by yotsuba »

Mick wrote:
Wed Dec 30, 2020 9:36 am
You should retract your topic subject by editing it as there are obviously PHP8.0 issues.
I got a better idea, i just moved to xenforo - it DOES work perfectly with php 8 so byeeeeeeeeeeee loosers. :P :arrow:
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22948
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: php 8.0 works fine!!!!!!!!!!

Post by Mick »

That’s not completely true especially with extensions but if you’re happy with xenforo I’ll mark this topic solved.
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 5162
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: php 8.0 works fine!!!!!!!!!!

Post by HiFiKabin »

Question asked, answered, closing
Locked

Return to “phpBB Discussion”