Preview doesn't show me my post?

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Get Involved
User avatar
drathbun
Former Team Member
Posts: 12204
Joined: Thu Jun 06, 2002 3:51 pm
Location: TOPICS_TABLE
Contact:

Preview doesn't show me my post?

Post by drathbun »

I've noticed something and am wondering if this is a browser issue or a standard feature of the new style. When I am composing a post and click "preview" the screen scrolls down to the post edit form rather than leaving me at the top of the page. That means I have to scroll back up to the top of the page in order to actually preview my post.

For shorter posts it's not a problem. But for longer posts you end up in the wrong place.

FWIW, I am using IE 6 when I experience this behavior. Is this the designed result? Does it happen the same way in other browsers?

The URL structure does contain the tag #preview which would normally hit an anchor point. When I view the source of this page, there are 3 instances of the word "preview" in the code. Once for the id (name) of the form, and the other two are associated with the preview button on the form itself. So I guess what is happening is that when I click the preview button the form is getting the focus since that's the name?

I would expect an anchor with the name "preview" to be at the top of the page, so that the preview mode would take me to the top of the page in order to actually review the text I have typed in so far.
I blog about phpBB: phpBBDoctor blog
Still using phpbb2? So am I! Click below for details
Image

User avatar
battye
Extension Customisations
Extension Customisations
Posts: 10945
Joined: Wed Feb 11, 2004 11:02 am
Location: Australia
Contact:

Re: Preview doesn't show me my post?

Post by battye »

FWIW, I am using IE 6 when I experience this behavior. Is this the designed result? Does it happen the same way in other browsers?


It is working correctly in Firefox. :)
Customisations Team Member

https://github.com/battye/php-array-parser - Give it a Star! :D

User avatar
drathbun
Former Team Member
Posts: 12204
Joined: Thu Jun 06, 2002 3:51 pm
Location: TOPICS_TABLE
Contact:

Re: Preview doesn't show me my post?

Post by drathbun »

So it's not the expected behavior then. :-) I'll submit a bug.
I blog about phpBB: phpBBDoctor blog
Still using phpbb2? So am I! Click below for details
Image

Thatbitextra
Former Team Member
Posts: 7604
Joined: Mon Mar 21, 2005 5:04 am
Location: A place where something is or could be located; a site.
Contact:

Re: Preview doesn't show me my post?

Post by Thatbitextra »

Works fine for me in IE6.
Styles KB
My MODs: Choose Who to Accept PMs From (Prevents unwanted PMs!) | Warn of Old Topic Before Posting Reply
Style: subBlack (Now updated to phpBB 2.0.22 and 5 new color schemes!)

User avatar
drathbun
Former Team Member
Posts: 12204
Joined: Thu Jun 06, 2002 3:51 pm
Location: TOPICS_TABLE
Contact:

Re: Preview doesn't show me my post?

Post by drathbun »

Thatbitextra wrote: Works fine for me in IE6.

Even on a very long post?

Type in a very long post, or just quote the first post in this topic and add a few lines, then click "Preview" and tell me where the focus of the browser ends up. For me it's back at the posting form, and I have to scroll up to see the post content preview...
I blog about phpBB: phpBBDoctor blog
Still using phpbb2? So am I! Click below for details
Image

User avatar
battye
Extension Customisations
Extension Customisations
Posts: 10945
Joined: Wed Feb 11, 2004 11:02 am
Location: Australia
Contact:

Re: Preview doesn't show me my post?

Post by battye »

Out of interest, if you look in the address bar drathbun, does it end with #preview?
Customisations Team Member

https://github.com/battye/php-array-parser - Give it a Star! :D

zanejin
Registered User
Posts: 182
Joined: Sun Oct 19, 2003 10:58 am

Re: Preview doesn't show me my post?

Post by zanejin »

IE 7 and Firefox display the preview properly. I typed random characters and copied-pasted until the length was long enough for the preview to cover the entire page, and clicked "Preview". The URL got a "#preview" and the browser window jumped down to the title of the post (here, "Preview: Re: Preview doesn't show me my post?").

User avatar
drathbun
Former Team Member
Posts: 12204
Joined: Thu Jun 06, 2002 3:51 pm
Location: TOPICS_TABLE
Contact:

Re: Preview doesn't show me my post?

Post by drathbun »

battye wrote: Out of interest, if you look in the address bar drathbun, does it end with #preview?

Yup...
drathbun wrote: The URL structure does contain the tag #preview...

If I enter a very long post
or just force one by
using very short lines
like this :-)

I will attach a screen shot of what
appears in my browser screen
which - by the way - is about
800 x 600-ish in size. I have a
larger monitor but don't
run the browser window full
screen. Now this post should
be long enough to show what
I mean, so I'm clicking
Preview...

I've attached a screen shot of the result. Here's the URL:

Code: Select all

http://www.phpbb.com/community/posting.php?mode=quote&f=64&sid=[SID REMOVED]&p=2922833#preview
Attachments
post_preview.jpg
post_preview.jpg (83.2 KiB) Viewed 615 times
Last edited by pentapenguin on Sun Apr 15, 2007 5:44 pm, edited 2 times in total.
Reason: SID removed
I blog about phpBB: phpBBDoctor blog
Still using phpbb2? So am I! Click below for details
Image

User avatar
Interlog
Registered User
Posts: 1258
Joined: Sat Jun 11, 2005 4:11 pm
Location: London, UK
Contact:

Re: Preview doesn't show me my post?

Post by Interlog »

This happens to me too - using IE7.

Mark :D
Image

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Re: Preview doesn't show me my post?

Post by SamG »

zanejin wrote: IE 7 and Firefox display the preview properly.
Neither IE 6 (Win2K) nor IE 7 (WinXP) work as expected for me. Firefox and Opera (both WinXP) do.

I say, "as expected." However, looking at the page source, it seems to me that the fragment identifier is in a curious spot:

Code: Select all

<div class="post bg2" id="preview">
	<div class="inner"><span class="corners-top"><span></span></span>


	<div class="postbody">
		<h3>Preview: Re: Preview doesn't show me my post?</h3>
This strikes me as a bug.

Thatbitextra
Former Team Member
Posts: 7604
Joined: Mon Mar 21, 2005 5:04 am
Location: A place where something is or could be located; a site.
Contact:

Re: Preview doesn't show me my post?

Post by Thatbitextra »

It strikes me as an IE bug tbh, but I could be wrong.
Styles KB
My MODs: Choose Who to Accept PMs From (Prevents unwanted PMs!) | Warn of Old Topic Before Posting Reply
Style: subBlack (Now updated to phpBB 2.0.22 and 5 new color schemes!)

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Re: Preview doesn't show me my post?

Post by SamG »

I won't deny that as a possibility at least. But that doesn't change the fact that the fragment identifier is in an unexpected place, IMHO. Why tag an outer, containing <div> when you have better options?

zanejin
Registered User
Posts: 182
Joined: Sun Oct 19, 2003 10:58 am

Re: Preview doesn't show me my post?

Post by zanejin »

Interestingly enough, I'm getting mixed results from another test run on IE 7. Apparently, the first time ("first time" defined as the first time after clicking the "Post reply" button) I click "Preview" for a post with a lot of lines, the browser window first jumps to the post title (here, "Preview: Re: Preview doesn't show me my post?"), but suddenly somewhere midway into the post's preview. However, if I click "Preview" after that first time, the browser window jumps to the right place. Any further clicking of "Preview" in the same "Post reply" page results in correct jumping.

User avatar
bbrian017
Registered User
Posts: 720
Joined: Mon Mar 19, 2007 2:20 pm
Location: Canada
Contact:

Re: Preview doesn't show me my post?

Post by bbrian017 »

Works good for me ?

User avatar
Eelke
QA Team
Posts: 2903
Joined: Thu Dec 20, 2001 8:00 am
Location: NL, Bussum
Name: Eelke Blok
Contact:

Re: Preview doesn't show me my post?

Post by Eelke »

I can confirm the same (i.e. unexpected) result with IE6, the top of the view ends up somewhere halfway the actual preview, it seems the bottom of the view lines up with the bottom of the edit textarea, but that might just be a coincidence. If you find it does work correctly, try and be a little more specific so that it is clear you actually understand the problem, because multiple people have now confirmed that IE6 does not work as expected.

Post Reply

Return to “phpBB Discussion”