Viewing attachment problem

Need some custom code changes to the phpBB core simple enough that you feel doesn't require an extension? Then post your request here so that community members can provide some assistance.

NOTE: NO OFFICIAL SUPPORT IS PROVIDED IN THIS SUB-FORUM
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: NO OFFICIAL SUPPORT IS PROVIDED IN THIS SUB-FORUM
Post Reply
cli
Registered User
Posts: 3
Joined: Wed May 23, 2018 12:15 pm

Viewing attachment problem

Post by cli » Wed May 23, 2018 12:29 pm

hello,

I have a forum using a custom modified prosilver template.
I only made changes in the style sheets. Now I am finished, I tried to make a post with an image attachment.
Well, there are some problems and I don't know why.

Firstly, the inline images with
are not visible. After posting it, there is only the name of the image file vsibile.
Secondly, all of my uploaded attachments are orphaned attachments and I have to link the attachments manually in the ACP with each post ID.
When I do that manually, the image was shown at first. But later on, there only was the linked name of the image displayed and when clicking on it, the forum tells me that the image is not available anymore.
Also the attachments aren't visible in the preview.

Is there any way, that the attachments can be directly linked to the post, without getting the orphaned image tag? (I always submitted the post, so there is no reason for the image to get orphaned)

PLEASE help me! I am sitting on that problem for hours and I cannot find any solution.

I'm new here, so sorry if I don't know how to exactly make a 'problem post'. If you need further information, please ask.

Thank you!

Cheers, Christina

User avatar
david63
Jr. Extension Validator
Posts: 14913
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Viewing attachment problem

Post by david63 » Wed May 23, 2018 12:46 pm

cli wrote:
Wed May 23, 2018 12:29 pm
I only made changes in the style sheets. Now I am finished, I tried to make a post with an image attachment.
Well, there are some problems and I don't know why.
Do you have the same problems if you use the default prosilver style?

Have you applied the fix described here? - viewtopic.php?f=556&t=2453611
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

cli
Registered User
Posts: 3
Joined: Wed May 23, 2018 12:15 pm

Re: Viewing attachment problem

Post by cli » Wed May 23, 2018 1:16 pm

david63 wrote:
Wed May 23, 2018 12:46 pm
Have you applied the fix described here? - viewtopic.php?f=556&t=2453611
Yes I have, still the same problem.

Ok, with the default prosilver template, the attachments are visible.
Maybe you know which exact file is responsible for attachments in general?
Thank you!

User avatar
david63
Jr. Extension Validator
Posts: 14913
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Viewing attachment problem

Post by david63 » Wed May 23, 2018 1:31 pm

cli wrote:
Wed May 23, 2018 1:16 pm
with the default prosilver template, the attachments are visible.
cli wrote:
Wed May 23, 2018 12:29 pm
I only made changes in the style sheets
Then it would appear that it is something you have done to your style sheets.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

cli
Registered User
Posts: 3
Joined: Wed May 23, 2018 12:15 pm

Re: Viewing attachment problem

Post by cli » Wed May 23, 2018 1:48 pm

Ok looks like I did changes in the template files as well and some php files in /includes as well.

Is or are there like documents in general, which are responsible for the attachments in phpbb?
Because the changes I made are huge and it would take me like forever to do the changes again on that template...

Sorry to bother you with that. Would be very appreciated!
Thank you!

Post Reply

Return to “phpBB Custom Coding”

Who is online

Users browsing this forum: No registered users and 6 guests