ArchivBot for AjaxChat - - 'rsquo' not defined in Entity

Need some custom code changes to the phpBB core simple enough that you feel doesn't require an extension? Then post your request here so that community members can provide some assistance.

NOTE: NO OFFICIAL SUPPORT IS PROVIDED IN THIS SUB-FORUM
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: NO OFFICIAL SUPPORT IS PROVIDED IN THIS SUB-FORUM
Post Reply
cryptoevo.de
Registered User
Posts: 7
Joined: Mon Dec 25, 2017 4:30 pm

ArchivBot for AjaxChat - - 'rsquo' not defined in Entity

Post by cryptoevo.de » Thu Jul 26, 2018 11:43 am

Hello :)

One of mine Forum members created an ArchiveBot, which posts the history from AjaxChat in to a Thread.
We had several Problems with a symbol which could not be rendert by render.php, a so called 'rsquo' meaning a " .
I tried deleting some messages one bye one to analyse which message caused the problem, also the Error said already something about URL.

It seemed to be caused by Links, I disabled OGP parser, which seemed to kinda help.
But i have now kinda the same Error, but this time it doesn't tell URL or anything.

This is the current Error:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/s9e/text-formatter/src/Renderer.php on line 19: DOMDocument::loadXML(): Entity 'rsquo' not defined in Entity, line: 1
The ArchivBot is now set to archive 120 messages each time, so at least one message from this snippet is causing the error:
https://pastebin.com/wntDJpLT

Here the current full Chat History maybe someone want to compare the valid message without error, every 1 in the last part of every line like 0, 0, 1), means it is already posted/archived and if it ends like 0, 0, 0), with a 0 as last number then it is not posted/not archived)
https://pastebin.com/VP8fwg5F
Last edited by cryptoevo.de on Thu Jul 26, 2018 7:05 pm, edited 1 time in total.

User avatar
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 24592
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: AjaxChat - ArchivBot - 'rsquo' not defined in Entity

Post by Paul » Thu Jul 26, 2018 1:40 pm

To receive extension support please visit our Extensions Database and post in the specific extension's designated support area. The link to the support area for each released extension is also available in the first post of each released extension listed in the [3.2.x] Extension Database Releases forum. For extensions still in development (not recommended for a live board) support is in that extensions's topic in the Extensions in Development forum.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

cryptoevo.de
Registered User
Posts: 7
Joined: Mon Dec 25, 2017 4:30 pm

Re: ArchivBot for AjaxChat - - 'rsquo' not defined in Entity

Post by cryptoevo.de » Thu Jul 26, 2018 7:07 pm

I changed the Title, maybe it is more clear now :P

We have coded the ArchivBot our selfs. There is no Database entry...

User avatar
Ger
Recognised Extension Developer
Posts: 1665
Joined: Wed Jan 02, 2008 7:35 pm
Location: 192.168.1.100
Contact:

Re: ArchivBot for AjaxChat - - 'rsquo' not defined in Entity

Post by Ger » Fri Jul 27, 2018 6:52 am

Might help if we have some code to look at.

Also, your pastebin has 1 sentence with rsquo. Guess you want to look there. Use Ctrl + F.
My extensions:
Simple CMS, Feed post bot, Avatar Resize, Modbreak, Magic OGP, Live topic update, Modern Quote, Quoted Where (GDPR) and Autoresponder.
Newest: FAQ manager for 3.2

Like my work? Buy me a coffee to keep it coming. :ugeek:
-Available for custom work-

Post Reply

Return to “phpBB Custom Coding”

Who is online

Users browsing this forum: No registered users and 7 guests