Page 2 of 2

Re: Topic Solved: [SOLVED] Prefix Placement

Posted: Wed May 29, 2019 9:55 pm
by chuppito
Thanks, does not work at home, I would do without
Thank you thanks again

Re: Topic Solved: [SOLVED] Prefix Placement

Posted: Thu May 30, 2019 7:24 am
by Mannix_
mrgoldy wrote:
Wed May 29, 2019 1:47 pm
Well, if you use the viewtopic_topic_title_prepend template event, you can prepend something to the topic title.
This is correct but to make it work you need to disable the extension first (clear the extension data if there is any just to be safe). Then change the name of the viewtopic_topic_title_append.html to viewtopic_topic_title_prepend.html. After that you can enable the extension.

Re: Topic Solved: [SOLVED] Prefix Placement

Posted: Thu May 30, 2019 7:41 am
by chuppito
Hello, Yes this is my way of proceeding. Otherwise the Forum don't work
With this technique I was able to place the button "accept response" before the others (viewtopic_body_post_buttons_after.html).

Here is a picture of the one that must be first
IMG_20190530_095245_opt.jpg
IMG_20190530_095245_opt.jpg (14.56 KiB) Viewed 358 times

Re: Topic Solved: [SOLVED] Prefix Placement

Posted: Thu May 30, 2019 9:14 am
by Mannix_
chuppito wrote:
Thu May 30, 2019 7:41 am
Hello, Yes this is my way of proceeding. Otherwise the Forum don't work
With this technique I was able to place the button "accept response" before the others (viewtopic_body_post_buttons_after.html).

Here is a picture of the one that must be first

IMG_20190530_095245_opt.jpg
You want to move that green check mark icon in front of the logos text? If so i would try viewtopic_body_post_subject_before.html

Re: Topic Solved: [SOLVED] Prefix Placement

Posted: Thu May 30, 2019 9:28 am
by mrgoldy
Chuppito, I already explained that in this topic, but you are refering to the Post Subject, not the topic title.
See one of my earlier replies in this topic to clearly see the difference.

If you want to put it infront of the Post subject, it's a bit more difficult, you can use viewtopic_body_post_subject_before as mentioned, but that is not inside, so outside, the post subject's h3 element, which is a block element. So you might be able to do some CSS magic and make it float infront or what ever.

And you do not have to disable the extension, if you purge the cache and force refresh the page (Ctrl + F5), that usually works for me.

Re: Topic Solved: [SOLVED] Prefix Placement

Posted: Fri May 31, 2019 11:23 am
by chuppito
Hello and thank you for your help. I didn't do it, it'll stay that way.
The developer did not answer this question :?

Thanks