Page 1 of 1

Strange behavior of a table

Posted: Tue Apr 09, 2019 6:23 pm
by EmilianoL
I ask you a little question that I can't manage. In my forum (https://www.thrillingforum.com/phpbb/vi ... .php?t=413) I using a BBcode table to make a table with images, in this way:

1.jpg

Everything works well, but when you try to see the forum via a mobile device, using the responsive functionality, the table is resized and some elements of the borders disappear and the words CREDITED and the two points ":" appear instead of the cage to the left.

2.jpg

Can anyone tell me why this happens? Thanks in advance.

Re: Strange behavior of a table

Posted: Wed Apr 10, 2019 7:20 am
by Toxyy
: keeps appearing because you have this css:

Code: Select all

@media (max-width: 700px) {
	...
	table.responsive td > dfn:after {
		content: ':';
		padding-right: 5px;
	}
	...
}
(theres stuff before and after the middle bit, it's just inside that max-width: 700px)

removing the content line fixes it.

For the word CREDITED it seems that it's hard coded into your template in the td's dnf tag, as far as I can tell at least.

For the border not being aligned, you have a couple of solutions. Assuming your added table uses the custom class .tables1 you could add this block to the same media query:

Code: Select all

	.tables1 {
		margin-left: 0px;
	}
and it also looks like you've hardcoded its width to 98%, change it to 97%

Re: Strange behavior of a table

Posted: Wed Apr 10, 2019 9:38 am
by EmilianoL
Thank you very much, I will try to make good use of these tips.