[CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
Anti-Spam Guide
Locked
iGimp
Registered User
Posts: 11
Joined: Sat Jul 24, 2010 3:33 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by iGimp »

can you explain the last part about the server settings

step by step would be helpful :)
User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by D¡cky »

Log in to the Administration Control Panel.
Look down the left menu and click Server settings
Change the script path from /test/ to /
Click Submit
Have you hugged someone today?
iGimp
Registered User
Posts: 11
Joined: Sat Jul 24, 2010 3:33 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by iGimp »

ok thanks

Now what do i do?
User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by D¡cky »

iGimp wrote:Now what do i do?
Have fun with your new board.
Have you hugged someone today?
Mokeli AJ
Registered User
Posts: 8
Joined: Sun Oct 10, 2010 6:36 pm
Contact:

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by Mokeli AJ »

It didnt work for my Mybb 1.6 LInk : http://forum.adminjunction.info/index.php
amciek
Registered User
Posts: 16
Joined: Sun Dec 26, 2010 5:20 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by amciek »

I have a problem :/ when I press continue conversion show me this:

Code: Select all

Fatal error: Maximum execution time of 30 seconds exceeded in /home/amci3k/public_html/includes/functions_convert.php on line 2401
User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by D¡cky »

amciek wrote:I have a problem :/ when I press continue conversion show me this:

Code: Select all

Fatal error: Maximum execution time of 30 seconds exceeded in /home/amci3k/public_html/includes/functions_convert.php on line 2401
Try this:

Open phpbb3/install/install_convert.php

Find:

Code: Select all

<?php
/**
*
* @package install
* @version $Id$
* @copyright (c) 2006 phpBB Group
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
*
*/

/**
*/
After add:

Code: Select all

@set_time_limit(0);
@ini_set('memory_limit', '256M');
@ini_set('upload_max_filesize', '128M');
@ini_set('post_max_size', '256M');
@ini_set('max_input_time', '-1');
@ini_set('max_execution_time', '-1');
@ini_set('expect.timeout', '-1');
@ini_set('default_socket_timeout', '-1');
Have you hugged someone today?
amciek
Registered User
Posts: 16
Joined: Sun Dec 26, 2010 5:20 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by amciek »

Unfortunately still not working
User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by D¡cky »

Sorry it didn't work for you. Some hosts don't allow the php.ini settings to be overridden. The alternative is to do the conversion locally. Use EasyPHP, WampServer, or XAMPP.
Some helpful tips are in this Knowledge Base article, Offline Conversions
Have you hugged someone today?
amciek
Registered User
Posts: 16
Joined: Sun Dec 26, 2010 5:20 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by amciek »

I install on another host and install done and work but during install i see this bug.
Forum is working http://onlytrucks.pl/forum/index.php

Code: Select all

hpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 361: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/index.php on line 444: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /install/index.php on line 445: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /install/index.php on line 446: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /install/index.php on line 447: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
And i have problem whit posts

in mybb
http://www4.picturepush.com/photo/a/475 ... 753062.jpg

in phbb3
http://www4.picturepush.com/photo/a/475 ... 753067.jpg
User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by D¡cky »

amciek wrote:I install on another host and install done and work but during install i see this bug.
Forum is working http://onlytrucks.pl/forum/index.php

Code: Select all

hpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 361: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/index.php on line 444: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /install/index.php on line 445: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /install/index.php on line 446: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /install/index.php on line 447: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
And i have problem whit posts

in mybb
http://www4.picturepush.com/photo/a/475 ... 753062.jpg

in phbb3
http://www4.picturepush.com/photo/a/475 ... 753067.jpg
Try this:
OPEN functions_mybb.php
FIND (at line 361)

Code: Select all

		 'forum_name'	=> ($row['name']) ? htmlspecialchars(html_entity_decode(htmlspecialchars_decode($row['name'], ENT_COMPAT), ENT_QUOTES), ENT_COMPAT, 'UTF-8') : $user->lang['CATEGORY'],
REPLACE WITH

Code: Select all

		 'forum_name'	=> ($row['name']) ? htmlspecialchars(mybb_set_default_encoding($row['name']), ENT_COMPAT, 'UTF-8') : $user->lang['CATEGORY'],
FIND (at line 434)

Code: Select all

		 'forum_name'		=> htmlspecialchars(mybb_set_default_encoding(htmlspecialchars_decode(html_entity_decode($row['name']), ENT_QUOTES)), ENT_COMPAT, 'UTF-8'),
REPLACE WITH

Code: Select all

		 'forum_name'		=> htmlspecialchars(mybb_set_default_encoding($row['name']), ENT_COMPAT, 'UTF-8'),
FIND (at line 438)

Code: Select all

		 'forum_desc'		=> htmlspecialchars(mybb_set_default_encoding(htmlspecialchars_decode(html_entity_decode($row['description']), ENT_QUOTES)), ENT_COMPAT, 'UTF-8'),
REPLACE WITH

Code: Select all

		 'forum_desc'		=> htmlspecialchars(mybb_set_default_encoding($row['description']), ENT_COMPAT, 'UTF-8'),
FIND (at line 565)

Code: Select all

					'forum_name'		=> htmlspecialchars(mybb_set_default_encoding(htmlspecialchars_decode(html_entity_decode($row['name']), ENT_QUOTES)), ENT_COMPAT, 'UTF-8'),
REPLACE WITH

Code: Select all

					'forum_name'		=> htmlspecialchars(mybb_set_default_encoding($row['name']), ENT_COMPAT, 'UTF-8'),
FIND (at line 568)

Code: Select all

					'forum_desc'		=> htmlspecialchars(mybb_set_default_encoding(htmlspecialchars_decode(html_entity_decode($row['description']), ENT_QUOTES)), ENT_COMPAT, 'UTF-8'),
REPLACE WITH

Code: Select all

					'forum_desc'		=> htmlspecialchars(mybb_set_default_encoding($row['description']), ENT_COMPAT, 'UTF-8'),
It is also a possibility that when you moved to another server, the characters in the database became corrupted.
Have you hugged someone today?
amciek
Registered User
Posts: 16
Joined: Sun Dec 26, 2010 5:20 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by amciek »

:/ change and again and the posts are cut

Code: Select all

[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 361: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 434: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 438: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 568: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 565: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /install/convertors/functions_mybb.php on line 568: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
[phpBB Debug] PHP Notice: in file /includes/utf/utf_tools.php on line 1845: htmlspecialchars() [function.htmlspecialchars]: Invalid multibyte sequence in argument
User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by D¡cky »

"Invalid multibyte sequence" indicates that you have invalid utf8 characters in your database. This may have happened when you moved the database. You should check the database first to see if the characters are corrupt and are the same as in the original database.
Have you hugged someone today?
amciek
Registered User
Posts: 16
Joined: Sun Dec 26, 2010 5:20 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by amciek »

Thank's work :)
User avatar
LoneHawk
Registered User
Posts: 16
Joined: Wed Mar 02, 2011 8:09 pm

Re: [CONVERTOR]myBB 1.4.x to phpBB 3.0.5

Post by LoneHawk »

Hello, I am having a problem with the convertor. Everytime I click 'Continue conversion', it just keeps loading. i've had it loading overnight and there has been no difference.
Locked

Return to “[3.0.x] Convertors”