Page 3 of 3

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.5

Posted: Wed Jun 24, 2009 9:26 pm
by Beseiged
Is this the same convertor that ships with the phpBB3.0.5 full package?

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.5

Posted: Tue Jun 30, 2009 7:15 pm
by D¡cky
Beseiged wrote:Is this the same convertor that ships with the phpBB3.0.5 full package?
It is basically the same convertor. The convertor that ships with 3.0.5 converts subforums to regular forums which means that you have to go into Forums Management and move the forums that you had as subforums on phpBB2 to the correct parent forum. This basic convertor has been modified to correctly recreate the phpBB2 subforums to subforums on phpBB3.

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.6

Posted: Sun Oct 24, 2010 8:32 pm
by Kranium Decay
So simple press forum posts and users can be shifted to phpBB aswell??

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.6

Posted: Sun Oct 24, 2010 8:52 pm
by D¡cky
I assume you are referring to the Simplepress forums that are used with Wordpress. This convertor has nothing to do with Simplepress. It is meant to convert a phpBB2 board that has the Simple Subforums modification installed so that the phpBB2 subforums will be converted to phpBB3 subforums. The phpBB2 convertor that comes with phpBB3 does not convert subforums.

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.8

Posted: Tue Mar 01, 2011 2:04 am
by growltiger23
awesome, thanks, will give it a shot. Was a PITA to manually recreate all the subforums

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.10

Posted: Fri Apr 27, 2012 2:23 am
by clinton4
What about post images and other non database stuff related to a phpbb2 forum?

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.10

Posted: Fri Apr 27, 2012 3:10 am
by D¡cky
Images in posts are preserved as well as attachments. Styles do not get converted. MODs generally are not converted. Some MODs can be converted, but the convertor will have to be modified to convert them.

I do not know what you mean by non database stuff.

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.10

Posted: Fri Jun 20, 2014 10:49 am
by Imrageth
I know it's been ages since the last reply but I really hope someone can help me. I have an old forum with nearly 600 subforums and doing the hierarchy manually is pain in the bottom. I tried this converter but it works only to some extent. It converts the first category with it's subforums but then breaks.

Any idea what may be going on?

Code: Select all

General Error
SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3 [1064]

SQL

UPDATE phpbb_forums SET left_id = left_id + 2, right_id = right_id + 2 WHERE left_id >

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 189
CALL: dbal->sql_error()

FILE: [ROOT]/install/convertors/functions_SS_phpbb20_300.php
LINE: 281
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/install/install_convert.php(1003) : eval()'d code
LINE: 5
CALL: phpbb_insert_forums()

FILE: [ROOT]/install/install_convert.php
LINE: 1003
CALL: eval()

FILE: [ROOT]/install/install_convert.php
LINE: 203
CALL: install_convert->convert_data()

FILE: [ROOT]/install/index.php
LINE: 326
CALL: install_convert->main()

FILE: [ROOT]/install/index.php
LINE: 203
CALL: module->load()

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.10

Posted: Tue Feb 10, 2015 3:07 pm
by clinton4
Download link is dead. Any other mirrors or could the author fix the download link?

Re: [CONVERT] phpBB2.0.x Simple Subforums to phpBB3.0.10

Posted: Tue Feb 10, 2015 4:16 pm
by DavidIQ
Unfortunately the OP is not around and there is no way to get the file that is referenced in the first post, but we were able to track down a 3.0.0 version of the convertor here and I've attached it to the first post. In order to convert you'll need to download and install phpBB 3.0.0, run the convertor, and then upgrade to 3.0.13-PL1. The convertor should work fine that way but if you run into problems going from 3.0.0 to 3.0.13-PL1 start a new topic in the 3.0.x Support Forum for additional assistance.