Page 1 of 1

3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 4:06 am
by Alexander George
I have a 3.0.3 board with many languages available. I am intending to convert to 3.0.4. Must I also update all my languages? (I'm hoping not, as that would take a really loooong time!)

Thanks.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 10:38 am
by datuk
I dont think you need to update your language. As when u go to language pack download, it only shows language for 3.0.x olympus. So basically the language all should be one.

Anyway to make sure you might want to wait for official reply for mods here. But you can actually see the change log and you will know if there is language update.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 12:49 pm
by RMcGirr83
datuk wrote:I dont think you need to update your language. As when u go to language pack download, it only shows language for 3.0.x olympus. So basically the language all should be one.

Code: Select all

############################################################## 
## Title: phpBB 3.0.3 to phpBB 3.0.4 Language Pack Changes
## Author: Acyd Burn < N/A > (Meik Sievertsen) N/A 
## Description: 
##
##		These are the phpBB 3.0.3 to phpBB 3.0.4 Language Pack Changes summed up
##		into a little Mod. These changes are only partial and do not include any code
##		changes, therefore not meant for updating phpBB.
##
## Files To Edit: 
##		language/en/acp/profile.php
##		language/en/acp/search.php
##		language/en/common.php
##		language/en/install.php
##		language/en/ucp.php
##
## License: http://opensource.org/licenses/gpl-license.php GNU General Public License v2 
############################################################## 

#
#-----[ OPEN ]--------------------------------------------- 
#
language/en/acp/profile.php

#
#-----[ FIND ]---------------------------------------------
# Around Line 62
	'DISPLAY_AT_REGISTER'			=> 'Display at registration screen',
	'DISPLAY_AT_REGISTER_EXPLAIN'	=> 'If this option is enabled, the field will be displayed on registration and able to be changed within the user control panel.',
	'DISPLAY_PROFILE_FIELD'			=> 'Display profile field',
	'DISPLAY_PROFILE_FIELD_EXPLAIN'	=> 'The profile field will be shown in all places allowed within the load settings. Setting this to “no” will hide the field from topic pages, profiles and the memberlist.',

#
#-----[ REPLACE WITH ]---------------------------------------------
#
	'DISPLAY_AT_REGISTER'			=> 'Display on registration screen',
	'DISPLAY_AT_REGISTER_EXPLAIN'	=> 'If this option is enabled, the field will be displayed on registration.',
	'DISPLAY_PROFILE_FIELD'			=> 'Display profile field',
	'DISPLAY_PROFILE_FIELD_EXPLAIN'	=> 'The profile field will be shown in all locations allowed within the load settings. Setting this to “no” will hide the field from topic pages, profiles and the memberlist.',

#
#-----[ FIND ]---------------------------------------------
# Around Line 93
	'HIDE_PROFILE_FIELD_EXPLAIN'	=> 'Only administrators and moderators are able to see/fill out this profile field. If this option is enabled, the profile field will be only displayed in users’ profiles.',

#
#-----[ REPLACE WITH ]---------------------------------------------
#
	'HIDE_PROFILE_FIELD_EXPLAIN'	=> 'Hide the profile field from all other users except the user, administrators and moderators who are still able to see this field. If the Display in user control panel option is disabled, the user will not be able to see or change this field and the field can only be changed by administrators.',

#
#-----[ FIND ]---------------------------------------------
# Around Line 122
	'REQUIRED_FIELD_EXPLAIN'	=> 'Force profile field to be filled out or specified by user. This will display the profile field at registration and within the user control panel.',

#
#-----[ REPLACE WITH ]---------------------------------------------
#
	'REQUIRED_FIELD_EXPLAIN'	=> 'Force profile field to be filled out or specified by user or administrator. If display at registration screen option is disabled, the field will only be required when the user edits their profile.',

#
#-----[ FIND ]---------------------------------------------
# Around Line 151
	'VISIBILITY_OPTION'				=> 'Visibility option',

#
#-----[ REPLACE WITH ]---------------------------------------------
#
	'VISIBILITY_OPTION'				=> 'Visibility options',

#
#-----[ OPEN ]--------------------------------------------- 
#
language/en/acp/search.php

#
#-----[ FIND ]---------------------------------------------
# Around Line 38
	'COMMON_WORD_THRESHOLD_EXPLAIN'			=> 'Words which are contained in a greater percentage of all posts will be regarded as common. Common words are ignored in search queries. Set to zero to disable. Only takes effect if there are more than 100 posts.',

#
#-----[ REPLACE WITH ]---------------------------------------------
#
	'COMMON_WORD_THRESHOLD_EXPLAIN'			=> 'Words which are contained in a greater percentage of all posts will be regarded as common. Common words are ignored in search queries. Set to zero to disable. Only takes effect if there are more than 100 posts. If you want words that are currently regarded as common to be reconsidered you have to recreate the index.',

#
#-----[ OPEN ]--------------------------------------------- 
#
language/en/common.php

#
#-----[ FIND ]---------------------------------------------
# Around Line 695

	'datetime'			=> array(
		'TODAY'		=> 'Today',
		'TOMORROW'	=> 'Tomorrow',
		'YESTERDAY'	=> 'Yesterday',

#
#-----[ AFTER, ADD ]---------------------------------------------
#
		'AGO'		=> array(
			0		=> 'less than a minute ago',
			1		=> '%d minute ago',
			2		=> '%d minutes ago',
			60		=> '1 hour ago',
		),

#
#-----[ OPEN ]--------------------------------------------- 
#
language/en/install.php

#
#-----[ FIND ]---------------------------------------------
# Around Line 377
	'CONTINUE_UPDATE_NOW'			=> 'Continue the update process now',

#
#-----[ REPLACE WITH ]---------------------------------------------
#
	'CONTINUE_UPDATE_NOW'			=> 'Continue the update process now',		// Shown within the database update script at the end if called from the updater
	'CONTINUE_UPDATE'				=> 'Continue update now',					// Shown after file upload to indicate the update process is not yet finished

#
#-----[ OPEN ]--------------------------------------------- 
#
language/en/ucp.php

#
#-----[ FIND ]---------------------------------------------
# Around Line 381
	'SENT_AT'					=> 'Sent at',

#
#-----[ REPLACE WITH ]---------------------------------------------
#
	'SENT_AT'					=> 'Sent',			// Used before dates in private messages

# 
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------ 
# 
# EoM

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 2:27 pm
by Alexander George
RMcGirr83, could you explain your post? Are you saying I need to run some mod to update my language packs from 3.0.3 to 3.0.4? If so, where is the mod?

Thanks.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 2:40 pm
by RMcGirr83
Those are the language updates from 3.0.3 to 3.0.4, taken from here

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 2:47 pm
by ameeck
Language packs change between versions, there hasn't been an update without language pack changes. Occasionally they might cause errors if you do not have the appropriate language pack for your version, but almost always they work fine.

What language are you using? Try poking your language's author to relase a new version. If you are using a very modified version of a language pack which is up-to-date, you can run it through a tool like WinMerge to fix up differences.

From your location I'm assuming you're using an english language pack, in that case you would need to manually apply the changes Rich has posted.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 2:53 pm
by Alexander George
Thanks. I have about 30 languages available, none modified. I'd really rather not update each of those if it makes no difference, since it seems the update must be carried out individually (uninstalling the old one, uploading the new one, and installing the new one). If you think it will cause no harm to use the old versions of the language packs, then I think I'll just leave them. But I was seeking expert advice on that.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 3:10 pm
by ameeck
You don't have to re-install them. Updating the files by overwriting them with new ones is enough. Just be careful, if you made modifications due to MODs, you will lose those changes.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 3:18 pm
by fberci
You don't have to reinstall the language packs, you just have to overwrite the old files with the new ones.

In my opinion language packs should always be updated. An outdated language pack doesn't always cause an apparent error, but in 3.0.4 there was a significant change: the new relative date display feature. So I strongly recommend you to update your language packs especially this time.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 4:10 pm
by Alexander George
fberci wrote:In my opinion language packs should always be updated. An outdated language pack doesn't always cause an apparent error, but in 3.0.4 there was a significant change: the new relative date display feature. So I strongly recommend you to update your language packs especially this time.
Thank you. Finally, how can I tell which should be updated? Here, http://www.phpbb.com/languages/, the packs all have different dates on which they were updated. Should I just update those language packs that have been updated since, say December 1, 2008?

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sat Dec 13, 2008 8:37 pm
by fberci
Alexander George wrote:Thank you. Finally, how can I tell which should be updated? Here, http://www.phpbb.com/languages/, the packs all have different dates on which they were updated. Should I just update those language packs that have been updated since, say December 1, 2008?
Yes, it would be a good idea to update the language packs that have a newer last updated date than the time you installed your board. Normally all language packs should be updated, but as not all of them are constantly updated, it is not possible.

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sun Dec 14, 2008 3:56 pm
by Alexander George
Thank you. One further question: could you tell me exactly which directory the relevant language image set files should be placed into? What precisely would the path be? (I am only using the prosilver style.)

Re: 3.0.3 to 3.0.4 -- language update?

Posted: Sun Dec 14, 2008 4:45 pm
by ameeck
Images for a language are stored in styles/prosilver/imageset/{lang_code}/.

Imagesets don't need to get updated, they often stay the same. Just be sure you have them uploaded for the specific language, since if you don't, you won't see any posting buttons.