Page 1 of 1

Problem with encoding...

Posted: Wed Feb 03, 2010 5:07 pm
by rumensoft
Hi, I have this problem: Image
In this case, have to be name: Български (Bulgarian), but it's look like problem with encoding. Any idea?
Thanks!

Re: Problem with encoding...

Posted: Wed Feb 03, 2010 5:10 pm
by ameeck
Looks like some file is not uf8 encoded. Have you made any changes to language files?

Re: Problem with encoding...

Posted: Wed Feb 03, 2010 5:18 pm
by rumensoft
ameeck wrote:Looks like some file is not uf8 encoded. Have you made any changes to language files?
No, I never change the file inside (folder "forum"). I check some page and they are with UTF-8.

Re: Problem with encoding...

Posted: Wed Feb 03, 2010 6:02 pm
by Paul
Did you use fantastico to install your board?

Re: Problem with encoding...

Posted: Wed Feb 03, 2010 6:10 pm
by rumensoft
Yes, I use fantastico. It's was easy :)

Re: Problem with encoding...

Posted: Thu Feb 04, 2010 4:38 am
by tzampatzis
So that's why you have a problem. Fantastico encodes the dtabase in utf8_general_ci. The phpBB system uses only utf8_bin encoding. You can go and change that in you phpMyAdmin at the Operations tab.

Somewhere says collation and you change that to utf8_bin and then you press the Go button. But i think that the problem is i all tables. So search the whole database for tables encoded other than utf8_bin and correct them.

Re: Problem with encoding...

Posted: Thu Feb 04, 2010 1:55 pm
by ameeck
tzampatzis wrote:So that's why you have a problem. Fantastico encodes the dtabase in utf8_general_ci. The phpBB system uses only utf8_bin encoding. You can go and change that in you phpMyAdmin at the Operations tab.

Somewhere says collation and you change that to utf8_bin and then you press the Go button. But i think that the problem is i all tables. So search the whole database for tables encoded other than utf8_bin and correct them.
Actually that's not correct. utf8_general_ci and utf8_bin define the collation. The main difference between them is how MySQL sorts data. Both use utf8 to store and serve data.

Fantastico does not encode the fields as utf8 at all :)

Re: Problem with encoding...

Posted: Thu Feb 04, 2010 6:43 pm
by rumensoft
I tried everything but it is same problem