how does the Standard/Default Folder Structure look like?

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

how does the Standard/Default Folder Structure look like?

Post by apollodriver »

Hello dear experts,


What's the usual standard default folders structure for a correctly installed phpBB-board, not including additional-stuff which may have been added by mods and the like?

Well - Looking at our board installation on the FTP list, i have created a screenshot - see below:

I've noticed some added folders that I know are there 'cuz I put 'em there, but also seeing some 'extras' that might be mistaken copied or failed "move" leftovers... or so. I'd like to clean those up, but what's "for sure" all SUPPOSED to be there, to start with?

btw - for comparison i have added a screenshot of a older phpBB - see viewtopic.php?t=2166305


note: i have difficulties in installing the phpbb

here the installation process - described: https://www.mja-sachsen.de/forum/docs/INSTALL.html

i get a 500 error - each time i call the domain:

question: is there something wrong with the uploaded phpBB version 3.3 xy !?

additional: how to debug!?
install_phpBB__1.jpg
for Wordpress-development - i use the Toolset: http://wpgear.org/

User avatar
warmweer
Jr. Extension Validator
Posts: 3912
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: how does the Standard/Default Folder Structure look like?

Post by warmweer »

apollodriver wrote:
Mon Feb 10, 2020 5:35 pm
i get a 500 error - each time i call the domain:
Which domain?
We should embrace problems, without which there wouldn't be any solutions.

apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

Re: how does the Standard/Default Folder Structure look like?

Post by apollodriver »

hello dear warmweer

http://www.wp-forum.net/install/app.php

funny - but i get 500 er errors all the way
for Wordpress-development - i use the Toolset: http://wpgear.org/

User avatar
warmweer
Jr. Extension Validator
Posts: 3912
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: how does the Standard/Default Folder Structure look like?

Post by warmweer »

That would be on http://www.optimate-server.de/?seite=we ... 1&lang=ger ?

Check your Chmod settings: https://www.phpbb.com/support/docs/en/3 ... rmissions/

Also check your host control panel to see if you have to manually enable features.

Do you have a database available?

On some hosts there's an index.htm or .html or an .htaccess or even a default.php in the root which you have to edit before being able to go online.

BTW I'm getting a 302 (indicating a redirect of some kind). You probably need to ask your host about that.

Added: looking at your printscreen I think the url should be http://www.wp-forum.net/phpbb/install/app.php I think but that gives an access denied.

Need to leave now.
We should embrace problems, without which there wouldn't be any solutions.

apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

Re: how does the Standard/Default Folder Structure look like?

Post by apollodriver »

hi there - and good day dear Warmweer - many many thanks for all your hints. And for the idea-sharing. i have had a quick view on the logs - see them here:

Code: Select all

035: access to /index.htm denied (filesystem path '/sites/www.my-domain.netn.org/index.htm') because search permissions are missing on a component of the path

[Mon Feb 10 20:27:27.883367 2020] [php7:error] [pid 14404] [client 92.74.16.205:51194] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.my-domain.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.my-domain.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.my-domain.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.my-domain.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.my-domain.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.my-domain.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.my-domain.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.my-domain.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.my-domain.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.my-domain.net/includes/functions.php on line 70
[Mon Feb 10 20:27:28.969219 2020] [php7:error] [pid 16158] [client 92.74.16.205:51196] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.my-domain.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.my-domain.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.my-domain.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.my-domain.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.my-domain.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.my-domain.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.my-domain.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.my-domain.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.my-domain.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.my-domain.net/includes/functions.php on line 70
[Mon Feb 10 20:27:29.702520 2020] [php7:error] [pid 14408] [client 92.74.16.205:51198] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.my-domain.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.my-domain.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.my-domain.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.my-domain.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.my-domain.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.my-domain.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.my-domain.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.my-domain.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.my-domain.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.my-domain.net/includes/functions.php on line 70
[Mon Feb 10 20:27:30.324374 2020] [php7:error] [pid 15456] [client 92.74.16.205:51200] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.my-domain.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.my-domain.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.my-domain.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.my-domain.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.my-domain.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.my-domain.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.my-domain.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.my-domain.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.my-domain.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.my-domain.net/includes/functions.php on line 70
[Mon Feb 10 20:27:36.711442 2020] [php7:error] [pid 8985] [client 92.74.16.205:51202] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.my-domain.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.my-domain.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.my-domain.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.my-domain.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.my-domain.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.my-domain.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.my-domain.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.my-domain.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.my-domain.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.my-domain.net/includes/functions.php on line 70
[Mon Feb 10 20:36:02.399565 2020] [php7:error] [pid 16158] [client 217.226.188.111:42836] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.my-domain.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.my-domain.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.my-domain.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.my-domain.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.my-domain.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.my-domain.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.my-domain.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.my-domain.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.my-domain.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.my-domain.net/includes/functions.php on line 70
[Mon Feb 10 20:36:20.349582 2020] [php7:error] [pid 14408] [client 94.69.229.80:51507] script '/sites/www.my-domain.net/phpbb/install/app.php' not found or unable to stat
- well probably there are some errors with the permissions !?

i have to have a closer look at the logs - and yes - i will have a look at the permssion-setup that you have linked to.

i come back later the evening - and will report all my findings.

untill soon -

yours apollo ;)


update:

see the domain: http://www.wp-forum.net

well i look and try to find out more...

i need to have much much more debugging-info - i have to gather those data.,..
for Wordpress-development - i use the Toolset: http://wpgear.org/

apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

Re: how does the Standard/Default Folder Structure look like?

Post by apollodriver »

hello again


well this is extraordinary confusing and disturbing...

with the phpBB version 3.3 xy we have a annoying file and folder structure


just have a closer look what we have the following listing:

/sites/www.wp-forum.net/install/

with the following folders
/convert/
/convertors/
/shemas/

and the files

app.php
etc.
etx

and we have the following:

/sites/www.wp-forum.net/phpbb/install

with the following folders

/controll/
/console/
/event/
/exception/
/helper/
/module/

installer.php
etc. etx.


well - we have to say: this folder-structure is pretty unusual - why the heck is this so - why do we have such a structure - with literally two - install-files!? or folders. This is unusual and i guess that i mixed something up.


btw. if i call the url http://www.wp-forum.net - the i get back the following:


Code: Select all

[php7:error] [pid 9543] [client 37.138.118.127:61431] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.wp-forum.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.wp-forum.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.wp-forum.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.wp-forum.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.wp-forum.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.wp-forum.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.wp-forum.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.wp-forum.net/includes/functions.php on line 70
[Fri Feb 14 20:19:07.436913 2020] [php7:error] [pid 9543] [client 94.217.101.253:38736] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.wp-forum.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.wp-forum.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.wp-forum.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.wp-forum.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.wp-forum.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.wp-forum.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.wp-forum.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.wp-forum.net/includes/functions.php on line 70

any idea!?

look forward to hear from you

regards
for Wordpress-development - i use the Toolset: http://wpgear.org/

User avatar
Lumpy Burgertushie
Registered User
Posts: 67236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: how does the Standard/Default Folder Structure look like?

Post by Lumpy Burgertushie »

there is a folder inside the phpBB folder named phpbb. notice the lowercase.

that is supposed to be there and the folders that you showed inside it are supposed to be there including the one named "install". you should never have any need to access that folder yourself. It is just part of the phpBB files it needs to work.

you have your board files in the root of your domain which is fine. therefore, to install phpBB you need to go here:
http://www.wp-forum.net/install/app.php

currently it is showing a blank page which usually means a php error.

you need to check with your host to make sure php is installed on your server. ( php not phpbb)
you need to find out if your hosting has the requirement to install/run phpBB.
php and a database usually mysql are required to run phpBB.

check with your host.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

Re: how does the Standard/Default Folder Structure look like?

Post by apollodriver »

hello dear Robert,


many thanks for the quick reply and the idea-sharing



regarding the issue that are in the logs:

Code: Select all

PHP Fatal error: Uncaught Exception: Cannot open source device
"Cannot open source device" is the same error message i keep getting. It's the exact same issue.

Code: Select all

<?php
$x = random_int(0, 5);
btw: - we allready gave permits to access dev/urandom - so this should support the wanted configuration.

But we have a closer look at the discussed /(mentioned) issues.

again - many thanks dear Robert for your idea-sharing. I will have a closer look at the server and i come back and report all the findings..
for Wordpress-development - i use the Toolset: http://wpgear.org/

apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

Re: how does the Standard/Default Folder Structure look like?

Post by apollodriver »

hello dear 

according to this instruction 

docs/INSTALL.html


i have to say :  this is pretty funny - . so called double bind instructions.... like so


a. do this 
b. do not this 

just have a closer look at this instrcutions.. 


Once all the files have been uploaded to your site, you should point your browser at this location with the addition of /install/. 
For example, if your domain name is www.example.com and you placed the phpBB files in the directory /phpBB3 off your web 
root you would enter 

http://www.wp-forum.net/phpBB3/install/ 
http://www.wp-forum.net/phpBB3/install/app.php 

into your browser. When you have done this, you should see the phpBB Introduction screen appear.


well - to be frank - i start over again -  but this file structure and these instructions are not good - all can be misunderstood

this is so bad bad bad.. and we can say - these instructions are messed up totally



again:  uplpoad and start over...
for Wordpress-development - i use the Toolset: http://wpgear.org/

User avatar
Lumpy Burgertushie
Registered User
Posts: 67236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: how does the Standard/Default Folder Structure look like?

Post by Lumpy Burgertushie »

the instructions are just giving you examples.

in your case you are installing your board in the root. that means that your path to phpBB install page is
http://www.wp-forum.net/install/

currently, I am getting blank pages at your domain regardless of where I try.

I think you have other problems with your hosting setup.


you need to contact your host and ask them for the server error log so you can see why you are getting blank pages for php files.
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 22083
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket.

Re: how does the Standard/Default Folder Structure look like?

Post by Mick »

How are you unzipping the phpBB files?

There’s nothing wrong with the hierarchy of the files or the file structure unless they haven't been unzipped correctly. Tens of thousands of users manage to install phpBB without an issue, if it were an issue we’d see it reported everyday and we don’t. To answer your question the file structure is exactly the same as you find in the unzipped phpBB3 folder from the download.
"The more connected we get the more alone we become" - Kyle Broflovski

Please read: “Am I In The Right Place?” before posting.

apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

Re: how does the Standard/Default Folder Structure look like?

Post by apollodriver »

hello dear Lumpy hello Mick

first of all -

i installed the phpBB version 3.3.0
i still get the following errors..:

Code: Select all

[Sun Feb 16 16:39:10.382324 2020] [php7:error] [pid 30171] [client 62.158.95.208:56223] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.wp-forum.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.wp-forum.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.wp-forum.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.wp-forum.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.wp-forum.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.wp-forum.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.wp-forum.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.wp-forum.net/includes/functions.php on line 70, referer: http://www.wp-forum.net/install/

[Sun Feb 16 16:59:53.138118 2020] [core:error] [pid 30171] (13)Permission denied: [client 62.158.95.208:57141] AH00035: access to /phpBB/install/ denied (filesystem path '/sites/www.literaturen.org/phpBB') because search permissions are missing on a component of the path
[Sun Feb 16 16:59:53.241618 2020] [core:error] [pid 30171] (13)Permission denied: [client 62.158.95.208:57141] AH00035: access to /favicon.ico denied (filesystem path '/sites/www.literaturen.org/favicon.ico') because search permissions are missing on a component of the path, referer: http://wp-forum.net/phpBB/install/
[Sun Feb 16 17:00:04.609242 2020] [php7:error] [pid 30170] [client 62.158.95.208:57138] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.wp-forum.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.wp-forum.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.wp-forum.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.wp-forum.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.wp-forum.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.wp-forum.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.wp-forum.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.wp-forum.net/includes/functions.php on line 70, referer: http://www.wp-forum.net/install/
[Sun Feb 16 17:01:06.889713 2020] [php7:error] [pid 3380] [client 62.158.95.208:57155] PHP Fatal error:  Uncaught Exception: Cannot open source device in /sites/www.wp-forum.net/includes/functions.php:70\nStack trace:\n#0 /sites/www.wp-forum.net/includes/functions.php(70): random_int(0, 35)\n#1 /sites/www.wp-forum.net/includes/functions.php(106): gen_rand_string(16)\n#2 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(202): unique_id()\n#3 /sites/www.wp-forum.net/phpbb/template/twig/environment.php(186): phpbb\\template\\twig\\environment->display_with_assets('installer_main....', Array)\n#4 /sites/www.wp-forum.net/phpbb/template/twig/twig.php(335): phpbb\\template\\twig\\environment->render('installer_main....', Array)\n#5 /sites/www.wp-forum.net/phpbb/install/controller/helper.php(145): phpbb\\template\\twig\\twig->assign_display('body')\n#6 /sites/www.wp-forum.net/phpbb/install/event/kernel_exception_subscriber.php(86): phpbb\\install\\controller\\helper->render('installer_main....', 'Information', false, 500)\n#7 /sites/www.wp-forum.net/vendor/symfony/event-dispatcher/EventDispatcher.php(214): phpbb\\install\\event\\kern in /sites/www.wp-forum.net/includes/functions.php on line 70, referer: http://www.wp-forum.net/install/
.....according to this installation-instructions -

docs/INSTALL.html

they want you to do the installation with the following paths

http://www.wp-forum.net/install/
http://www.wp-forum.net/phpBB3/install/
http://www.wp-forum.net/phpBB3/install/app.php
http://www.wp-forum.net/phpBB3/install/app.php


but they do not exist at all: we do not have the following path - called mydomain.com/phpbb3 -
well i wonder why this installation-instruction does not meet the real conditions and facts.



http://www.wp-forum.net/install/
http://www.wp-forum.net/phpBB/install/
http://www.wp-forum.net/phpBB/install/app.php
http://www.wp-forum.net/phpBB/install/app.php


@ Mick - i have WinRAR 5.71 (32 bit) note this is a testversion - for only 40 days.
these 40 days are gone..

are the issue probably rootet in the WinRAR 5.71 !? Could / should i try to do the unzip with another tool!?

love to hear from you

your apollodriver
for Wordpress-development - i use the Toolset: http://wpgear.org/

User avatar
Lumpy Burgertushie
Registered User
Posts: 67236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: how does the Standard/Default Folder Structure look like?

Post by Lumpy Burgertushie »

as I said above, those are only examples to help you figure out what the install path would be in your situation.

I showed you what the correct path is for the install on your domain.
those errors mean that you have not installed the files properly and/or there is something wrong with the server settings at your host.

contact your host and show them the errors.



robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

Re: how does the Standard/Default Folder Structure look like?

Post by apollodriver »

hello dear Lumpy,

many thanks for the quick reply _ happy to hear from you again.

i will talk to the server-admin. Those errors look like very interesting. Guess that we need to correct the server-conditions for php 7.2xy

i will come back here and keep you informed..
Last edited by Mick on Mon Feb 17, 2020 9:07 am, edited 1 time in total.
Reason: Removed unnecessary full quoting.
for Wordpress-development - i use the Toolset: http://wpgear.org/

User avatar
warmweer
Jr. Extension Validator
Posts: 3912
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: how does the Standard/Default Folder Structure look like?

Post by warmweer »

From what I read your domain is www.wp-forum.net.

In the root of that domain, make a directory in which you'll put all the forum files (let's say /board)
So you'll have www.wp-forum.net/board.

On your PC, extract the files from the phpBB330.zip >>> you'll get a phpBB3/ with 20 files and 17 subdirectories
Copy everything from /phpBB3 on your board, into www.wp-forum.net/board/ (keeping the whole directory structure
So you'll have:

Code: Select all

www.wp-forum.net
		/board
			/ 20 files and 17 directories
then browse to www.wp-forum.net/board/install/app.php
IF you are only going to install phpBB in www.wp-forum.net then the extra directory (/board) isn't really necessary but if you are going to install other things, then it's best to use different directories, if only to avoid mixing up .htaccess files or index files.
We should embrace problems, without which there wouldn't be any solutions.

Post Reply

Return to “[3.3.x] Support Forum”