Moved site from cPanel to Interworx. Users cant login

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
sp3ctre
Registered User
Posts: 307
Joined: Sun Jul 15, 2007 11:06 am

Moved site from cPanel to Interworx. Users cant login

Post by sp3ctre »

I have just moved my site from a cPanel server using MySQL 8 to an Interworx server using MariaDB 10.2. The site seemed to move ok and I can browse the site but the users can't login (incorrect password, then gives recaptcha challenge)

I have pointed the DNS back at the old server for now, so everyone is able to login again there but I can't figure out what is going on on the new server.

Ideally I would not have changed the DB type but I don't have a choice. The data looks to be in tact and when I look in phpmyadmin the data looks to be identical.

There are no errors being reported in the error logs either.

Any advice on where to start? PHP versions are the same on both (7.4)
User avatar
Lumpy Burgertushie
Registered User
Posts: 68296
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Moved site from cPanel to Interworx. Users cant login

Post by Lumpy Burgertushie »

make sure about the php versions.

go into your admin panel and check it there on both boards.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
sp3ctre
Registered User
Posts: 307
Joined: Sun Jul 15, 2007 11:06 am

Re: Moved site from cPanel to Interworx. Users cant login

Post by sp3ctre »

I'll have to check with phpinfo as I can't even get into the admin panel at the moment
User avatar
warmweer
Jr. Extension Validator
Posts: 5836
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Moved site from cPanel to Interworx. Users cant login

Post by warmweer »

sp3ctre wrote:
Sun Nov 22, 2020 7:24 pm
I have just moved my site from a cPanel server using MySQL 8 to an Interworx server using MariaDB 10.2. The site seemed to move ok and I can browse the site but the users can't login (incorrect password, then gives recaptcha challenge)
...
Any advice on where to start? PHP versions are the same on both (7.4)
Probably a wild guess but since you changed servers: is the sodium extension installed and enabled?
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
sp3ctre
Registered User
Posts: 307
Joined: Sun Jul 15, 2007 11:06 am

Re: Moved site from cPanel to Interworx. Users cant login

Post by sp3ctre »

looks like you may have hit the nail on the head... just need to figure out how to install it on the interworx server now... not quite as user friendly as cpanel!

edit... confirmed sodium was not installed on the custom version of php... switched to server version and it worked... now need to find out how to get it working on the custom version!
sp3ctre
Registered User
Posts: 307
Joined: Sun Jul 15, 2007 11:06 am

Re: Moved site from cPanel to Interworx. Users cant login

Post by sp3ctre »

ok, looks like it was sodium that wasn't installed... Interworx defaults to using crappy "safe" versions of php... switched to the proper repo and it's all working now :)

Thanks for your help!
Post Reply

Return to “[3.3.x] Support Forum”