php lock errors after 3.3.0 update

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
kjh-mov
Registered User
Posts: 48
Joined: Mon May 07, 2018 12:23 pm
Contact:

Re: php lock errors after 3.3.0 update

Post by kjh-mov »

AbaddonOrmuz wrote:
Wed Jan 08, 2020 9:13 pm
The cache/production/ directory must also be writable.

You could try to remove all the content of that directory (cache/production/), they will be generated again.
Hi,

I want to install 3.3.0 from 3.2.8 to. Strato.de

Image

cache/install is 755, cache/production is 755. Both must be writable?
3 Files in cache/production, must I delete them? In cache/install is nothing.

Thanks for your help,
kjh-mov
Wer nichts weiß, muss alles glauben.

Marie von Ebner-Eschenbach
User avatar
warmweer
Jr. Extension Validator
Posts: 5547
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: php lock errors after 3.3.0 update

Post by warmweer »

kjh-mov wrote:
Tue Jan 21, 2020 4:52 am

I want to install 3.3.0 from 3.2.8 to. Strato.de

Image

cache/install is 755, cache/production is 755. Both must be writable?
3 Files in cache/production, must I delete them? In cache/install is nothing.
Your printscreen shows file diffing. Is there any reason for not using the full update package ( only database-Update is needed unless you have custom edits and file diffing between major versions will in most cases introduce errors.

I suggest you start over with the full package, in /store, delete install_config.php, nay migrations xxx and io_lock_lock before restarting the upgrade following Upgrading from 3.2 to 3.3
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
kjh-mov
Registered User
Posts: 48
Joined: Mon May 07, 2018 12:23 pm
Contact:

Re: php lock errors after 3.3.0 update

Post by kjh-mov »

warmweer wrote:
Tue Jan 21, 2020 7:59 am
Your printscreen shows file diffing. Is there any reason for not using the full update package ( only database-Update is needed unless you have custom edits and file diffing between major versions will in most cases introduce errors.

I suggest you start over with the full package, in /store, delete install_config.php, nay migrations xxx and io_lock_lock before restarting the upgrade following Upgrading from 3.2 to 3.3
I have custom edits ... :cry:

First I had problems with .htaccess. I fix it.

https://www.phpbb.de/community/viewtopi ... dfe9456e2d

Now it stop again at this position:
Datenbank aktualisieren…

3%

3%
Richte Daten ein: \phpbb\db\migration\data\v32x\v329rc1.
Installiertes Schema: \phpbb\db\migration\data\v32x\v329rc1; Dauer: 0.00 Sekunden
Installiere Schema: \phpbb\db\migration\data\v32x\v329rc1.
Wer nichts weiß, muss alles glauben.

Marie von Ebner-Eschenbach
User avatar
warmweer
Jr. Extension Validator
Posts: 5547
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: php lock errors after 3.3.0 update

Post by warmweer »

kjh-mov wrote:
Tue Jan 21, 2020 11:19 am
I have custom edits ... :cry:
I can understand using the autoupdate when updating to a minor version, but not with a major version upgrade);
The number of files that are different is so much larger + the risk that code for a lower major version doesn't work in a higher major version is so much greater (in fact IMHO it would help avoid a lot of support topics if the autoUPGRADE would be prevented, and only autoUPDATE were allowed.
The only advice I can give is to follow the upGRADE instructions, if necessary on a personal webserver.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
kjh-mov
Registered User
Posts: 48
Joined: Mon May 07, 2018 12:23 pm
Contact:

Re: php lock errors after 3.3.0 update

Post by kjh-mov »

warmweer wrote:
Tue Jan 21, 2020 11:28 am
kjh-mov wrote:
Tue Jan 21, 2020 11:19 am
I have custom edits ... :cry:
I can understand using the autoupdate when updating to a minor version, but not with a major version upgrade);
The number of files that are different is so much larger + the risk that code for a lower major version doesn't work in a higher major version is so much greater (in fact IMHO it would help avoid a lot of support topics if the autoUPGRADE would be prevented, and only autoUPDATE were allowed.
The only advice I can give is to follow the upGRADE instructions, if necessary on a personal webserver.
It's ok. ;)

Good moment to make all better ...

Thank you for your help, warmweer :D
Wer nichts weiß, muss alles glauben.

Marie von Ebner-Eschenbach
Post Reply

Return to “[3.3.x] Support Forum”