Extension error in acp after update from 3.2.8 to 3.3.0

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
markus808
Registered User
Posts: 6
Joined: Fri Nov 11, 2005 9:42 pm

Extension error in acp after update from 3.2.8 to 3.3.0

Post by markus808 »

After updating from 3.2.8 to 3.3.0 I receive a red error in the the acp regarding the stopforumspam extension. I tried purging the forum cache.

Exception: The file "/home/statecom/public_html/forum/ext/rmcgirr83/stopforumspam/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 5 (near "- @config")...

I've added the information into the support template:

Support Request Template
What version of phpBB are you using? phpBB 3.3.0
What is your board's URL? https://www.808state.com/forum
Who do you host your board with? https://www.pickaweb.co.uk
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.8
What extensions do you have installed? Stop Forum Spam
What styles do you currently have installed? prosilver
What language(s) is your board currently using? British English
Which database type/version are you using? MariaDB
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Updating from 3.2.8 to 3.3.0
Please describe your problem. I used the automatic updating for the first time, and it all went a bit fast, at some point there was a message displayed that about ten files nees to be deleted, but before I knew I had clicked onwards and didn't take note. Now I'm not sure if those files were deleted automatically, or if I should have done that manually. Maybe that is the issue. The update went OK, but I have the following error in the ACP:

phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.

Exception: The file "/home/statecom/public_html/forum/ext/rmcgirr83/stopforumspam/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 5 (near "- @config").

#0 /home/statecom/public_html/forum/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('/home/statecom/...')
#1 /home/statecom/public_html/forum/phpbb/extension/di/extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 /home/statecom/public_html/forum/phpbb/extension/di/extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 /home/statecom/public_html/forum/vendor/symfony/dependency-injection/Compiler/MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 /home/statecom/public_html/forum/vendor/symfony/http-kernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 /home/statecom/public_html/forum/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 /home/statecom/public_html/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 /home/statecom/public_html/forum/phpbb/di/container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 /home/statecom/public_html/forum/common.php(115): phpbb\di\container_builder->get_container()
#9 /home/statecom/public_html/forum/adm/index.php(23): require('/home/statecom/...')
#10 {main}
Generated by SRT Generator

Thanks in advance for any help on this.
Markus

User avatar
invenio
Registered User
Posts: 140
Joined: Wed Dec 09, 2015 1:45 pm
Location: New Hampshire, USA
Contact:

Re: Extension error in acp after update from 3.2.8 to 3.3.0

Post by invenio »

Why did you use automatic update? You should be doing the full package upgrade method as advised in the documentation. Did you disable all your extensions prior to the upgrade as recommended?

User avatar
warmweer
Registered User
Posts: 3501
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Extension error in acp after update from 3.2.8 to 3.3.0

Post by warmweer »

markus808 wrote:
Mon Jan 13, 2020 9:04 pm
After updating from 3.2.8 to 3.3.0 I receive a red error in the the acp regarding the stopforumspam extension. I tried purging the forum cache.

Exception: The file "/home/statecom/public_html/forum/ext/rmcgirr83/stopforumspam/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 5 (near "- @config")...
You could try a possible solution
viewtopic.php?p=15402471#p15402471
No guarantees given. And you should at least check all extensions using david63's .yml checker, probably too late for that.
Brexit and Trump are old news and currently I have no inspiration for a new signature.
Ow, wait: 3.3 has been released.

User avatar
janus_zonstraal
Registered User
Posts: 3920
Joined: Sat Aug 30, 2014 1:30 pm

Re: Extension error in acp after update from 3.2.8 to 3.3.0

Post by janus_zonstraal »

And you should at least check all extensions using david63's .yml checker, probably too late for that.
Indeed because that extension is not working on 3.3.0 :lol:
Sorry! My English is bat ;) !!!

User avatar
david63
Registered User
Posts: 17041
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Extension error in acp after update from 3.2.8 to 3.3.0

Post by david63 »

janus_zonstraal wrote:
Mon Jan 13, 2020 9:31 pm
Indeed be course that extension is not working on 3.3.0
Yes it is
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
janus_zonstraal
Registered User
Posts: 3920
Joined: Sat Aug 30, 2014 1:30 pm

Re: Extension error in acp after update from 3.2.8 to 3.3.0

Post by janus_zonstraal »

Ok, did you change it, the first version wasn't working on 3.3.0 I remember.
Sorry! My English is bat ;) !!!

User avatar
david63
Registered User
Posts: 17041
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Extension error in acp after update from 3.2.8 to 3.3.0

Post by david63 »

janus_zonstraal wrote:
Mon Jan 13, 2020 9:37 pm
Ok, did you change it, the first version wasn't working on 3.3.0 I remember.
Nope - it works "out of the box" on 3.3.0
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
janus_zonstraal
Registered User
Posts: 3920
Joined: Sat Aug 30, 2014 1:30 pm

Re: Extension error in acp after update from 3.2.8 to 3.3.0

Post by janus_zonstraal »

Then my memory is in error :roll:
Sorry! My English is bat ;) !!!

Post Reply

Return to “[3.3.x] Support Forum”