phpBB encountered an error building the container due to an installed extension

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
AlexandrBu
Registered User
Posts: 44
Joined: Tue Jan 02, 2018 6:31 am

phpBB encountered an error building the container due to an installed extension

Post by AlexandrBu »

Hello
ammmm as far all extension what i need does not work, and i dont know if athours will update them!

I have php 7.2 and i had phpbb 3.2.8 after upgrade to 3.3.0 extensions does not work with error
phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.

Exception: The file "/usr/www/forum/ext/bb3mobi/imgposts/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 5 (near "- @template").
I just dont know php, but the error the same for all extensions, can i do something by myself with it?

P.S. I realyyy love this exstentions
Images from posts 1.0.5 Details Enable | Delete data
Posts merging 2.1.0 Details Enable | Delete data
Thanks for posts 3.0.7 Details Enable | Delete data
User avatar
janus_zonstraal
Registered User
Posts: 5128
Joined: Sat Aug 30, 2014 1:30 pm

Re: phpBB encountered an error building the container due to an installed extension

Post by janus_zonstraal »

Did you have a look into the support forums from that extensions?
Sorry! My English is bat ;) !!!
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 5253
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: phpBB encountered an error building the container due to an installed extension

Post by HiFiKabin »

Check out this extension that may help you solve the errors viewtopic.php?f=456&t=2528456
User avatar
AlexandrBu
Registered User
Posts: 44
Joined: Tue Jan 02, 2018 6:31 am

Re: phpBB encountered an error building the container due to an installed extension

Post by AlexandrBu »

janus_zonstraal wrote:
Sat Feb 01, 2020 7:50 pm
Did you have a look into the support forums from that extensions?
No hope for that! For example "Images from posts" last update on 2014 and its a grate ext - it takes the image from first post and put in as preview in forum list!!!
User avatar
AlexandrBu
Registered User
Posts: 44
Joined: Tue Jan 02, 2018 6:31 am

Re: phpBB encountered an error building the container due to an installed extension

Post by AlexandrBu »

HiFiKabin wrote:
Sat Feb 01, 2020 7:53 pm
Check out this extension that may help you solve the errors viewtopic.php?f=456&t=2528456
Not helped me, its just generic recomendation for php coders

For me phpBB is 50% its extentions, and its very sad that the lost them all after just update from 3.2 to 3.3...
Attachments
Screenshot_2020-02-02 Extensions yml Files Syntax Check.png
User avatar
warmweer
Jr. Extension Validator
Posts: 6523
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: phpBB encountered an error building the container due to an installed extension

Post by warmweer »

AlexandrBu wrote:
Sun Feb 02, 2020 3:24 pm
HiFiKabin wrote:
Sat Feb 01, 2020 7:53 pm
Check out this extension that may help you solve the errors viewtopic.php?f=456&t=2528456
Not helped me, its just generic recomendation for php coders

For me phpBB is 50% its extentions, and its very sad that the lost them all after just update from 3.2 to 3.3...
It's not a recommendation.
It's a necessity as those extensions work with 3.2 but not with 3.3 due to changed coding requirements. That extension will allow you to solve a specific coding requirement problem (that is checked) and that may be sufficient to make the extension work again. If it isn't you'll just have to wait for an upgraded version of the extension (and this is not something unexpected with upgrades (see phpBB2 --> PHPbb3.0 and phpBB3.0 --> 3.1, even sometime 3.1, and even so sometimes 3.2.x to 3.2.higherx).
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
AlexandrBu
Registered User
Posts: 44
Joined: Tue Jan 02, 2018 6:31 am

Re: phpBB encountered an error building the container due to an installed extension

Post by AlexandrBu »

Hi, sorry for delay

I am having second attempt to move to 3.3.x

looks like in case of my favourite addon 3.3.x has just a syntactise(grammatical) problem

just changing one file services.yml
all lines like

Code: Select all

- @config
- %something%
to

Code: Select all

- '@config'
- '%something%'
fixes the 3.3.x problem with 3.2.x addons

keep testing it
some time its not only one file found by Extensions .yml Files Syntax Check

and
word

Code: Select all

pattern:
must be changed to

Code: Select all

path:
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51890
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: phpBB encountered an error building the container due to an installed extension

Post by stevemaury »

So is your issue resolved?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
Post Reply

Return to “[3.3.x] Support Forum”