YouTube BBCode Issue

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
ChinaGal
Registered User
Posts: 90
Joined: Fri Jan 24, 2020 10:02 am

YouTube BBCode Issue

Post by ChinaGal »

I am trying to get BBCode setup for inserting YouTube video links into topics on the forum. I went to ACP > Posting > BBCodes and added a new BBCode for YouTube. Then I got the BBCode to insert for the settings for YouTube from a topic on this forum.

So for BBCode usage I am using (not sure if it is up to date or not):

Code: Select all

[youtube]{IDENTIFIER}://{SIMPLETEXT1}youtube.com/watch?v={SIMPLETEXT2}[/youtube]
For HTML replacement I have (not sure if it is up to date or not):

Code: Select all

<object width="425" height="350"><param name="movie" value="{IDENTIFIER}://{SIMPLETEXT1}youtube.com/v/{SIMPLETEXT2}"></param><param name="wmode" value="transparent"></param><embed src="{IDENTIFIER}://{SIMPLETEXT1}youtube.com/v/{SIMPLETEXT2}" type="application/x-shockwave-flash" wmode="transparent" width="425" height="350"></embed></object>
And for Help line text I have:

Code: Select all

Enter the YouTube video URL
I have a problem though. I can't successfully submit the HTML replacement code into the forum though. If I put it in there, and then click submit, I get a 403 error from my server and I am not able to submit the HTML replacement code. I am only able to save the BBCode usage code and I also was able to enable Display on posting page.

When I go to create a post though, the new YouTube BBCode button is now there. When I click on the button it works and lays down the BBCode within the post, but when I put in a YouTube video link and submit the new topic it doesn't work. The YouTube video doesn't appear.

I have 2 questions please:

1 - I assume it is not working because without the HTML replacement code entered in, then the BBCode wont work?

2 - What might be causing the 403 error from my server and preventing me from saving the HTML replacement code on the site?

Thank you so much for any possible assistance you can offer.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69625
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: YouTube BBCode Issue

Post by KevC »

It's not worth the effort to use a BBcode because youtube uses multiple link forms.

Just use this
https://www.phpbb.com/customise/db/exte ... ediaembed/

you paste the link and it shows up, that's it. Also works for twitter and numerous other kinds of media.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
ChinaGal
Registered User
Posts: 90
Joined: Fri Jan 24, 2020 10:02 am

Re: YouTube BBCode Issue

Post by ChinaGal »

Sounds like the way to go, thank you. I’ll give it a try.

Post Reply

Return to “[3.3.x] Support Forum”