HTTP ERROR 500 after upgrading to 3.3 & PHP 7.2

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
golfeasy23
Registered User
Posts: 2
Joined: Mon Feb 10, 2020 11:11 am

HTTP ERROR 500 after upgrading to 3.3 & PHP 7.2

Post by golfeasy23 »

Hi,

Recently I upgraded from PHP 5.2 to PHP 7.2 and I got a a HTTP ERROR 500 when I try to visit the phpBB forum. I restarted Apache and it fixed the problem but the forum wasn't stable. I was still on phpbb 3.2

After that I could log in to the forum but I got the HTTP ERROR 500 when trying to go to the control panel, eventually I just managed to get to the control panel without doing anything but when I tried to do a few things with the database (reset dotted lines, etc. ... cant remember all of them) I got a HTTP ERROR 500 and couldn't get back to the board since.

I tried upgrading to the latest version of phpBB by following the upgrade instructions but there are some files I could not delete via FTP. I copied the files over anyway but two files couldn't be copied over -
\cache\.htaccess
\cache\index.htm

I tried restarting Apache but still getting a black screen https://forum.clogherhistory.ie/

I tried looking for the error log but only have found php_errors.log which is a massive file but hasn't had an entry for over 10 days. I don't have access to the control panel to view errors.log

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51081
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: HTTP ERROR 500 after upgrading to 3.3 & PHP 7.2

Post by stevemaury »

If there are files or folders you can't delete, rename them. Add a .bak extension. Those two /cache/* files do not matter if not over-copied.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

golfeasy23
Registered User
Posts: 2
Joined: Mon Feb 10, 2020 11:11 am

Re: HTTP ERROR 500 after upgrading to 3.3 & PHP 7.2

Post by golfeasy23 »

thanks for that idea, I'm going to try it now

User avatar
EA117
Registered User
Posts: 1297
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: HTTP ERROR 500 after upgrading to 3.3 & PHP 7.2

Post by EA117 »

The fact that your FTP user isn't able to access those files to overwrite them may also be the important symptom, and at least one possible cause of the HTTP 500 error. i.e. If we look in the PHP error log, it may be citing that the /cache directory isn't writeable by the user the HTTP server is running as, either. You might want to check what permissions are set on the /cache directory and those files in the /cache directory, if you're able.

The fact that your PHP error log hasn't had any new entries in ten days... does this correspond to the length of time since the PHP upgrade? Just wondering if perhaps the PHP errors are now being logged elsewhere as a result of the updated PHP version and configuration. Either to a different stand-alone error log with a different name or location, or maybe now as part of the HTTP server error log, or even possibly now in the operating system error log.

If you don't have another way to view the current PHP configuration info, one thing I would try is to temporarily put the /install directory back again and use the phpinfo.php there to confirm what "error_log" is configured as, in case there is a particular file name or path you need to be looking for. That's presuming you can't get far enough into the phpBB ACP to use the "PHP Information" link already provided there.

Wirral Talk
Registered User
Posts: 74
Joined: Mon Jun 09, 2014 12:29 am
Location: Wirral, UK
Contact:

Re: HTTP ERROR 500 after upgrading to 3.3 & PHP 7.2

Post by Wirral Talk »

I hit a 500 error the other day, by fluke I found it had come about during an SSL certificate change and I couldn't find any other possible cause, I'd left it overnight thinking it would clear itself but it didn't. Clearing the browser cookies, history etc cleared the error.

Post Reply

Return to “[3.3.x] Support Forum”