how to debug the phpBB-Version 3.3.0 - not installed yet

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
apollodriver
Registered User
Posts: 31
Joined: Tue Jan 21, 2020 11:35 am

how to debug the phpBB-Version 3.3.0 - not installed yet

Post by apollodriver »

hello dear phpbb-experts,



i have to admit that i have quiete a very less knowledge on phhBB - can you plz try to understand my question....thank's a lot...
I Install Debug Tools in my root shown below.

well i have found this tool: xampp\htdocs\phpBB\ext\nicofuma\debugtools
Extension Name: Debug Tools
Author: Nicofuma
Extension Version:: 1.0.0-b1
Requirements: 3.1.0-RC3
i downloaded from this link
cf: https://github.com/Nicofuma/phpbb-ext-debugtools

bes
ides this i have seen that we can debug like described here:

viewtopic.php?t=2349466

@define('PHPBB_DISPLAY_LOAD_TIME', true);
@define('DEBUG', true);
@define('DEBUG_CONTAINER', true);
well - note: i did not have install the phpBB version 3.3. all ready. No : i just have downloaded the files and put it on to the server _ which runs on php 7.2.8

so - at the moment the config file has got no content!?

Love to hear from you
for Wordpress-development - i use the Toolset: http://wpgear.org/

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25939
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: how to debug the phpBB-Version 3.3.0 - not installed yet

Post by Paul »

Why do you need to debug it? What error are you getting?
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

User avatar
Mick
Support Team Member
Support Team Member
Posts: 22083
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket.

Re: how to debug the phpBB-Version 3.3.0 - not installed yet

Post by Mick »

Install 3.3 as per the instructions here (it says 3.2 but it’s the same for 3.3) or here and config.php will populate intself. It’s not clear, to me anyway, what your issue is, please fill out the Support Request Template and post it back here to enable us to assist you better.
"The more connected we get the more alone we become" - Kyle Broflovski

Please read: “Am I In The Right Place?” before posting.

User avatar
Lumpy Burgertushie
Registered User
Posts: 67236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: how to debug the phpBB-Version 3.3.0 - not installed yet

Post by Lumpy Burgertushie »

those debug tools are for an older version of phpbb.

delete that from your ext folder as it may not be compatible with phpbb 3.3

just install phpBB3 3.3.0 following the install instructions.

You will not need to debug anything so forget about that unless some time in the future you have a problem. you should not have any problems that you need to debug for .


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

User avatar
warmweer
Jr. Extension Validator
Posts: 3910
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: how to debug the phpBB-Version 3.3.0 - not installed yet

Post by warmweer »

Why start a new topic when your previous one isn't solved yet?
you are requesting a debug of phpBB when it isn't even installed yet, either because something is missing on your server or because you're doing something you're not supposed to do (or not doing what you're supposed to do).

Also extensions run on phpBB, implying it has to be installed before any extension (phpBB extension that is) can function.
The instructions for installation of phpBB can be found in https://www.phpbb.com/support/docs/en/3 ... tallation/.
How about telling us the url of your host and which kind of hosting you bought/rented.

On January 21 you enquired about a policy extension (see viewtopic.php?f=496&t=2537721) but it seems you didn't (and still don't) have a board up and running. Do you know (or can find?) the requirements for a PHPBB installation?
We should embrace problems, without which there wouldn't be any solutions.

Post Reply

Return to “[3.3.x] Support Forum”