update 3.2.1-3.3.0 timeout error forum does not work

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
lan
Registered User
Posts: 1
Joined: Sat Feb 22, 2020 9:45 pm

update 3.2.1-3.3.0 timeout error forum does not work

Post by lan »

I update this post because during moderation it was some progress and now issue changed.

The story is I tried to update automatically from 3.2.1 to 3.3.0. My phpbb admin panel somehow had this option to download update 3.2.1 to 3.3.0 zip archive I can't attach here because it is too large. I just was in admin panel and went to updates tab. I saw some options and there one could upload the update zip archive and I chose my current 3.2.1 version only. So when I got into /install I chose update tab in my example.com/install and reached the step "update files": example.com/install/app.php/update and stuck when it came to conflicting files. I manually solved conflicting files not in the internet and deleted install folder in root, then I put new revised install folder back so that these files can wipe old ones. But as it was in another folder it did not appear in /install and I saw blank screen.

After I repack install folder back to root once more and now example.com/install link works gain, BUT it still throws me into update files tab and when I click update it gives timeout error:

"The installer detected a timeout

The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI."

It appears in few seconds or one second after clicking update.

this is a part of error log in my root ("path to forum" is root folder of this forum - the one with config.php)

[22-Feb-2020 17:16:48 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /path to forum/includes/functions.php:3262) in /path to forum/includes/functions.php on line 4516
[22-Feb-2020 17:16:48 UTC] PHP Fatal error: Uncaught Error: Call to private method Twig\Loader\FilesystemLoader::validateName() from context 'phpbb\template\twig\loader' in /path to forum/phpbb/template/twig/loader.php:140
Stack trace:
0 /path to forum/vendor/twig/twig/src/Loader/FilesystemLoader.php(150): phpbb\template\twig\loader->findTemplate('message_body.ht...')
1 /path to forum/vendor/twig/twig/src/Environment.php(299): Twig\Loader\FilesystemLoader->getCacheKey('message_body.ht...')
2 /path to forum/vendor/twig/twig/src/Environment.php(381): Twig\Environment->getTemplateClass('message_body.ht...')
3 /path to forum/phpbb/template/twig/environment.php(277): Twig\Environment->loadTemplate('message_body.ht...', NULL)
4 /path to forum/vendor/twig/twig/src/Environment.php(359): phpbb\template\twig\environment->loadTemplate('message_body.ht...')
5 /path to forum/vendor/twig/twig/src/Environment.php(318): Twig\Environment-> in /path to forum/phpbb/template/twig/loader.php on line 140


When I try to access the admin page where I got instructions to update: example.com docs/INSTALL.html I get another error:

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/template/twig/lexer.php on line 16: Declaration of phpbb/template/twig/lexer::tokenize($code, $filename = NULL) should be compatible with Twig/Lexer::tokenize(Twig/Source $source)
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/template/twig/loader.php on line 19: Declaration of phpbb/template/twig/loader::findTemplate($name) should be compatible with Twig/Loader/FilesystemLoader::findTemplate($name, $throw = true)

My forum does not work right now, I can't update it and I can't restore it back because if I put install folder out of root main page of forum will still not work, it is just blank page. What I do now?

Thank you.

Post Reply

Return to “[3.3.x] Support Forum”