New Install 3.3 stalls on final page - sending notification e-mail

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
durangod
Registered User
Posts: 709
Joined: Tue Nov 03, 2009 1:26 pm
Name: Dave

New Install 3.3 stalls on final page - sending notification e-mail

Post by durangod »

I installed php 3.3 new install, all went well until the last page... Its 85% and says sending notification email and it has stalled out. What should i do, remove it and rerun install or what... please advise.. thanks

FYI i am running cpanel with php version 7.3

see pic...
phpbb_installhang.jpg
UPDATE: I am in the ACP now on another browser and have renamed the install folder but i left the tab open with the stalled out install in case i need to go back to it. So far the ACP seems to be working, if sending the email was the last step and the email failed then that would explain the stall.

UPDATE2: yes that was it... the error log had this
Email error
» EMAIL/SMTP
/forum/install/app.php

Could not get mail server response codes.
Backtrace

Connecting to example.net:465

Does anything come after the email notification in the install process? I will also check out the install if so and see if i can run anything missed manually :)
User avatar
janus_zonstraal
Registered User
Posts: 4854
Joined: Sat Aug 30, 2014 1:30 pm

Re: New Install 3.3 stalls on final page - sending notification e-mail

Post by janus_zonstraal »

Maybe set the email settings in the ACP will do the trick.
Sorry! My English is bat ;) !!!
User avatar
durangod
Registered User
Posts: 709
Joined: Tue Nov 03, 2009 1:26 pm
Name: Dave

Re: New Install 3.3 stalls on final page - sending notification e-mail

Post by durangod »

Good morning all...

After looking at the install process this morning, it appears that the sending of the email notification is indeed near the very end of the process, so all the important stuff seems to have been completed by that point, maybe some cleanup of the config but i cant tell if that happens before or after or at the same time.

But it seems to run fine even though the install did not finish.


I do have one question and one recommendation.

Question: I deleted the install folder in the root, but what about the install folder in the phpbb dir - does that need to be removed as well?

Recommendation: maybe add a SMTP test to the beginning of the install and flag it if it does not work. Or add some kind of other error control to allow the install to finish if it fails and show a message that the email was not send due to SMTP failure. In any regard, IMO a failed email should never cause an install to fail, maybe just a bit of tweaking on this needs to be considered. :)
User avatar
warmweer
Jr. Extension Validator
Posts: 5539
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: New Install 3.3 stalls on final page - sending notification e-mail

Post by warmweer »

durangod wrote:
Fri Feb 28, 2020 5:08 pm
Question: I deleted the install folder in the root, but what about the install folder in the phpbb dir - does that need to be removed as well?
No, only the /install in the root should be removed.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22833
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: New Install 3.3 stalls on final page - sending notification e-mail

Post by Mick »

If the instructions tell you to delete the domain.tld/install folder and nothing else, that’s all you have to do, no more.
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
durangod
Registered User
Posts: 709
Joined: Tue Nov 03, 2009 1:26 pm
Name: Dave

Re: New Install 3.3 stalls on final page - sending notification e-mail

Post by durangod »

Understood thanks... What about my recommendation, is it something to consider?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22833
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: New Install 3.3 stalls on final page - sending notification e-mail

Post by Mick »

Personally I’m not a big fan of SMTP for normal board use but that’s my preference. If you wish to follow up on your suggestion you can make a new topic in the ideas forum.
"The more connected we get the more alone we become" - Kyle Broflovski©
Post Reply

Return to “[3.3.x] Support Forum”