Attachments settings in the ACP

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
3Di
Former Team Member
Posts: 16052
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 - Frankfurt 🇩🇪
Name: Marco
Contact:

Re: Attachments settings in the ACP

Post by 3Di »

Does it happens also using prosilver and english?
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ยบ PhpStorm's proud user ยบ Extensions, Scripts, MOD porting, Update/Upgrades
๐Ÿš€ Looking for a specific feature or alternative option? We will rock you! ๐Ÿš€
roiebh
Registered User
Posts: 29
Joined: Fri Jan 21, 2011 10:20 am

Re: Attachments settings in the ACP

Post by roiebh »

3Di wrote: โ†‘
Fri Apr 24, 2020 9:43 pm
Does it happens also using prosilver and english?
BINGO - no it doesn't!
alright, so what's next?
because I tried to replace the attachments.php file in the language/acp
and it didn't change a thing, so I thought it's not a translation issue.
User avatar
3Di
Former Team Member
Posts: 16052
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 - Frankfurt 🇩🇪
Name: Marco
Contact:

Re: Attachments settings in the ACP

Post by 3Di »

It is, some of your language files (not English) contains bad chars or is not coded UTF8.
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ยบ PhpStorm's proud user ยบ Extensions, Scripts, MOD porting, Update/Upgrades
๐Ÿš€ Looking for a specific feature or alternative option? We will rock you! ๐Ÿš€
roiebh
Registered User
Posts: 29
Joined: Fri Jan 21, 2011 10:20 am

Re: Attachments settings in the ACP

Post by roiebh »

3Di wrote: โ†‘
Fri Apr 24, 2020 10:42 pm
It is, some of your language files (not English) contains bad chars or is not coded UTF8.
Ok, how would you suggest to start tracking it?
Tried to upload the attachments.php again after saving under UTF8 and I still have a problem.
Should I just replace the Hebrew files with the English files one by one (or 5 by 5) until I get ride of this problem and try to locate the problematic file?
User avatar
tbackoff
Former Team Member
Posts: 7064
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: Attachments settings in the ACP

Post by tbackoff »

I see I lay down for a nap and y'all get chatty. :lol:
roiebh wrote: โ†‘
Fri Apr 24, 2020 10:55 pm
Should I just replace the Hebrew files with the English files one by one (or 5 by 5) until I get ride of this problem and try to locate the problematic file?
Looks like the Hebrew translation hasn't been updated since 3.2.5. However, yes, start uploading files 1 by one (I would start with the files in \language\en\acp). I'm guessing attachments.php and common.php in that folder would be the culprit.
Flying is the second best thrill to cheerleaders; being caught is the first.
roiebh
Registered User
Posts: 29
Joined: Fri Jan 21, 2011 10:20 am

Re: Attachments settings in the ACP

Post by roiebh »

OK!!!
Found it!
It was the viewtopic.php file on the main language (he) directory!
There was a vixen letter at the beginning of the code.

Thank you for everyone who helped me through this :)

BTW I translated the new version 3.3 by myself, following the change log from 3.2.5>3.2.9>3.3 (all the early versions)>3.3 final,
that's why there was an issue.

Take care :)
User avatar
3Di
Former Team Member
Posts: 16052
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 - Frankfurt 🇩🇪
Name: Marco
Contact:

Re: Attachments settings in the ACP

Post by 3Di »

Language files are php files therefore they produce error logs in case.
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ยบ PhpStorm's proud user ยบ Extensions, Scripts, MOD porting, Update/Upgrades
๐Ÿš€ Looking for a specific feature or alternative option? We will rock you! ๐Ÿš€
User avatar
Lumpy Burgertushie
Registered User
Posts: 68282
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Attachments settings in the ACP

Post by Lumpy Burgertushie »

sounds like the problem could be the text editor you are using to edit the language files.

you MUST use a plain text editor like notepad++ or editpad lite. something that does not put anything at the beginning of the files like a BOM/byte order mark

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
roiebh
Registered User
Posts: 29
Joined: Fri Jan 21, 2011 10:20 am

Re: Attachments settings in the ACP

Post by roiebh »

Thank you all so much!

Another issue I couldn't figure out how to solve is the "Full Editor" button that I cannot "translate" it.
Of course in the language files I translated it, but it insist staying in english.
See the attachment.
Attachments
Screen Shot 2020-05-26 at 7.24.08 PM.png
User avatar
Lumpy Burgertushie
Registered User
Posts: 68282
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Attachments settings in the ACP

Post by Lumpy Burgertushie »

just a wild guess. probably a style issue. maybe the template file for the quck reply has it hard coded instead or using a language variable. what style is that?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
roiebh
Registered User
Posts: 29
Joined: Fri Jan 21, 2011 10:20 am

Re: Attachments settings in the ACP

Post by roiebh »

User avatar
Lumpy Burgertushie
Registered User
Posts: 68282
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Attachments settings in the ACP

Post by Lumpy Burgertushie »

ok, proflat inherits from prosilver. the quickreply_editor.html file is where that is but because it is a prosilver file the problem is not in that file.

check your language/( whatever language you said you did the translation for )/viewtopic.php file.
look for this line:
'FULL_EDITOR' => 'Full Editor & Preview',

if you don't have that line, add it with your translation. if you do have it make sure it is correct.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
roiebh
Registered User
Posts: 29
Joined: Fri Jan 21, 2011 10:20 am

Re: Attachments settings in the ACP

Post by roiebh »

I tried to change it so many times.
I also copy this line again from the original file and rewrote it.
Also tried to leave it in English, because I don't get the full text with is Full editor and Preview, but only Full Editor.

Strange.... :(

BTW it's happening also with other styles.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68282
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Attachments settings in the ACP

Post by Lumpy Burgertushie »

copy and paste that line from your translation here please.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
roiebh
Registered User
Posts: 29
Joined: Fri Jan 21, 2011 10:20 am

Re: Attachments settings in the ACP

Post by roiebh »

Code: Select all

	'FULL_EDITOR'			=> 'ืขื•ืจืš ืžืœื & ืชืฆื•ื’ื” ืžืงื“ื™ืžื”',

Attachments
viewtopic_copy.php
(5.13 KiB) Downloaded 4 times
Post Reply

Return to โ€œ[3.3.x] Support Forumโ€