Database not fully updated, blobs still in db?

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Registered User
Posts: 733
Joined: Mon Oct 24, 2016 3:22 pm
Location: Namek

Database not fully updated, blobs still in db?

Post by Toxyy »

Support Request Template
What version of phpBB are you using? phpBB 3.3.0
What is your board's URL? n/a
Who do you host your board with? hostgator
How did you install your board? I used the download package from
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.2.2
What styles do you currently have installed? Acidtech, MilkV2
What language(s) is your board currently using? en, en_us
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Updated a copy of the forum in a subfolder via automatic update, then ran the same process on the main board
Please describe your problem. I have 3 issues here. #2 and #3 are more important, and are my reason for posting.

1) The database wasn't updating. I attempted to run the auto updater on the main board and the files updated, and it said that the database update was complete, but the ACP was still registering as 3.2.2. I checked the migration files for 3.3 and some versions inbetween, and the database did have those updates present for multiple versions after 3.2.2. So, the db was updated, but the version number wasn't changed for some reason. No adverse affects have been noticed and everything is running smoothly. The copy of the forum in the subfolder did not have this issue.

I tried updating the db via cli, removing the lock from /store, migration files, and install_config.php, doing a full package update instead with a fresh /install, and received the same issue. I also cleared the cache via the acp and manually multiple times.

2) Blobs are still used in the database. Much if it is in MyISAM and there is a mix in collation between utf8_general_ci and utf8_bin for some tables. The db itself is in utf8_unicode_ci, and it is in InnoDB, but none of the tables are. I took a look in the topics and posts tables, and blobs are still being used. Is there a tool I can run to fix this deprecation?

3) Attachments aren't working on a few posts (this was happening prior to the update), though the files are there. The file 1146_3bd820fdf7a820e87da9e11c68d4f2d6 is present and in the filesystem, under attachment id 1589, but the file will not load. The row exists in the attachments table and it is linked to the proper topic id, post id, and filename, but it still won't load for some reason. Other attachments in other topics work fine. They are not orphan attachments. What's going on here?

EDIT - I was able to solve #3, it turns out a lot of the attachments were corrupted on transfer during the site move/two updates ago. I was able to find a backup and the attachments that weren't working did work there, so I changed the setting in filezilla according to the guide on this site and it worked after clearing my browser's cache.

#2 is the most important issue now.
Generated by SRT Generator
I am a web developer/administrator, specializing in forums. If you have work you need done or are too lazy to do, pm me!

My extensions:
[3.2][BETA] Anonymous Posts || [3.2][BETA] Sticky Ad || [3.2][RC] Show User Activity ||
[3.2][DEV] User Delete Topics

Post Reply

Return to “[3.3.x] Support Forum”