Updating my Forum

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Funk Theory
Registered User
Posts: 736
Joined: Mon Sep 25, 2006 3:33 pm
Location: UK
Contact:

Updating my Forum

Post by Funk Theory »

Hi, I have only recently started using my forum again and its out of date on phpbb. Im on 3.2.7, how do i upgrade? If i remember from years ago, am i right in saying I have to go to 3.3.0 then to current version? Thank you
User avatar
Lumpy Burgertushie
Registered User
Posts: 68323
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Updating my Forum

Post by Lumpy Burgertushie »

3.3.0 is the current version.

it will be an upgrade, not an update.

https://www.phpbb.com/support/docs/en/3 ... upgrade32/

be sure to follow all the instructions exactly and in order and you should have no problems.

most important is the backup of files and database before you start.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
Funk Theory
Registered User
Posts: 736
Joined: Mon Sep 25, 2006 3:33 pm
Location: UK
Contact:

Re: Updating my Forum

Post by Funk Theory »

Thank you. One other question. Years ago, when you set permissions eg for guests, you used to be able to set it so they could see the forum but to see whats inside it eg read the posts, it forced them to login, is that still possible, i cant see that option?

(edit: found it dont worry)
Last edited by Funk Theory on Sat May 16, 2020 12:04 pm, edited 1 time in total.
User avatar
P_I
Registered User
Posts: 1348
Joined: Tue Mar 01, 2011 8:35 pm
Location: Staying home - Western Canada
Contact:

Re: Updating my Forum

Post by P_I »

Funk Theory wrote:
Fri May 15, 2020 6:16 pm
Hi, I have only recently started using my forum again and its out of date on phpbb. Im on 3.2.7, how do i upgrade? If i remember from years ago, am i right in saying I have to go to 3.3.0 then to current version? Thank you
You could also update to phpBB 3.2.9 Release - Please Update.

The main reason to upgrade to phpBB 3.3 is under the covers rather than features that users with notice,
Marc wrote:
Mon Jan 06, 2020 11:54 am
The new phpBB 3.3 Proteus builds upon 3.2 Rhea and is a big step towards a more modern base while maintaining a clear update path. It is now shipped with Symfony 3.4, Twig 2, and jQuery 3.4. The improvements include, among others, support for Invisible reCAPTCHA, Argon2i and Argon2id password hashing, improved reset password functionality, and minor changes to the UI.
The minimum supported PHP version has been increased to PHP 7.1.3 while support for PHP 7.3 and PHP 7.4 has been added. Fixed security issues in 3.2.9 are part of this release as well.
From my perspective the moving to more current and up-to-date PHP versions was an important factor in the decision to upgrade boards to phpBB 3.3.

If you do decide to upgrade to phpBB 3.3, make sure you read through Common problems while upgrading to 3.3.0 and also confirm that any extensions that you are using are compatible with phpBB 3.3. The [3.2][3.3][RC] Extension .yml check is the best tool for that job.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
Post Reply

Return to “[3.3.x] Support Forum”