[SOLVED] AJAX error - Something went wrong

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
lzsilva
Registered User
Posts: 16
Joined: Mon May 14, 2012 6:28 pm

[SOLVED] AJAX error - Something went wrong

Post by lzsilva »

Support Request Template
What version of phpBB are you using? phpBB 3.3.0
What is your board's URL? http://www.c4clube.com/forum/
Who do you host your board with? Locaweb (Brazil)
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0.13-PL1
What styles do you currently have installed? Nosebleed
What language(s) is your board currently using? Brazilian Portuguese
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? On "Purge the cache" attempt
Please describe your problem. When I try to "Purge the cache", the ACP give the following error:

"AJAX error
Something went wrong with the request and the server returned an invalid reply."

AJAX error. status: parsererror, message: SyntaxError: JSON.parse: unexpected non-whitespace character after JSON data at line 1 column 1073 of the JSON data core.js:279:13

Generated by SRT Generator

Hello everyone!

I appreciate any help on this.

Notes:

- It happend whatever the theme/style activated (prosilver or Nosebleed;
- It happend whatever language (English or Brazillian Portuguese);
- Cache directory permission is OK";
- I don't know why
- No extensions enabled:

Code: Select all

-bash-3.2$ php73  bin/phpbbcli.php extension:show

Activated
-------


Deactivated
----------

 * phpbb/viglink

Available
----------
The only message that PHP error_log show is (error_reporting=32767):

Code: Select all

[22-May-2020 22:38:07 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:08 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:10 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:10 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:10 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:14 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:17 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:21 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:24 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
[22-May-2020 22:38:26 America/Sao_Paulo] PHP Deprecated:  Directive 'track_errors' is deprecated in Unknown on line 0
Regards,
lzsilva
Attachments
ajax_error.JPG
Last edited by lzsilva on Mon May 25, 2020 4:02 pm, edited 1 time in total.

lzsilva
Registered User
Posts: 16
Joined: Mon May 14, 2012 6:28 pm

Re: AJAX error - Something went wrong

Post by lzsilva »

Bump :(

User avatar
3Di
Former Team Member
Posts: 15415
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: AJAX error - Something went wrong

Post by 3Di »

The track_errors was deprecated in PHP 7.2

In php.ini change track_errors=On to track_errors=Off

If you do not know how just ask your host.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Premium extensions @ The Studio

lzsilva
Registered User
Posts: 16
Joined: Mon May 14, 2012 6:28 pm

Re: AJAX error - Something went wrong

Post by lzsilva »

Problem solved, 3Di gave me a light.

I deleted my php.ini (an old version, from my old hosting service) and everything is fine now.

Regards,
Lincoln

Post Reply

Return to “[3.3.x] Support Forum”