Page 1 of 3

Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 8:51 am
by libralion
Hello,
I try to update from 3.2 to 3.3, but it doesn't work.
I get a 500 error. What can I do?
https://www.libralion.com/forum/install/app.php

Johanna :(

Re: Updating from 3.2 to 3.3

Posted: Sat Aug 08, 2020 8:53 am
by Siguza
Don't add app.php to it, just type mysite.tld/install

Re: Updating from 3.2 to 3.3

Posted: Sat Aug 08, 2020 8:54 am
by libralion
Yes I did that, but then it returns with app.

Re: Updating from 3.2 to 3.3

Posted: Sat Aug 08, 2020 8:59 am
by Siguza
huh. it redirected to app.php for me buy I didn't get a server error

Re: Updating from 3.2 to 3.3

Posted: Sat Aug 08, 2020 9:03 am
by libralion
qcz wrote:
Sat Aug 08, 2020 8:59 am
huh. it redirected to app.php for me buy I didn't get a server error
What do you get then?

Re: Updating from 3.2 to 3.3

Posted: Sat Aug 08, 2020 9:04 am
by Siguza
A welcome screen.

Re: Updating from 3.2 to 3.3

Posted: Sat Aug 08, 2020 9:06 am
by libralion
qcz wrote:
Sat Aug 08, 2020 9:04 am
A welcome screen.
Can you make a screen shot of it?

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 9:10 am
by Siguza
here, I've attached it

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 9:20 am
by libralion
That is really weird. I get a page with a 500 error. :shock:
I don't know what to do. Should I wait?

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 9:30 am
by Tread
In your root htaccess file find

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on
add after

Code: Select all

php_flag display_errors on
Now you should see whats making the 500 error page rather than a white page saying 500 please note the above depends on the server.

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 9:42 am
by libralion
Tread wrote:
Sat Aug 08, 2020 9:30 am
In your root htaccess file find

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on
add after

Code: Select all

php_flag display_errors on
Now you should see whats making the 500 error page rather than a white page saying 500 please note the above depends on the server.
Ok did that.
Than I get this:

"Fatal error: Uncaught TypeError: Argument 2 passed to phpbb\template\twig\extension::__construct() must be an instance of phpbb\template\twig\environment, instance of phpbb\language\language given, called in /home/u9012p6233/domains/libralion.com/public_html/forum/cache/installer/container_edd8661cdbc16adfc424781340313ded.php on line 1941 and defined in /home/u9012p6233/domains/libralion.com/public_html/forum/phpbb/template/twig/extension.php:34 Stack trace: #0 /home/u9012p6233/domains/libralion.com/public_html/forum/cache/installer/container_edd8661cdbc16adfc424781340313ded.php(1941): phpbb\template\twig\extension->__construct(Object(phpbb\template\context), Object(phpbb\language\language)) #1 /home/u9012p6233/domains/libralion.com/public_html/forum/vendor/symfony/dependency-injection/Container.php(306): phpbb_cache_container->getTemplate_Twig_Extensions_PhpbbService() #2 /home/u9012p6233/domains/libralion.com/public_html/forum/phpbb/di/service_collection.php(57): Symfony\Component\DependencyInjection\Container->get('tem in /home/u9012p6233/domains/libralion.com/public_html/forum/phpbb/template/twig/extension.php on line 34"

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 1:33 pm
by Derky
Please try to delete the folders: /cache/production/ and /cache/installer/. Also ensure you've uploaded all files correctly.

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 4:30 pm
by libralion
Derky wrote:
Sat Aug 08, 2020 1:33 pm
Please try to delete the folders: /cache/production/ and /cache/installer/. Also ensure you've uploaded all files correctly.
I did that. no chnage.
And upload the files correctly, you say. Is that in binary mode?

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sat Aug 08, 2020 6:42 pm
by janus_zonstraal
Yes but check also if you upload all the files.

Re: Updating from 3.2 to 3.3 - 500 error

Posted: Sun Aug 09, 2020 5:05 am
by libralion
I did upload all the files, like they said.