Error 3.3.0 ► 3.3.1 database only update

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

Followed full update path as advised:
https://www.phpbb.com/support/docs/en/3 ... date_full/

Chose Update Database only

Stalls after a few seconds with

Code: Select all

Skip “installer.update_filesystem.diff_files” task
Skip “installer.update_filesystem.check_task” task
Skip “installer.obtain_data.update_ftp_settings” task
Skip “installer.obtain_data.update_files” task
Skip “installer.obtain_data.file_updater_method” task
Tried again, same result

I have no extensions

My config.php is

Code: Select all

<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysqli'; //database type it may not be mysql
$dbhost = 'localhost';
$dbport = '';
$dbname = 'kjbkbkbj';
$dbuser = 'nklknlknkln';
$dbpasswd = 'kbkjbklbjj';

$table_prefix = 'phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
//@define('DEBUG', true);
//@define('DEBUG_EXTRA', true);
?>
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

This was suggested as a fix when this happened last time, in 3.2.2
viewtopic.php?f=556&t=2453611

Still valid?
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

Note I did not have prosilver set as the default style since this was not specified in the linked document at top of this thread. Could this be the problem?

I have switch off Cloudflare, no change

I also have Litespeed cache .... could that be an issue? Have not switched that off yet.
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

Renamed folders production and installer in cache to production0 and installer0 to make them invisible to the update process. Tried again, no change.
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
warmweer
Jr. Extension Validator
Posts: 5880
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error 3.3.0 ► 3.3.1 database only update

Post by warmweer »

Did you delete instal_config.php, any migrationsxxx and io_lock.lock from /store?

Added:
and

edit your config.php as follows

Code: Select all

<?php
// phpBB 3.3.x auto-generated configuration file
// Do not change anything in this file!
$dbhost = 'xxx';
$dbport = 'xxx';
$dbname = 'xxx';
$dbuser = 'xxx';
$dbpasswd = 'xxx';
$table_prefix = 'phpbb_';
$dbms = 'phpbb\\db\\driver\\mysqli';
$acm_type = 'phpbb\\cache\\driver\\file';
$phpbb_adm_relative_path = 'adm/';

@define('PHPBB_INSTALLED', true);
@define('PHPBB_ENVIRONMENT', 'production');
//@define('DEBUG_CONTAINER', true);
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

Did all that, got

Code: Select all

Skip “installer.update_filesystem.diff_files” task
Skip “installer.update_filesystem.check_task” task
Skip “installer.obtain_data.update_ftp_settings” task
Skip “installer.obtain_data.update_files” task
Skip “installer.obtain_data.file_updater_method” task
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4255
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: Error 3.3.0 ► 3.3.1 database only update

Post by thecoalman »

mamba wrote:
Tue Aug 11, 2020 9:42 am
I have switch off Cloudflare, no change
CF should not cause any issues but turning on developer mode for upgrade and clearing the cache after upgrade is advisable.
I also have Litespeed cache .... could that be an issue? Have not switched that off yet.
I'm not familiar with Litespeed but I know if you are using Opcache this can cause all kinds of problems with certain configurations. For production you can configure it to not check for new/changed files for increased performance.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

Okay, turned off Litespeed cache and the problem has changed slightly:
phpbb-error.png
phpbb-error.png (10.86 KiB) Viewed 303 times
This was an almost instant result, so no timeout IMO.

This makes it more like the previous instances when these error messages were seen, where timeouts occurred. The fact that it changed with cache change is interesting .....
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

I see you have the instruction
Deactivate all styles except for prosilver
When updating from 3.2.x to 3.3.x
https://www.phpbb.com/support/docs/en/3 ... upgrade32/

Does this also apply to 3.3.0 ► 3.3.1?
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
warmweer
Jr. Extension Validator
Posts: 5880
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error 3.3.0 ► 3.3.1 database only update

Post by warmweer »

mamba wrote:
Tue Aug 11, 2020 10:57 am
I see you have the instruction
Deactivate all styles except for prosilver
When updating from 3.2.x to 3.3.x
https://www.phpbb.com/support/docs/en/3 ... upgrade32/

Does this also apply to 3.3.0 ► 3.3.1?
I think that's almost implicit as the update/grade is probably only tested with prosilver. It wouldn't be the first time an update succeeds with prosilver but error appear when switching to an older version of a different style. (BTW the printscreen shows ">update files". Did you click update database?
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

Yes, I clicked update database, which was the only option I got.

BTW, please don't tell me that instructions are "implicit" when they are not on the page. :roll:
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

I have tried the database update about 7 times now. So what does the "data corruption" message as seen in the screenshot above mean? Am I corrupting my installation?

Oh god this is the 2nd time I've been burned by being an update guinea pig for this phpBB software. When will I learn!
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
warmweer
Jr. Extension Validator
Posts: 5880
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error 3.3.0 ► 3.3.1 database only update

Post by warmweer »

mamba wrote:
Tue Aug 11, 2020 11:09 am
Yes, I clicked update database, which was the only option I got.

BTW, please don't tell me that instructions are "implicit" when they are not on the page. :roll:
By that reasoning the update/upgrade package doesn't need to include a version of prosilver compatible with the update, nor updated language files. And old versions of extensions should also work with new versions of phpBB, right?
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
mamba
Registered User
Posts: 538
Joined: Thu Jan 16, 2003 7:59 pm
Location: Australia

Re: Error 3.3.0 ► 3.3.1 database only update

Post by mamba »

warmweer wrote:
Tue Aug 11, 2020 11:36 am
By that reasoning the update/upgrade package doesn't need to include a version of prosilver compatible with the update, nor updated language files. And old versions of extensions should also work with new versions of phpBB, right?
Look, if people need to switch back from their style to the prosilver style in order for updates to work, then PUT IT IN THE INSTRUCTIONS. Just like was done on other instruction pages for other versions. Amirite?
Using 3.3, PHP version 7.4, MySQL 5.6, Host: HawkHost shared Linux, Style: Prosilver
User avatar
warmweer
Jr. Extension Validator
Posts: 5880
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error 3.3.0 ► 3.3.1 database only update

Post by warmweer »

mamba wrote:
Tue Aug 11, 2020 11:42 am
Look, if people need to switch back from their style to the prosilver style in order for updates to work, the PUT IT IN THE INSTRUCTIONS. Just like was done on other instruction pages for other versions. Amirite?
youcouldberite
With some styles/language packs there is no problem, with others there is/could be.
Should this be mentioned in the update instructions: well, it wouldn't hurt but AFAIAC it's implicit.

Have you tried updating with prosilver as active style when updating?
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Post Reply

Return to “[3.3.x] Support Forum”