Error 500/Error 401 after updating

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Holger
Registered User
Posts: 1844
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Error 500/Error 401 after updating

Post by Holger »

I also get a blank Error 500 page (adm gets an Error 401) when upldating from 3.2.10 to 3.3.1 (automatic update package).
Update went through without problem but returing to the index or admin index gives me blank pages. I also tried to upload a vanilla 3.3.1, but it does not help.

When uploading a backup of the 3.2.10-files (but using the 3.3.1-DB) everything works again, but when I try to disable an Ext I get 500/401 again.

Right now I am restoring the 3.2.10-DB.
User avatar
ssl
Registered User
Posts: 463
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: Error 500/Error 401 after updating

Post by ssl »

Hi
The best way to update is to use the full package, and forget about an automatic update. Source of the problem.
Sorry for my English ... I do my best!
Holger
Registered User
Posts: 1844
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: Error 500/Error 401 after updating

Post by Holger »

Ok, I have a child-theme/template.
That would be the only thing to fix after your suggested "full package"-update?
Or wait, a child-template/theme is fetching the prosilver-items, so there would be nothing to do.

Do I really have to deactivate each and every Ext?
User avatar
david63
Registered User
Posts: 18837
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Error 500/Error 401 after updating

Post by david63 »

Holger wrote:
Sat Aug 15, 2020 12:19 pm
Do I really have to deactivate each and every Ext?
It is entirely up to you - you don't have to disable but are strongly advised to in order to mitigate problems.

You can make it easy by using this - https://www.phpbb.com/customise/db/exte ... xtensions/
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
ssl
Registered User
Posts: 463
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: Error 500/Error 401 after updating

Post by ssl »

Make sure that your extensions will be compatible with the version you install
The best is to deactivate them before the update, then you reactivate them one by one once the update is done.

Yes, you will also have to update your personal style
Sorry for my English ... I do my best!
Holger
Registered User
Posts: 1844
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: Error 500/Error 401 after updating

Post by Holger »

Ok, thank you all!
Ill give it a new try right now!

BTW, the personal style is just some tweaking, referencing to prosilver, no complete style. So maybe there is nothing to do, Ill have to check.
User avatar
ssl
Registered User
Posts: 463
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: Error 500/Error 401 after updating

Post by ssl »

Holger wrote:
Sat Aug 15, 2020 12:30 pm
BTW, the personal style is just some tweaking, referencing to prosilver, no complete style. So maybe there is nothing to do, Ill have to check.
If you are using Prosilver templates for your custom style then they will need to be updated
Sorry for my English ... I do my best!
Holger
Registered User
Posts: 1844
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: Error 500/Error 401 after updating

Post by Holger »

I only tweaked the CSS/images part, I will check if there is some thing to do.

Ah, I just noticed, header and footer too.
Post Reply

Return to “[3.3.x] Support Forum”