Blank page on a post - problem in message_parser.php

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
geneca
Registered User
Posts: 3
Joined: Sat Aug 29, 2020 12:19 pm

Blank page on a post - problem in message_parser.php

Post by geneca »

Hello.

I have installed a PhpBB 3.3.1 forum on a server with Php 7.3.19 and 10.3.23-MariaDB.
The only problem is when I do a POST I have a blank page.
I have of course reinstalled the programs except config.php etc.
The problem is located in this script:
includes / message_parser.php
The following instruction does not run :
$parser = $phpbb_container-> get ('text_formatter.parser');

If anyone had an idea,
Thank you in advance.
Geneca
User avatar
david63
Registered User
Posts: 18614
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Blank page on a post - problem in message_parser.php

Post by david63 »

What do your server error logs report about the problem? - a blank page is often indicative of a suppressed PHP error.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
geneca
Registered User
Posts: 3
Joined: Sat Aug 29, 2020 12:19 pm

Re: Blank page on a post - problem in message_parser.php

Post by geneca »

Hello.
Really I don't have access to the server error logs, but I asked the server support team (they probably don't work on weekends).
I have set exactly the same configuration (programs and database) on my personal server, and here is the error:

Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "". in C:\wamp64\www\FORUM\forum\phpBB3\vendor\symfony\dependency-injection\Container.php on line 331

Geneca
User avatar
david63
Registered User
Posts: 18614
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Blank page on a post - problem in message_parser.php

Post by david63 »

You could try re-uploading the vendor folder as there may be a missing/corrupt file in there
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
geneca
Registered User
Posts: 3
Joined: Sat Aug 29, 2020 12:19 pm

Re: Blank page on a post - problem in message_parser.php

Post by geneca »

Hello.

I have uploaded a new PhpBB 3.3.1 from https://www.phpbb.com/downloads/
copied vendor, and purged the cache.
I have also verified all the ext .yml (@xxxx => '@xxxx').

After the submit, always the page with :

Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "". in C:\wamp64\www\FORUM\forum\phpBB3\vendor\symfony\dependency-injection\Container.php on line 331
Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "". in C:\wamp64\www\FORUM\forum\phpBB3\vendor\symfony\dependency-injection\Container.php on line 331

Call Stack
# Time Memory Function Location
1 0.0012 386512 {main}( ) ...\posting.php:0
2 21.8853 3177576 submit_post( ) ...\posting.php:1542
3 22.0128 3276512 phpbb\notification\manager->add_notifications( ) ...\functions_posting.php:2391
4 22.0178 3288280 phpbb\notification\manager->add_notifications( ) ...\manager.php:266
5 22.0363 3294368 phpbb\notification\manager->add_notifications_for_users( ) ...\manager.php:295
6 22.0406 3296416 phpbb\notification\manager->get_method_class( ) ...\manager.php:390
7 22.0406 3296416 phpbb\notification\manager->load_object( ) ...\manager.php:892
8 22.0406 3296416 phpbb_cache_container->get( ) ...\manager.php:903

BUT THE POST IS WELL PASSED and can be read when I return to see the forum.

Geneca
User avatar
JoshyPHP
Code Contributor
Posts: 1177
Joined: Mon Jul 11, 2011 12:28 am

Re: Blank page on a post - problem in message_parser.php

Post by JoshyPHP »

I wrote the thing that does BBCodes in 3.2+.
Post Reply

Return to “[3.3.x] Support Forum”