ReCaptcha v3 not working anymore

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
fanmail
Registered User
Posts: 271
Joined: Fri Mar 18, 2005 2:33 pm

ReCaptcha v3 not working anymore

Post by fanmail »

Hi,

ReCaptcha v3 not working anymore on the registration page of my message board.

I get a "Could not connect to the reCAPTCHA service. Please check your internet connection and reload to get a reCAPTCHA challenge." message.

1.PNG
.
2.PNG

Support Request Template
What version of phpBB are you using? phpBB 3.1.1
What is your board's URL? http://www.fanmail.biz/mboard/
Who do you host your board with? No answer given
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? prosilver 3.3.1
What language(s) is your board currently using? English
Which database type/version are you using? MariaDB
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? No answer given
Please describe your problem. The registration page does not work anymore: http://www.fanmail.biz/mboard/ucp.php?mode=register
Generated by SRT Generator

Thanks in advance for your help.
User avatar
ssl
Registered User
Posts: 575
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: ReCaptcha v3 not working anymore

Post by ssl »

Hi,
Before using v3, you must modify in the Google settings: https://g.co/recaptcha/v3
You have to remove v2 and redo with v3, so the problem does not come from phpBB.

Once on the page, click on your domain then on "Delete the key" (for v2)
 
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
fanmail
Registered User
Posts: 271
Joined: Fri Mar 18, 2005 2:33 pm

Re: ReCaptcha v3 not working anymore

Post by fanmail »

I removed the V2 and V3. Restart with a new V3 code and it still does not work. I get the same error message.

http://www.fanmail.biz/mboard/ucp.php?mode=register
User avatar
ssl
Registered User
Posts: 575
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: ReCaptcha v3 not working anymore

Post by ssl »

Hum... You talk about this error when we try to register on your forum?

Image
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
fanmail
Registered User
Posts: 271
Joined: Fri Mar 18, 2005 2:33 pm

Re: ReCaptcha v3 not working anymore

Post by fanmail »

Probably not related to the problem :geek:

Please try again :|
User avatar
ssl
Registered User
Posts: 575
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: ReCaptcha v3 not working anymore

Post by ssl »

What version of reCAPTCHA do you use?
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
fanmail
Registered User
Posts: 271
Joined: Fri Mar 18, 2005 2:33 pm

Re: ReCaptcha v3 not working anymore

Post by fanmail »

"ReCaptcha v3 not working"
User avatar
ssl
Registered User
Posts: 575
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: ReCaptcha v3 not working anymore

Post by ssl »

So i repeat, what version of reCAPTCHA do you use? (ex. 1.1.0, 1.1.1, etc...)
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
User avatar
EA117
Registered User
Posts: 2038
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: ReCaptcha v3 not working anymore

Post by EA117 »

fanmail wrote:
Sat Sep 05, 2020 12:30 pm
ReCaptcha v3 not working anymore on the registration page of my message board.

I get a "Could not connect to the reCAPTCHA service. Please check your internet connection and reload to get a reCAPTCHA challenge." message.
Could you try, or have you already tried, disabling the advertisement system for the registration pages? I'm seeing some kind of "refresh" on that page, and the Google API Javascript files being loaded again, in the time between when I'm seeing the reCAPTCHA badge displaying as expected, versus when the reCAPTCHA switches to "could not connect..." Even though I haven't done anything on the registration page yet.

Since nothing about the registration page itself tries to "refresh" in the background right then, I'm just suspecting maybe the advertisement system might have caused something like that as part of an opportunity to change ads.

Or you could wholesale disable all extensions temporarily, just to rule out or confirm whether the symptom remains the same without them.
fanmail
Registered User
Posts: 271
Joined: Fri Mar 18, 2005 2:33 pm

Re: ReCaptcha v3 not working anymore

Post by fanmail »

I removed the banner. The problem remains the same: http://www.fanmail.biz/mboard/ucp.php?mode=register

There is no extension installed

:|
Last edited by fanmail on Sat Sep 05, 2020 8:09 pm, edited 1 time in total.
User avatar
ssl
Registered User
Posts: 575
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: ReCaptcha v3 not working anymore

Post by ssl »

Do you use this version 1.2.4?
https://github.com/google/recaptcha

Is this the same problem with Prosilver style?
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
fanmail
Registered User
Posts: 271
Joined: Fri Mar 18, 2005 2:33 pm

Re: ReCaptcha v3 not working anymore

Post by fanmail »

ssl wrote:
Sat Sep 05, 2020 8:03 pm
Do you use this version 1.2.4?
https://github.com/google/recaptcha

Is this the same problem with Prosilver style?
The ReCapcha version is the one installed on phpBB 3.1.1

:|
User avatar
ssl
Registered User
Posts: 575
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: ReCaptcha v3 not working anymore

Post by ssl »

OK
reCAPTCHA 3 work fine of one of my forum

Image


Are you sure of your configuration?
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
User avatar
ssl
Registered User
Posts: 575
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: ReCaptcha v3 not working anymore

Post by ssl »

It's OK on your forum

Image
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
User avatar
EA117
Registered User
Posts: 2038
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: ReCaptcha v3 not working anymore

Post by EA117 »

ssl wrote:
Sat Sep 05, 2020 9:01 pm
It's OK on your forum
It always started out that way for me. The issue didn't happen until 20+ seconds of just staring blankly at that page. You would see a (re)load of several resources at that point if you were watching the F12 Network view, and by 30+ seconds the page will switch from showing the reCAPTCHA badge as expected to showing the connection error described.

Looks like reCAPTCHA has simply been turned off on the site at this point, when checking again just now.
Post Reply

Return to “[3.3.x] Support Forum”