Cannot add new users after 3.3.1 Upgrade

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
tcprezdcmc
Registered User
Posts: 4
Joined: Sat Sep 12, 2020 7:24 pm

Cannot add new users after 3.3.1 Upgrade

Post by tcprezdcmc »

Since upgrading my forum to 3.3.1, New Users cannot register on the forum. I am using PHP Version 7.2.30 and MYSql 5.7.28. There is a simple error when they click "submit" and a much more detailed error if I'm using the ACP Add User Mod/Ext that I've always used. NEED HELP.

The error if trying to register from the board index is:

SQL ERROR [ mysqli ]

Unknown column 'user_email_hash' in 'field list' [1054]



The error if I try to add a user from the ACP Add User in the ACP is:

Code: Select all

SQL ERROR [ mysqli ]

Unknown column 'user_email_hash' in 'field list' [1054]

SQL

SELECT user_email_hash FROM phpbb_users WHERE user_email_hash = 125933421219

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 996
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/includes/functions_user.php
LINE: 1917
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/includes/functions_user.php
LINE: 1528
CALL: validate_user_email()

FILE: [ROOT]/ext/phpbbmodders/adduser/acp/adduser_module.php
LINE: 144
CALL: validate_data()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: phpbbmodders\adduser\acp\adduser_module->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
bevanc
Registered User
Posts: 11
Joined: Fri Feb 13, 2015 2:29 am

Re: Cannot add new users after 3.3.1 Upgrade

Post by bevanc »

We had the same unknown column email_hash error.
This was one response:
"Continued reference to user_email_hash can also simply be an extension that is otherwise working on phpBB 3.3.x, but was not actually updated for compatibility to phpBB 3.3.x. One such extension identified earlier was "OneAll social login", although that's not to say it's the only one. Any phpBB 3.2.x extension could have required a query which involved the user_email_hash column, if handling an action related to user account information, and would still be attempting to do this on phpBB 3.3.x where the column no longer exists.

So also try disabling Gallery, and any extension other than Gallery which may now be installed, to see if the issue persists. Before continuing on the assumption that it could also be a damaged upgrade or incorrect set of phpBB files."

Cheers, Bevan
User avatar
3Di
Former Team Member
Posts: 16032
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Cannot add new users after 3.3.1 Upgrade

Post by 3Di »

tcprezdcmc wrote:
Sat Sep 12, 2020 7:38 pm
FILE: [ROOT]/ext/phpbbmodders/adduser/acp/adduser_module.php
Seems like an extension is the culprit infact. How did you upgrade phpBB and from which version?
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
Looking for a specific feature or alternative option? We will rock you! 🚀
tcprezdcmc
Registered User
Posts: 4
Joined: Sat Sep 12, 2020 7:24 pm

Re: Cannot add new users after 3.3.1 Upgrade

Post by tcprezdcmc »

Thanks all.
It was an overdue upgrade. I upgraded from 3.2 (early) to 3.3.1. I followed all the upgrade steps to the letter. I researched the hell out of this before posting and did see the reference to the extensions issue. I've disabled all of them and still have the same problem. I have not yet actually deleted the extension folders from the server, but not sure if that will help. I feel like I'm running the most up to date SQL versions from the server side, and everything else on the board works perfectly. Am I missing something? I really do not want to roll back to my last version of the bb as I was having some issues with double posts showing up and that issue has been resolved with the upgrade.
Thanks for the insight.
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4910
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Cannot add new users after 3.3.1 Upgrade

Post by HiFiKabin »

tcprezdcmc wrote:
Sun Sep 13, 2020 3:33 pm
I have not yet actually deleted the extension folders from the server, but not sure if that will help.
It will not help at all, in fact it will make things far far worse. Extensions need to be disabled, and then have their data deleted BEFORE deleting the files from the server.

As it appears that it is an extension issue, you need to disable all of your extensions and see if that solves the issue.

If you are still having problems, then please fill out the Support Request Template and post it back here to enable us to assist you better.
User avatar
RMcGirr83
Former Team Member
Posts: 21472
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: Cannot add new users after 3.3.1 Upgrade

Post by RMcGirr83 »

It would seem your forum has includes/functions_user.php from 3.2 and not from 3.3.1. How did you update?

FYI, it has nothing to do with the add user extension, as you were told, as that simply uses the validate_data function from functions_user.php file. Whoever told you that is simply wrong. There are 4 changes to that file from 3.2 to 3.3.1, two of them being removing user_email_hash.

I would overwrite the includes/functions_user.php file on your server from a fresh download of 3.3.1 and see if the issue still persists or comparing them using a tool such as winmerge. If the issue doesn't persist, as I expect it won't, then I would look at other files as it would seem you have an incomplete update from 3.2 to 3.3.1.
Appreciate the extensions/mods/support then buy me a beerImage
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
tcprezdcmc
Registered User
Posts: 4
Joined: Sat Sep 12, 2020 7:24 pm

Re: Cannot add new users after 3.3.1 Upgrade

Post by tcprezdcmc »

Thank you. I'll try the suggestions and then repost.
tcprezdcmc
Registered User
Posts: 4
Joined: Sat Sep 12, 2020 7:24 pm

Re: Cannot add new users after 3.3.1 Upgrade

Post by tcprezdcmc »

The repair suggested by RMcGrr83 worked perfectly. Thank you for taking the time and digging into it. I appreciate it. And thank you to the rest for the insight, including HiFiKabin.

Respects.
Post Reply

Return to “[3.3.x] Support Forum”