upgrade phpbb 1.12.6 to newest version

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
marcinzmyslowski
Registered User
Posts: 14
Joined: Tue Nov 03, 2020 3:17 pm

upgrade phpbb 1.12.6 to newest version

Post by marcinzmyslowski »

Hello,

My client asked me to upgrade old out-of-date phpbb forum to newest version.

I run a mysql query:

SELECT config_value
FROM phpbb_config
WHERE config_name = 'version'

and it returned:

1.12.6

Questions:
1) How can I upgrade this phpbb version to newest version?
2) Do I need to use some converters while migration to new version? Where can I donwload such converter
3) My client wants to keep default forum style named as: Akagahara. Is it possible to use it on newest version of phpbb?

Please help me. I have no idea how to do it, because I don`t have any experience with it?

Regards
Marcin
User avatar
warmweer
Jr. Extension Validator
Posts: 5835
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: upgrade phpbb 1.12.6 to newest version

Post by warmweer »

marcinzmyslowski wrote:
Tue Nov 03, 2020 3:22 pm
....
1.12.6

Questions:
1) How can I upgrade this phpbb version to newest version?
phpBB version 1.12.6 ??
How old is that and on which php version is that running?

I'm fairly confident there's no "normal" upgrade possible to 3.0 and higher. I even doubt that an upgrade (or convertor) to phpBB 2 is available.

If the phpBB team can't point you to a solution, you could try http://www.phpbb2refugees.com/ .
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
david63
Registered User
Posts: 18582
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: upgrade phpbb 1.12.6 to newest version

Post by david63 »

There never was a phpBB 1.12.6 version.

A link to the board may help identify the version
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
warmweer
Jr. Extension Validator
Posts: 5835
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: upgrade phpbb 1.12.6 to newest version

Post by warmweer »

david63 wrote:
Wed Nov 04, 2020 9:53 am
There never was a phpBB 1.12.6 version.

A link to the board may help identify the version
The thought crossed my mind but I only came into existence as of phpBB 2.0.2. ;)
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
david63
Registered User
Posts: 18582
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: upgrade phpbb 1.12.6 to newest version

Post by david63 »

It may be a customised version - I found this phpBB by Przemo wersja 1.12.8 which I believe is Polish.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
marcinzmyslowski
Registered User
Posts: 14
Joined: Tue Nov 03, 2020 3:17 pm

Re: upgrade phpbb 1.12.6 to newest version

Post by marcinzmyslowski »

Yes, I am Polish, and this version is also Polish.
marcinzmyslowski
Registered User
Posts: 14
Joined: Tue Nov 03, 2020 3:17 pm

Re: upgrade phpbb 1.12.6 to newest version

Post by marcinzmyslowski »

As I wrote before, it is a Polish version of phpbb.

Can you give me tips what I can do with it? How can I upgrade it to new version?
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4253
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: upgrade phpbb 1.12.6 to newest version

Post by thecoalman »

Please don't double post marcinzmyslowski, edit previous post if no one has replied in 6 hours.

Post a link to the forum or you can send to me a link in PM to help determine what version you are using.

edit: As noted above this looks like it may be fork of phpBB and I see post in regards to it from 2008. The problem is that is only a year after release of 3.X so it could be 2.X. What you can try and do is see if either of these two URL's open.

yourdomain.com/forum_root/styles/prosilver/style.cfg
yourdomain.com/forum_root/styles/subsilver/style.cfg

forum_root needs to be directory phpBB is installed in, if it's root of domain you don't need it. That may or may not work but if they do open they may list the original phpBB version they are used for.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
marcinzmyslowski
Registered User
Posts: 14
Joined: Tue Nov 03, 2020 3:17 pm

Re: upgrade phpbb 1.12.6 to newest version

Post by marcinzmyslowski »

I am not able to delete one of my double posts.:( I don`t see such delete option when I try to edit it.

I tried the following links:

yourdomain.com/forum_root/styles/prosilver/style.cfg
yourdomain.com/forum_root/styles/subsilver/style.cfg
yourdomain.com/styles/prosilver/style.cfg
yourdomain.com/styles/subsilver/style.cfg
yourdomain.com/styles/

but none of them works. So these links don`t work on the domain of my client. There no such files and directories.

forum_root is not necessary in my case, because all phpbb files are inside the root folder.

subSilver.cfg file is inside yourdomain.com/templates/subSilver/
Akagahara.cfg style which my clients wants to keep in upgraded version of phpbb is inside yourdomain.com/templates/Akagahara folder.

As you mentioned before, the files can be from 2008 or similiar, because my client told me that they never be upgraded and the forum has been existing very long time.
User avatar
warmweer
Jr. Extension Validator
Posts: 5835
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: upgrade phpbb 1.12.6 to newest version

Post by warmweer »

marcinzmyslowski wrote:
Wed Nov 04, 2020 11:48 am
subSilver.cfg file is inside yourdomain.com/templates/subSilver/
Akagahara.cfg style which my clients wants to keep in upgraded version of phpbb is inside yourdomain.com/templates/Akagahara folder.
So browse to those .cfg files and report the version mentioned.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68296
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: upgrade phpbb 1.12.6 to newest version

Post by Lumpy Burgertushie »

they won't be able to keep the style unless someone recreates it for phpbb 3.1.x
there would be no way to simply upgrade that style. every single line of code would probably have to be completelly rewritten.

best thing would be to find a current style with similar colors etc. and customize it etc.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4253
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: upgrade phpbb 1.12.6 to newest version

Post by thecoalman »

marcinzmyslowski wrote:
Wed Nov 04, 2020 11:48 am
subSilver.cfg file is inside yourdomain.com/templates/subSilver/
This AFAIK would indicate it's based on some phpBB 2 version.

If you don't have local server installed then install one so you can test upgrade. You are going to need oldder version of PHP on local server so try installing one with php 5.3 5.2, you may even earlier version but I don't remember.

Try running test conversion using phpBB 3.0, unzip the download and open docs folder. There is instructions there on how to convert from phpBB 2 phpBB3 . All versions of phpBB3 3.0.+ have the the conversion script for phpBB2 >> phpBB3 but the reason I'm suggesting going to 3.0 first is if problems occur you are more likely to find solutions from old documentation where someone has had same issue with the same thing you have.

See where you get to with that. Once you get to working 3.0 version it should be easy from there.

As Lumpy mentioned there would be no way to keep current style. You would need to recreate it from scratch which is very big job. There is likely custom style that is close and you can tweak that.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
User avatar
david63
Registered User
Posts: 18582
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: upgrade phpbb 1.12.6 to newest version

Post by david63 »

thecoalman wrote:
Wed Nov 04, 2020 12:34 pm
This AFAIK would indicate it's based on some phpBB 2 version.
A version of subSilver was available for versions of phpBB 3.0.x and the earlier versions of phpBB 3.1
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4253
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: upgrade phpbb 1.12.6 to newest version

Post by thecoalman »

david63 wrote:
Wed Nov 04, 2020 12:41 pm
A version of subSilver was available for versions of phpBB 3.0.x and the earlier versions of phpBB 3.1
I'm aware of that but it wouldn't be in a directory named template. ;)
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
User avatar
warmweer
Jr. Extension Validator
Posts: 5835
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: upgrade phpbb 1.12.6 to newest version

Post by warmweer »

thecoalman wrote:
Wed Nov 04, 2020 12:34 pm
If you don't have local server installed then install one so you can test upgrade. You are going to need oldder version of PHP on local server so try installing one with php 5.3 5.2, you may even earlier version but I don't remember.
AFAIR phpBB 2 needed a minimum op php 4 something. phpBB 1.22 might need a lower version (although I don't think so). What does some in to play may be the highest php version compatible and php5 was only released in 2004 (so I wouldn't be surprised if phpBB 1.22 won't function with that.

In my phpBB 2 days I used XAMPP and Easyphp (I found easyphp easier to install but used both successfully)

old XAMPP versions : https://xampp.en.uptodown.com/windows/versions
old Easyphp versions : https://phpsources.net/scripts/php/easy ... 78_easyphp
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Post Reply

Return to “[3.3.x] Support Forum”